Results 1 to 3 of 3

Thread: Problem with Python 3.6 dependencies

  1. #1

    Default Problem with Python 3.6 dependencies

    Hi, I'm having some issues trying to update my system.

    I usually keep it fairly up to date, I run "sudo zypper dup" at least two or three times a week.

    I'm experiencing some problems tied to python packages, as you can see from the output:

    Code:
    ~> LANG=C sudo zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    2 Problems:
    Problem: python3-pykwalify-1.6.0-2.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    Problem: borgmatic-1.2.14-1.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
    
    Problem: python3-pykwalify-1.6.0-2.1.noarch requires python(abi) = 3.6, but this requirement cannot be provided
      deleted providers: python3-base-3.6.5-3.3.x86_64
     Solution 1: deinstallation of python3-pykwalify-1.6.0-2.1.noarch
     Solution 2: keep obsolete python3-base-3.6.5-3.3.x86_64
     Solution 3: break python3-pykwalify-1.6.0-2.1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
    
    I also keep my repo list fairly clean and small:

    Code:
    ~> LANG=C sudo zypper lr -d
    #  | Alias                            | Name                        | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                            | Service
    ---+----------------------------------+-----------------------------+---------+-----------+---------+----------+----------+--------------------------------------------------------------------------------+--------
     1 | code                             | Visual Studio Code          | Yes     | (r ) Yes  | No      |   99     | rpm-md   | https://packages.microsoft.com/yumrepos/vscode                                 |        
     2 | http-opensuse-guide.org-5b67ba5e | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                            |        
     3 | localrepo                        | localrepo                   | Yes     | ( p) Yes  | Yes     |   99     | plaindir | dir:///home/localrepo/                                                         |        
     4 | packman                          | packman                     | Yes     | (r ) Yes  | Yes     |   90     | rpm-md   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/            |        
     5 | repo-debug                       | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/debug/tumbleweed/repo/oss/                        |        
     6 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/tumbleweed/repo/non-oss/                          |        
     7 | repo-oss                         | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/tumbleweed/repo/oss/                              |        
     8 | repo-source                      | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/source/tumbleweed/repo/oss/                       |        
     9 | repo-update                      | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/tumbleweed/                                |        
    10 | sekhemty                         | sekhemty                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://download.opensuse.org/repositories/home:/sekhemty/openSUSE_Tumbleweed/ |        
    11 | skype-stable                     | skype (stable)              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://repo.skype.com/rpm/stable/                                             |
    As you can see, just Packman, a couple of single app repos (VS Code and Skype) and a personal home repo with only few packages, that don't seem to be involved in this problem; "borgmatic" and "pykwalify" are both from the official repo.

    How can I solve this?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,583
    Blog Entries
    14

    Default Re: Problem with Python 3.6 dependencies

    Just be patient for a couple of days. TW itself has been updated to python 3.7, but not all packages have been built with that yet.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Problem with Python 3.6 dependencies

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •