Results 1 to 6 of 6

Thread: MariaDB doesn't start on boot

  1. #1

    Default MariaDB doesn't start on boot

    The title says it all but I should add that of course I have the service turned on in services to start on boot.

    This used to work so some upgrade somewhere has caused this to break. Once my system has booted I can start the DB no problem with
    Code:
    service mariadb start
    Does anyone have any idea on how I could fix this so it starts on boot again like it used to and should?
    I also ran
    Code:
    systemctl unmask mariadb
    which didn't help.

  2. #2
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    341

    Default Re: MariaDB doesn't start on boot

    I use
    Code:
    systemctl enable mysqld
    I do have mariadb and you can change mysqld but I have always used this (think its a link to mariadb). It's a habit I've never got round to changing.
    Pete

  3. #3

    Default Re: MariaDB doesn't start on boot

    Quote Originally Posted by peteh100 View Post
    I use
    Code:
    systemctl enable mysqld
    I do have mariadb and you can change mysqld but I have always used this (think its a link to mariadb). It's a habit I've never got round to changing.
    Interesting I did a
    Code:
    systemctl is-enabled mariadb
    and because it came back as enabled I didn't bother to do a
    Code:
    systemctl enable mariadb
    . However, did it just now anyway and it came back with Created symlink
    Code:
    /etc/systemd/system/multi-user.target.wants/mariadb.service → /usr/lib/systemd/system/mariadb.service.
    so perhaps that link was missing.

  4. #4
    Join Date
    Sep 2012
    Posts
    5,203

    Default Re: MariaDB doesn't start on boot

    Quote Originally Posted by Reg_gie View Post
    Interesting I did a
    Code:
    systemctl is-enabled mariadb
    and because it came back as enabled
    As far as I see mariadb defines multiple links in [Install] section:
    Code:
    [Install]
    WantedBy=multi-user.target
    Alias=mysql.service
    "systemctl is-enabled" returns success if any one link is present.

  5. #5

    Default Re: MariaDB doesn't start on boot

    Well, that fixed it.

    Thanks peteh100.

  6. #6
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    341

    Default Re: MariaDB doesn't start on boot

    Quote Originally Posted by Reg_gie View Post
    Well, that fixed it.

    Thanks peteh100.
    You're welcome. Glad I could help.
    Pete

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •