Results 1 to 6 of 6

Thread: Missing dependencies

  1. #1

    Exclamation Missing dependencies

    After the last update of OpenSuse Tumbleweed, when I try to upgrade some packages I receive row with missing dependencies :

    zypper install -y ibus-1.5.19-231.4.x86_64 command-not-found-0.2.1+20181004.20a0aae-96.2.noarch scout-0.2.1+20181004.20a0aae-96.2.noarch lutris-0.4.23-6.1.noarch


    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    4 Problems:
    Problem: nothing provides python(abi) = 3.6 needed by lutris-0.4.23-6.1.noarch
    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Problem: nothing provides python(abi) = 3.6 needed by ibus-1.5.19-231.4.x86_64


    Problem: nothing provides python(abi) = 3.6 needed by lutris-0.4.23-6.1.noarch
    Solution 1: do not install lutris-0.4.23-6.1.noarch
    Solution 2: break lutris-0.4.23-6.1.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 1: do not install scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 2: break scout-0.2.1+20181004.20a0aae-96.2.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 1: do not install command-not-found-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 2: break scout-0.2.1+20181004.20a0aae-96.2.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by ibus-1.5.19-231.4.x86_64
    Solution 1: do not install ibus-1.5.19-231.4.x86_64
    Solution 2: break ibus-1.5.19-231.4.x86_64 by ignoring some of its dependencies


    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...


    Nothing to do.

    How I need to fix this issue?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,806
    Blog Entries
    14

    Default Re: Missing dependencies

    Remove those Staging repos, as already posted in the other thread, and run zypper dup first.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Thumbs up Re: Missing dependencies

    I change the vendor to OpenSuse Official chanel.

    Thank you for your assitences.

  4. #4

    Thumbs up Re: Missing dependencies

    # zypper install -y ibus-1.5.19-231.4.x86_64 command-not-found-0.2.1+20181004.20a0aae-96.2.noarch scout-0.2.1+20181004.20a0aae-96.2.noarch lutris-0.4.23-6.1.noarch

    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    4 Problems:
    Problem: nothing provides python(abi) = 3.6 needed by lutris-0.4.23-6.1.noarch
    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Problem: nothing provides python(abi) = 3.6 needed by ibus-1.5.19-231.4.x86_64


    Problem: nothing provides python(abi) = 3.6 needed by lutris-0.4.23-6.1.noarch
    Solution 1: do not install lutris-0.4.23-6.1.noarch
    Solution 2: break lutris-0.4.23-6.1.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 1: do not install scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 2: break scout-0.2.1+20181004.20a0aae-96.2.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by scout-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 1: do not install command-not-found-0.2.1+20181004.20a0aae-96.2.noarch
    Solution 2: break scout-0.2.1+20181004.20a0aae-96.2.noarch by ignoring some of its dependencies


    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1


    Problem: nothing provides python(abi) = 3.6 needed by ibus-1.5.19-231.4.x86_64
    Solution 1: do not install ibus-1.5.19-231.4.x86_64
    Solution 2: break ibus-1.5.19-231.4.x86_64 by ignoring some of its dependencies


    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...


    Nothing to do.

    How I can fix this issue?


    I change the vendor to official channel of OpenSuse Tumbleweed.

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    153

    Default Re: Missing dependencies

    Those packages you have are not from the official Tumbleweed repo, therefore you have the dependency issues. The official packages install without an issue after the latest update.

  6. #6

    Thumbs up Re: Missing dependencies

    Thank you Knurphtandswannemafor your assitences. Everything at this moment is working as usual.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •