Results 1 to 4 of 4

Thread: speech-dispatcher does everything twice

  1. #1

    Default speech-dispatcher does everything twice

    hi

    been installing tumbleweed on a new PC this weekend based on a MSI B450M with a AMD/ATI RX570
    Everything went surprisingly easy and have only really run into 1 issue which is related to speech--dispatcher and I think Pulse.


    alsa-info: http://www.alsa-project.org/db/?f=2e...0a659e3d9ad93b

    even something as simple as spd-say "hello" will be spoken twice, the first time really bad quality and the 2nd time (starts about 1sec later) more normal.
    any audio playing at that time will also get messed up till speech-dispatcher is unloaded (about 5sec after).
    I set speech-dispatcher to log level 5 on this new PC and an older one where it works fine and the log is identical, there is no indication that it's doing its job twice.
    ps shows the exact same speed-dispatcher processes running on both machines, so there is nothing double there either:

    Code:
    ps -ef | grep spee
    root       8930     1  8 18:13 pts/0    00:00:00  /usr/lib64/speech-dispatcher-modules/sd_espeak-ng  /etc/speech-dispatcher/modules/espeak-ng.conf
    root      8936     1  0 18:13 pts/0    00:00:00 /usr/lib64/speech-dispatcher-modules/sd_dummy
    root       8939     1  0 18:13 ?        00:00:00 /usr/bin/speech-dispatcher  --spawn --communication-method unix_socket --socket-path  /run/user/1000/speech-dispatcher/speechd.sock
    so that really makes me think PulseAudio has something to do with this and the fact there is the onboard sounds (which I use) and the RX570 hdmi build in sound (which I don't use), like it sends to both or something.

    tried blacklisting the driver for the RX570 to see if that helps but that is no option as both use the same intel one and no idea if you can make pulse ignore a specific device

    thanks for any idea or help you can give me

  2. #2

    Default Re: speech-dispatcher does everything twice

    edit: doing the spd-say "hello" makes 2 instances of speech-dispatcher show up list of sound applications, appear at the same time and disappear at the same time

  3. #3

    Default Re: speech-dispatcher does everything twice

    I changed the order of the alsa devices to see if that made a difference in 50-sound.cf

    options snd-hda-intel id=Generic index=0
    options snd-hda-intel id=HDMI index=1

    and after that that good output from spd-say comes first and the bad/garbled comes second.
    so I figured I be smart and do this:

    options snd-hda-intel id=Generic enable=1 index=0
    options snd-hda-intel id=HDMI enable=0 index=1

    the hdmi is no longer listed now in alsa but weirdly enough the bad/garbled comes first again and the good one second.

  4. #4

    Default Re: speech-dispatcher does everything twice

    if anybody is running into this in the future, the solution is/was

    Code:
    vi /etc/pulse/default.pa
    
    load-module module-udev-detect tsched=0
    adding the red part.... don't ask me why.... but all is fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •