Page 5 of 5 FirstFirst ... 345
Results 41 to 45 of 45

Thread: Leap 15, the Vista version of Opensuse ?

  1. #41
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    70

    Default Re: Leap 15, the Vista version of Opensuse ?

    Quote Originally Posted by mrmazda View Post
    The link in your clipboard was all you needed to paste here, either of those two URLs provides what I was asking for. Sorry for botching my instructions.
    No problems. When my mind is set on a problem. I go the core forgetting some detail too. I understand.
    Open-suse Leap 15
    Cinnamon

  2. #42
    -G- NNTP User

    Default Re: Leap 15, the Vista version of Opensuse ?

    On Sat, 02 Feb 2019 01:26:03 +0000, Asimov wrote:

    > Under 42,3 everything was working perfectly. Now, i got sound problem
    > went i used the sleep mode. And the core seems to have a hard time
    > following the mouse sometimes. Now my last update has erased windows
    > from my Grub. That the kind of thing that you must expect under
    > Tumbleweed. But not Leap.
    >
    > What is the fix for Grub ?


    I have Leap 15.0 installed in 6 different machines. Some are UEFI, some
    are MBR booting, all with different multiboot OSs, Leap 15 + one of
    these: XP, Win7, Win8, Win10, old_opensuse_version.
    In ALL the machines, whenever there is a kernel update (that means every
    time), I lose the 'foreign OS', regardless of the booting install type or
    version.

    I have been able to recreate the right grub by executing:
    # os-prober
    # grub2-mkconfig -o /boot/grub2/grub.cfg

    but I wonder why this keeps happening.
    Shouldn't the grup recreation step be included in the kernel update
    procedure?
    This has been happening for quite some time now, and I was surprised that
    nobody else has reported this problem.
    Cheers

    -G-

  3. #43
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,200
    Blog Entries
    3

    Default Re: Leap 15, the Vista version of Opensuse ?

    Quote Originally Posted by -G- View Post
    I have Leap 15.0 installed in 6 different machines. Some are UEFI, some
    are MBR booting, all with different multiboot OSs, Leap 15 + one of
    these: XP, Win7, Win8, Win10, old_opensuse_version.
    In ALL the machines, whenever there is a kernel update (that means every
    time), I lose the 'foreign OS', regardless of the booting install type or
    version.
    That's not happening here. And yes, like you, I have several computers with Leap 15.0 installed.
    I have been able to recreate the right grub by executing:
    # os-prober
    # grub2-mkconfig -o /boot/grub2/grub.cfg
    That is supposed to be run automatically.

    What's the output from:
    Code:
    grep LOADER_TYPE /etc/sysconfig/bootloader
    I'm guessing that's wrong or not set. For me, the output is
    Code:
    LOADER_TYPE="grub2"
    (or that will be "grub2-efi" on the UEFI systems). The system depends on that to properly update the bootloader.

    Did you maybe install your Leap 15.0 systems with the "gecko-linux" install? I think that's a bug in their installer.

    If I'm right about that LOADER_TYPE setting being wrong or missing, then the easy fix is to go into Yast bootloader and properly configure booting there. And that will set the sysconfig variables correctly.
    openSUSE Leap 15.0; KDE Plasma 5;

  4. #44
    -G- NNTP User

    Default Re: Leap 15, the Vista version of Opensuse ?

    On Sat, 16 Feb 2019 14:36:03 +0000, nrickert wrote:
    > That's not happening here. And yes, like you, I have several computers
    > with Leap 15.0 installed.
    > What's the output from:
    >
    > Code:
    > --------------------
    > grep LOADER_TYPE /etc/sysconfig/bootloader
    > --------------------
    >
    >
    > I'm guessing that's wrong or not set. For me, the output is
    >
    > Code:
    > --------------------
    > LOADER_TYPE="grub2"
    > --------------------


    In this machine (it has an old XP install and also an old opensuse
    install appart from Leap 15.0) it is the same as you posted.
    Code:
    --------------------
    LOADER_TYPE="grub2"
    --------------------

    > Did you maybe install your Leap 15.0 systems with the "gecko-linux"
    > install? I think that's a bug in their installer.


    Not sure what is the gecko-linux, sorry... I downloaded the ISO and put
    it in a usb stick with the suse studio imagewriter.

    All were installed from that same usb drive (no other problems with that
    installation, and all of them had originally detected the foreign OS
    properly. The issue starts after, with the kernel updates.
    I find it very strange that all the 6 machines are behaving like this,
    but obviously there haven't been many reports of this, I guess.
    Thank you

    -G-


  5. #45
    -G- NNTP User

    Default Re: Leap 15, the Vista version of Opensuse ?

    Well, there was a kernel update yesterday. The foreign OS detection was
    successful and grub shows all the right entries.
    It seems that somebody fixed this. Thanks to whoever did that.

    Cheers

    -G-


Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •