Page 5 of 5 FirstFirst ... 345
Results 41 to 43 of 43

Thread: Can't build on Obs

  1. #41
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,452
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    I'm almost ok...

    but I'd like to start postgresql when installing skylendar, with a declaration in skylendar.spec such as:

    Code:
    %post
    /sbin/ldconfig
    systemctl start postgres
    of course it doesn't work. systemctl no found
    Hi
    That's a bad idea for security/stability reasons, just add a post install note for starting it, or a start script that will start/check it's running?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #42

    Default Re: Can't build on Obs

    I can do without systemctl, but now I want to create an assocaition between the skif mime type and the skylendar application. Before, it was done with the skif.desktop file, but nowadays it doesn't work anymore. It seems to have been replaced by an entry in the file gnome-mimeapps.list: how to craete such an association in the .spec file ?

  3. #43
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,452
    Blog Entries
    15

    Default Re: Can't build on Obs

    On Thu 14 Feb 2019 05:16:03 PM CST, lader1 wrote:

    I can do without systemctl, but now I want to create an assocaition
    between the *skif* mime type and the skylendar application. Before, it
    was done with the skif.desktop file, but nowadays it doesn't work
    anymore. It seems to have been replaced by an entry in the file
    gnome-mimeapps.list: how to craete such an association in the .spec file
    ?


    Hi
    It should be installing src/skif.xml in /usr/share/mime/packages/ but
    it's installing skif.desktop instead.... that needs to be fixed and
    should sort out the problem.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •