Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Can't build on Obs

  1. #21

    Default Re: Can't build on Obs

    after several attempts even without patches, I always get the same error, such as :
    [ 100s] CMake Error: The source directory "/home/abuild/rpmbuild/BUILD/skylendar/#" does not exist.

    because I have no access to the underlying structure, and don't know what's going on. I still flounder in the mud...

  2. #22
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,891

    Default AW: Can't build on Obs

    Set up your build environment in your /home:
    Code:
    $ mkdir -p ~/rpmbuild/{BUILD,BUILDROOT,OTHER,RPMS,SOURCES,SPECS,SRPMS}
    Code:
    $ echo '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros
    The $ means: execute it as User.

    Copy your source to SOURCES, the spec-File to SPEC.
    Goto the SPEC Directory and execute as User:
    Code:
    rpmbuild -ba --noclean File.spec
    Then the Source will expand to BUILD, the Files from the builded rpm will be installed in BUILDROOT, the builded rpms to RPMS, the src.rpm to SRPMS.
    If something is going wrong, you can follow it better as on OBS.
    And all is done as User, not as root.

    AT least, you have to install the rpms with zypper as root.

  3. #23
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: AW: Can't build on Obs

    Quote Originally Posted by Sauerland View Post
    Set up your build environment in your /home:
    Code:
    $ mkdir -p ~/rpmbuild/{BUILD,BUILDROOT,OTHER,RPMS,SOURCES,SPECS,SRPMS}
    Code:
    $ echo '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros
    The $ means: execute it as User.

    Copy your source to SOURCES, the spec-File to SPEC.
    Goto the SPEC Directory and execute as User:
    Code:
    rpmbuild -ba --noclean File.spec
    Then the Source will expand to BUILD, the Files from the builded rpm will be installed in BUILDROOT, the builded rpms to RPMS, the src.rpm to SRPMS.
    If something is going wrong, you can follow it better as on OBS.
    And all is done as User, not as root.

    AT least, you have to install the rpms with zypper as root.
    Hi
    AFAIK, user is using osc locally to build not rpmbuild....?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #24
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    after several attempts even without patches, I always get the same error, such as :
    [ 100s] CMake Error: The source directory "/home/abuild/rpmbuild/BUILD/skylendar/#" does not exist.

    because I have no access to the underlying structure, and don't know what's going on. I still flounder in the mud...
    Hi
    Because you need to use the -c option in %prep....

    Code:
    %setup -c -q -n %{name}-%{version}
    Then in %build use;
    Code:
    %cmake -DCMAKE_BUILD_Type=Release ../%{name}/
    The reason is the %cmake macro sets up the build directory, therefore the src files are relative to this so always ../ and because the way the tarball extracts you need to add the name as well....

    On your local system you can browse the home/abuild directory to see what it's doing....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #25

    Default Re: AW: Can't build on Obs

    Quote Originally Posted by Sauerland View Post
    Set up your build environment in your /home:
    Code:
    $ mkdir -p ~/rpmbuild/{BUILD,BUILDROOT,OTHER,RPMS,SOURCES,SPECS,SRPMS}
    Code:
    $ echo '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros
    The $ means: execute it as User.

    Copy your source to SOURCES, the spec-File to SPEC.
    Goto the SPEC Directory and execute as User:
    Code:
    rpmbuild -ba --noclean File.spec
    Then the Source will expand to BUILD, the Files from the builded rpm will be installed in BUILDROOT, the builded rpms to RPMS, the src.rpm to SRPMS.
    If something is going wrong, you can follow it better as on OBS.
    And all is done as User, not as root.

    AT least, you have to install the rpms with zypper as root.
    Thx for the tip. Will try, but I'm doing several tasks at the same moment. That's why I'm a little confused...

  6. #26

    Default Re: Can't build on Obs

    After hours of tedious attempts, I'm already ok, but last glitch, rpmbuild can't find:
    /home/abuild/rpmbuild/SOURCES/skylendar-4.1nn-74.1.tar.xz

    whereas I have downloaded: skylendar-4.1nn-1.tar.xz

    where 74 is the current obs release number and -1 the provided release.

    I'm tired....

  7. #27
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,891

    Default AW: Can't build on Obs

    Without spec-file, nobody can help......
    Also the whole error.....

  8. #28
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    After hours of tedious attempts, I'm already ok, but last glitch, rpmbuild can't find:
    /home/abuild/rpmbuild/SOURCES/skylendar-4.1nn-74.1.tar.xz

    whereas I have downloaded: skylendar-4.1nn-1.tar.xz

    where 74 is the current obs release number and -1 the provided release.

    I'm tired....
    Hi
    Almost there...wakey wakey

    So line 25 of the spec file, remove the %{release} also set line 20 (Release) to zero as OBS takes care of this.

    Code:
    Line 20: Release:        1
    
    should be
    
    Line 20: Release:        0
    
    Line 25: Source0:        https://cfhcable.dl.sourceforge.net/project/skylendar/%{name}-%{version}-%{release}.tar.xz
    
    should be
    
    Line 25: Source0:        https://cfhcable.dl.sourceforge.net/project/skylendar/%{name}-%{version}.tar.xz
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #29

    Default Re: Can't build on Obs

    Ok, I got something, for x86_64, but gcc yields an error for i586 in astrosql.cpp

    sighhhhhhhhh again

  10. #30

    Default Re: Can't build on Obs

    Ok, I got something!

    Now, what should I do with my rpm packages ?

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •