Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 50

Thread: Can't build on Obs

  1. #11
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It needed to create the directory first (-c) and change to it and unpack...

    Here you go: https://build.opensuse.org/request/show/670647

    It's building, but failing.... patches needed by the looks.
    Hi
    The above is cancelled....

    I have prepared some patches etc so it all builds etc. I noted your with you current build the upstream sources changed, did you change and create a new tarball? If so, please don't do that, always patch, fix etc with the pristine upstream source.

    https://build.opensuse.org/package/s...der1/Skylendar

    Do you want me to push this build to you on a SR?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #12

    Default Re: Can't build on Obs

    Yesterday, BuildRequires: pkgconfig(Qt5Linguist) worked in my .spec file. but today, it says that nothing provides this. How can I declare the qt5 linguist tools ?

    The build logs say:
    [ 104s] CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
    [ 104s] Could not find a package configuration file provided by "Qt5LinguistTools"
    [ 104s] with any of the following names:
    [ 104s]
    [ 104s] Qt5LinguistToolsConfig.cmake
    [ 104s] qt5linguisttools-config.cmake
    [ 104s]




  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    Yesterday, BuildRequires: pkgconfig(Qt5Linguist) worked in my .spec file. but today, it says that nothing provides this. How can I declare the qt5 linguist tools ?
    Hi
    There is no pkgconfig, use cmake(Qt5Linguist) instead.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14

    Default Re: Can't build on Obs

    Quote Originally Posted by malcolmlewis View Post
    Hi
    There is no pkgconfig, use cmake(Qt5Linguist) instead.
    I both tried cmake(Qt5Linguist) and BuildRequires: cmake(Qt5Linguist) but got errors in either cases.

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    I both tried cmake(Qt5Linguist) and BuildRequires: cmake(Qt5Linguist) but got errors in either cases.
    Hi
    Its cmake(Qt5LinguistTools);
    https://build.opensuse.org/package/v....spec?expand=1
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16

    Default Re: Can't build on Obs

    Quote Originally Posted by malcolmlewis View Post
    Thx very much for the contribution, but unfortunately, I got this error message:
    [41s]error: Bad source: /home/abuild/rpmbuild/SOURCES/skylendar-fix-qt-error.patch: No such file or directory

  7. #17

    Default Re: Can't build on Obs

    Quote Originally Posted by malcolmlewis View Post
    you deserve that I click on a star, but there is no visible star below your posts. But I rated the thread as excellent

    Ok, found th star, but only after having rated the thread !

  8. #18
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    you deserve that I click on a star, but there is no visible star below your posts. But I rated the thread as excellent

    Ok, found th star, but only after having rated the thread !
    Hi
    You need to grab the patches as well...
    https://build.opensuse.org/package/s...der1/Skylendar
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #19

    Default Re: Can't build on Obs

    I grabbed and uploaded the patches as recommended, but I got this:
    Code:
    [   68s] + echo 'Patch #0 (skylendar-fix-qt-error.patch):'
    [   68s] Patch #0 (skylendar-fix-qt-error.patch):
    [   68s] + /usr/bin/patch --no-backup-if-mismatch -p1 --fuzz=0
    [   68s] can't find file to patch at input line 4
    [   68s] Perhaps you used the wrong -p or --strip option?
    [   68s] The text leading up to this was:
    [   68s] --------------------------
    [   68s] |diff -Naur a/skylendar/src/editastrodata.cpp b/skylendar/src/editastrodata.cpp
    [   68s] |--- a/skylendar/src/editastrodata.cpp    2018-12-12 13:33:24.157745000 -0600
    [   68s] |+++ b/skylendar/src/editastrodata.cpp    2019-02-01 16:47:10.444078545 -0600
    [   68s] --------------------------
    [   68s] File to patch: 
    [   68s] Skip this patch? [y] 
    [   68s] Skipping patch.
    [   68s] patch unexpectedly ends in middle of line
    Last edited by malcolmlewis; 04-Feb-2019 at 09:14. Reason: Add code tags

  10. #20
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Can't build on Obs

    Quote Originally Posted by lader1 View Post
    I grabbed and uploaded the patches as recommended, but I got this:
    [/CODE]
    [ 68s] + echo 'Patch #0 (skylendar-fix-qt-error.patch):'
    [ 68s] Patch #0 (skylendar-fix-qt-error.patch):
    [ 68s] + /usr/bin/patch --no-backup-if-mismatch -p1 --fuzz=0
    [ 68s] can't find file to patch at input line 4
    [ 68s] Perhaps you used the wrong -p or --strip option?
    [ 68s] The text leading up to this was:
    [ 68s] --------------------------
    [ 68s] |diff -Naur a/skylendar/src/editastrodata.cpp b/skylendar/src/editastrodata.cpp
    [ 68s] |--- a/skylendar/src/editastrodata.cpp 2018-12-12 13:33:24.157745000 -0600
    [ 68s] |+++ b/skylendar/src/editastrodata.cpp 2019-02-01 16:47:10.444078545 -0600
    [ 68s] --------------------------
    [ 68s] File to patch:
    [ 68s] Skip this patch? [y]
    [ 68s] Skipping patch.
    [ 68s] patch unexpectedly ends in middle of line
    [/CODE]
    Hi
    Your source is different...???? This is the one I used: https://sourceforge.net/projects/sky...ar.xz/download
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •