Results 1 to 5 of 5

Thread: eric5 (the python IDE) is missing PyQt4.QtWebKit

  1. #1

    Default eric5 (the python IDE) is missing PyQt4.QtWebKit

    Cannot get eric (the Python IDE) to run.
    When started it gives the following output:

    Code:
    Error in sys.excepthook:
    Traceback (most recent call last):
      File "<frozen importlib._bootstrap>", line 971, in _find_and_load
      File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
      File "<frozen importlib._bootstrap_external>", line 678, in exec_module
      File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
      File "/usr/lib/python3.6/site-packages/eric5/Utilities/__init__.py", line 73, in <module>
        import Preferences
      File "/usr/lib/python3.6/site-packages/eric5/Preferences/__init__.py", line 35, in <module>
        from PyQt4.QtWebKit import QWebSettings
    ModuleNotFoundError: No module named 'PyQt4.QtWebKit'
    
    Original exception was:
    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/eric5/eric5.py", line 329, in <module>
        main()
      File "/usr/lib/python3.6/site-packages/eric5/eric5.py", line 240, in main
        import Preferences
      File "/usr/lib/python3.6/site-packages/eric5/Preferences/__init__.py", line 35, in <module>
        from PyQt4.QtWebKit import QWebSettings
    ModuleNotFoundError: No module named 'PyQt4.QtWebKit'
    python-qt4-utils is installed but does not include PyQt4.QtWebKit.

    Google search reveals little, except a statement that PyQt4.QtWebKit has not been maintained for some years.

    Suggestions?
    Go placidly amidst the noise and haste, and remember what peace there may be in silence.

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: eric5 (the python IDE) is missing PyQt4.QtWebKit

    Use pycharm or visual studio code instead. If you installed eric5 from a standard openSUSE repository report a bug.
    Best regards,
    Greg

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: eric5 (the python IDE) is missing PyQt4.QtWebKit

    For Development related issues, you might want to search the Development forums instead of, or in addition to this Applications forum.

    This should be the answer to your question...

    https://forums.opensuse.org/showthre...-crashing-help

    Bottom line, The Eric team no longer supports Eric 5.
    Instead Eric 6 as described in the thread instead.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    93

    Default Re: eric5 (the python IDE) is missing PyQt4.QtWebKit

    Try Atom. It is as good as Sublime. But it free. Eclipse and Netbeans are not bad. But tough to install. And it is my personal taste, bought ugly. You download the binary and you put it in your local Bin directory. And Voilà !
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  5. #5

    Default Re: eric5 (the python IDE) is missing PyQt4.QtWebKit

    Thank you all for your suggestions.
    I have no particular reason to use eric5, so I'll try the others.
    Go placidly amidst the noise and haste, and remember what peace there may be in silence.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •