Results 1 to 4 of 4

Thread: Problems with installing/running wordpress on localhost LAMP stack

  1. #1
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Problems with installing/running wordpress on localhost LAMP stack

    Hi,
    I'm trying to run a localhost web server for training purposes but I can't get it to work.
    Firstly I installed Apache2, MariaDB, PHP7 phpmyadmin and wordpress from Yast. When I write localhost in firefox I get this:

    That's ok, but when I type localhost/wp-admin to configure wordpress I get an error



    Then I deleted all installed packages from Yast and started over installing via console following this guide

    https://en.opensuse.org/SDB:LAMP_setup

    In this case I have working apache2 and also MariaDB and phpMyAdmin. I create an empty database with my site name and a user for the database. I can't figure out where to install wordpress to make it work. I noticed that if I install wordpress from Yast it is installed in /srv/www and it's not working. I moved the /wordpress folder to /srv/www/htdocs and it also is not working.
    Now I deleted all installed packages again from Yast and started over for third time this time installing XAMPP server. Again its not working. When i start all from XAMPP Control panel, I get this error for ProFTPD:

    Code:
    Starting all servers...
    Starting MySQL Database...
    /opt/lampp/mysql/scripts/ctl.sh : mysql  started at port 3306
    Starting Apache Web Server...
    /opt/lampp/apache2/scripts/ctl.sh : httpd started
    Starting ProFTPD...
    Exit code: 8
    Stdout:
    Checking syntax of configuration file
    proftpd config test fails, aborting
    Stderr:
    linux-npks proftpd[3606]: warning: unable to determine IP address of 'linux-npks'
    linux-npks proftpd[3606]: error: no valid servers configured
    linux-npks proftpd[3606]: Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
    That does't boder me much until I tried to change the new block wordpress editor with the classic one by installing the classic editor plugin. In this case I got a FTP login screen that I don't know what to do, because I didn't set up an FTP server and I don't need it.
    So, I now will uninstall all again and please, can someone guide me to install a working wordpress environment on opensuse leap 15

    Thanks in advance
    Ilian

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: Problems with installing/running wordpress on localhost LAMP stack

    Install the LAMP server pattern from YaST, enable mysql.service and start it, use YaST's HTTP server module to enable the apache2.service, http://localhost should show "It works!"

    The fact that Apache shows up in /opt is proof that you installed some external package/tarball.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Re: Problems with installing/running wordpress on localhost LAMP stack

    Thanks for the reply.
    What have I done so far?
    1. I deleted all server and database related packages via YAST
    2. I installed the Web and LAMP server pattern via YAST
    3. Strange but after I don't have an HTTP server in YAST>Network services
    4. I opened localhost in firefox and got It Works!
    5. I activated apache and MYSQL services to start at boot
    6. Reboot
    7. I installed phpMyAdmin via YAST
    8. I opened localhost/phpmyadmin in browser
    9. I logged in then created a database named gameuniversebg and a user gameuniversebg with all privileges for this DB
    10. server is located at /srv/www/htdocs so to install Wordpress I placed it in this folder
    11. I opened localhost/wordpress in browser and got an error message:

    Sorry, but I can’t write the wp-config.php file.
    You can create the wp-config.php file manually and paste the following text into it.
    Last edited by gongalov71; 31-Jan-2019 at 11:01. Reason: more info

  4. #4
    Join Date
    Dec 2008
    Location
    Bulgaria, Sofia
    Posts
    33

    Default Re: Problems with installing/running wordpress on localhost LAMP stack

    I edited the file wp-config-sample.php and saved it as wp-config.php
    I got the FTP login screen again
    I opened my Windows 10 XAMPP server installation folder and copied the contents of /htdocs folder to /srv/www/htdocs

    And the FTP login is no longer required. Thanks, case solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •