Results 1 to 8 of 8

Thread: 22/tcp filtered ssh

  1. #1

    Default 22/tcp filtered ssh

    I dont have any firewall but port is blocked. What is blocking it?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,385

    Default Re: 22/tcp filtered ssh

    Not much information here!

    To prove that a port is blocked, you first have to prove that some process is listening on that port. As root:
    Code:
    netstat -tlpn | grep 22
    Last edited by hcvv; 30-Jan-2019 at 04:04.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,341
    Blog Entries
    14

    Default Re: 22/tcp filtered ssh

    Even thenm check YaST - Security - Firewall. If the port is blocked, it can only be the firewall. OTOH, check whether the sshd service is running.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: 22/tcp filtered ssh

    ThePC:~ # netstat -tlpn | grep 22
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2223/master
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 14240/sshd
    tcp6 0 0 ::1:25 :::* LISTEN 2223/master
    tcp6 0 0 :::22 :::* LISTEN 14240/sshd

    I can do ssh internally.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,385

    Default Re: 22/tcp filtered ssh

    Quote Originally Posted by donvito7 View Post
    tcp6 0 0 :::22 :::* LISTEN 14240/sshd
    It looks that sshd is listening on port 22 through IPv6.
    Are you sure the client is trying to contact using IPv6 also?

    And please:

    There is an important, but not easy to find feature on the forums.


    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.
    Henk van Velden

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,620
    Blog Entries
    3

    Default Re: 22/tcp filtered ssh

    Quote Originally Posted by hcvv View Post
    It looks that sshd is listening on port 22 through IPv6.
    It is listening with both IPv6 and IPv4, but it would be easier to see that with a CODE block.

    We don't know what the OP is attempting that is failing.
    openSUSE Leap 15.0; KDE Plasma 5;
    testing Leap 15.1.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,385

    Default Re: 22/tcp filtered ssh

    Quote Originally Posted by nrickert View Post
    It is listening with both IPv6 and IPv4, but it would be easier to see that with a CODE block.

    We don't know what the OP is attempting that is failing.
    You are correct, it is there. I always get a headache when no CODE block.

    And indeed, I already tried to hint to the OP that there is not much information in his first post.
    Henk van Velden

  8. #8
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,127

    Default Re: 22/tcp filtered ssh

    Quote Originally Posted by donvito7 View Post
    I dont have any firewall but port is blocked. What is blocking it?
    Can you check that please with 'systemctl status' ?

    E.g.
    Code:
    sysman@ns3:~> systemctl status SuSEfirewall2
    ● SuSEfirewall2.service - SuSEfirewall2 phase 2
       Loaded: loaded (/usr/lib/systemd/system/SuSEfirewall2.service; disabled; >
       Active: inactive (dead)
    sysman@ns3:~> systemctl status firewalld
    ● firewalld.service - firewalld - dynamic firewall daemon
       Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendo>
       Active: active (running) since Thu 2019-01-17 11:23:34 GMT; 1 weeks 6 day>
         Docs: man:firewalld(1)
     Main PID: 1002 (firewalld)
        Tasks: 2 (limit: 4915)
       CGroup: /system.slice/firewalld.service
               └─1002 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid
    sysman@ns3:~>
    I can do ssh internally.
    Do you mean within the host (your computer) or from another machine on your LAN (local network)? If the latter, do you have a firewall on your gateway'router or upstream? Where did the “filtered” message come from?
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •