Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: How restart the audio/sound system?

  1. #21
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,466
    Blog Entries
    1

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by martinprowe View Post
    Okay.... The Sound card on the graphics controller has gone quiet (for whatever reason)?
    So, I re-run the three aplay <device> test.wav and these are the results...
    Code:
    # aplay --device=hdmi:CARD=MID,DEV=0 /usr/share/sounds/alsa/test.wav                        
    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo                
    # //I CAN hear the test sound on my HDMI Amp connected to the motherboard sound card
    
    # aplay --device=hdmi:CARD=HDMI,DEV=0 /usr/share/sounds/alsa/test.wav
    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo                
    # //I CAN NOT hear the test sound on my Left-Hand DisplayPort monitor connected to my graphics card
    
    #  aplay --device=hdmi:CARD=HDMI,DEV=1 /usr/share/sounds/alsa/test.wav                        
    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo                
    # //I CAN NOT hear the test sound on my Right-Hand DisplayPort monitor connected to my graphics card
    It seems that I must have a problem with Graphics/Sound Card.
    I'll not guess, will you advise on what info I can provide...

    Regards, Martin
    It is BOTH devices that go quite with respect to HDMI outputs. More research/investigation will be needed....
    openSUSE Leap 15.0; KDE Plasma 5

  2. #22

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by deano_ferrari View Post
    It is BOTH devices that go quite with respect to HDMI outputs
    I don't know if this helps to explain the setup here? But I have Radeon FirePro Dual DisplayPort graphics card.
    Each DispayPort has a monitor with speakers (as they all do these days) and to feed those speakers is a sound chip on the FirePro.
    I have set my "default" audio sink to one of those displays because it will always on. The amp connected to the HDMI output on the motherboard sound card may not be.

    So, I'm not surprised that both HDMI devices (which should read DisplayPort devices - but I guess that's whole different game?) should go quiet because they are managed by the sound chip on the graphics card.

    Regards, Martin
    openSUSE Leap 15; KDE Plasma 5.12.5;

  3. #23
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,466
    Blog Entries
    1

    Default Re: How restart the audio/sound system?

    If you unplug and re-plug the display, are you then able to get audible sound again? It's hard to know whether the behaviour is monitor-related, or in the graphics card itself. Anyway, you might try disabling the sound driver power management to start with. Add the following to a custom file eg /etc/modprobe.d/20-sound.conf
    Code:
    options snd-hda-intel power_save=0
    It will take effect the next time the module is unloaded and loaded again, (or at boot).

    Graphics hardware and driver details might be useful to know...
    Code:
    /sbin/lspci -nnk | grep -iA3 '\[03'
    openSUSE Leap 15.0; KDE Plasma 5

  4. #24
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,466
    Blog Entries
    1

    Default Re: How restart the audio/sound system?

    Returning to you opening post statement...
    However, after some time (unknown, maybe hours) one sound card stops working.
    The only way I know how to get it working again, is to reboot.
    ....do the monitors go to sleep after a period of inactivity, or have you configured the desktop to blank after an idle time etc? Maybe an event like that causes the 'missing' audio.

    FWIW, here's similar behaviour described in a M$ thread....
    https://www.tenforums.com/graphic-ca...hd-7800-a.html
    openSUSE Leap 15.0; KDE Plasma 5

  5. #25

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by deano_ferrari View Post
    ....do the monitors go to sleep after a period of inactivity, or have you configured the desktop to blank after an idle time etc?
    No, not exactly... However, I do flick the monitor power buttons to off when I leave the computer. And I think you are on to something here....

    It seems that if I turn off either (or both), when I turn either (or both) back on , there is no audio. There is no Power Save functions that I can find in the ASUS VG245Q documentation.

    However, have found that if I amend the display config, I can bring the audio back on. Yeah..... Success... Sorta...?
    What I need to do, (and now you may be able to suggest a short-hand?) is to use the Systemsettings5 GUI and open "Manage and configure monitors and displays"
    then "Disable" and then "Enable" each display in turn (even if I have only turned off one monitor) with the "Display Enabled" check box.

    Not slick... But quicker than rebooting.

    So what I'm guessing, is that the monitors tell the graphics controller that the display and audio are off. However, either the monitor forgets to tell the graphics controller that audio is back or the graphics controller does not hear the message? Either way, short of fixing the problem (which is unlikely to happen?) or finding a script or hot-key to disable/enable the displays, I think you Mods have solved (yet again) my problem.

    Regards, Martin
    openSUSE Leap 15; KDE Plasma 5.12.5;

  6. #26
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,466
    Blog Entries
    1

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by martinprowe View Post
    No, not exactly... However, I do flick the monitor power buttons to off when I leave the computer. And I think you are on to something here....
    Yes, after reading a number of similar threads, it is apparent this is not an openSUSE-specific problem.

    So what I'm guessing, is that the monitors tell the graphics controller that the display and audio are off. However, either the monitor forgets to tell the graphics controller that audio is back or the graphics controller does not hear the message? Either way, short of fixing the problem (which is unlikely to happen?) or finding a script or hot-key to disable/enable the displays, I think you Mods have solved (yet again) my problem.

    Regards, Martin
    Try using xrandr to turn the audio back on. Make sure that you use the HDMI device name applicable to your system. You can use 'xrandr' for that. Anyway, something like...
    Code:
    xrandr --output HDMI-0 --set audio on
    If that doesn't do the trick, then it may be that toggling is required
    Code:
    xrandr --output HDMI-0 --set audio off
    xrandr --output HDMI-0 --set audio on
    Or you could just disable and re-enable a display (similar to your 'System Settings' findings) using xrandr. Once you have it working manually, it's not hard to construct a keyboard shortcut to do the same.
    Last edited by deano_ferrari; 02-Feb-2019 at 13:38.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #27

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by deano_ferrari View Post
    If that doesn't do the trick, then it may be that toggling is required
    Threw the lot at it...
    Code:
    xrandr --output DisplayPort-0 --set audio off
    xrandr --output DisplayPort-0 --set audio on
    xrandr --output DisplayPort-1 --set audio off
    xrandr --output DisplayPort-1 --set audio on
    ... maybe overkill? But it works!

    Thank you both (Deano/Malcolm), Martin
    openSUSE Leap 15; KDE Plasma 5.12.5;

  8. #28
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,466
    Blog Entries
    1

    Default Re: How restart the audio/sound system?

    Quote Originally Posted by martinprowe View Post
    Threw the lot at it...
    Code:
    xrandr --output DisplayPort-0 --set audio off
    xrandr --output DisplayPort-0 --set audio on
    xrandr --output DisplayPort-1 --set audio off
    xrandr --output DisplayPort-1 --set audio on
    ... maybe overkill? But it works!

    Thank you both (Deano/Malcolm), Martin
    That's a good result!

    You can create a custom shortcut to do all that with a key combo if desired....
    https://www.addictivetips.com/ubuntu...-kde-plasma-5/
    openSUSE Leap 15.0; KDE Plasma 5

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •