Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Ruby update problem

  1. #1

    Default Ruby update problem

    Hello.
    Could you tell me how to solve this problem?


    Code:
    alex@linux-1fj7:~> LC_ALL=C sudo zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    
    Problem: ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64 requires rubygem(ruby:2.5.0:tzinfo:1) >= 1.1, but this requirement cannot be provided
      deleted providers: ruby2.5-rubygem-tzinfo-1.2.5-1.1.x86_64
     Solution 1: deinstallation of ruby2.5-rubygem-activesupport-5_1-5.1.6-1.1.x86_64
     Solution 2: keep obsolete ruby2.5-rubygem-tzinfo-1.2.5-1.1.x86_64
     Solution 3: break ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    Repos:

    Code:
    alex@linux-1fj7:~> LC_ALL=C zypper lr -Ed
    #  | Alias                               | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                     | Service
    ---+-------------------------------------+----------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------+--------
     1 | google-chrome                       | google-chrome                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                     |        
     2 | graphics                            | Graphics Project (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_Tumbleweed/                 |        
     3 | http-download.opensuse.org-f8390583 | devel:languages:nodejs                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/nodejs/openSUSE_Tumbleweed/ |        
     4 | http-ftp.uni-erlangen.de-419fcde3   | Packman Repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Tumbleweed                 |        
     5 | packman                             | packman                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                     |        
     7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                                   |        
     8 | repo-oss                            | openSUSE-Tumbleweed-Oss                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                       |        
    10 | repo-update                         | openSUSE-Tumbleweed-Update             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/
    |
    Code:
    alex@linux-1fj7:~> LC_ALL=C zypper repos
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    
    #  | Alias                               | Name                                   | Enabled | GPG Check | Refresh
    ---+-------------------------------------+----------------------------------------+---------+-----------+--------
     1 | google-chrome                       | google-chrome                          | Yes     | (r ) Yes  | Yes    
     2 | graphics                            | Graphics Project (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes    
     3 | http-download.opensuse.org-f8390583 | devel:languages:nodejs                 | Yes     | (r ) Yes  | Yes    
     4 | http-ftp.uni-erlangen.de-419fcde3   | Packman Repository                     | Yes     | (r ) Yes  | Yes    
     5 | packman                             | packman                                | Yes     | (r ) Yes  | Yes    
     6 | repo-debug                          | openSUSE-Tumbleweed-Debug              | No      | ----      | ----   
     7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss            | Yes     | (r ) Yes  | Yes    
     8 | repo-oss                            | openSUSE-Tumbleweed-Oss                | Yes     | (r ) Yes  | Yes    
     9 | repo-source                         | openSUSE-Tumbleweed-Source             | No      | ----      | ----   
    10 | repo-update                         | openSUSE-Tumbleweed-Update             | Yes     | (r ) Yes  | Yes

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    171

    Default Re: Ruby update problem

    As YaST2 is almost completely Ruby-based, I can only recommend from experience not to uninstall anything of the default Ruby packages. I once made my YaST unusable that way, after issuing a »gem uninstall --all« as root, IIRC.

    Having been using Ruby as my main scripting language since 2004, I ought to know more about rvm and other Ruby version managers, but as it is I'lm just using the pre-installed MRI (true to Matz' POLS) and leave it as it is, otherwise. You can always compile Ruby into a local directory and use that one, but you have to be careful about different library and ruby-gem and ruby-doc paths as well (because commands as »ri«, »irb« and »gem« need to use the correct paths depending on the version of Ruby they run on).

    Can you tell a bit about how you ended up with this configuration? Thanks!

  3. #3

    Default Re: Ruby update problem

    Quote Originally Posted by unix111 View Post
    Can you tell a bit about how you ended up with this configuration? Thanks!
    Ok, here is my story.
    I have not had problems with Ruby for almost a year.
    It would be cool if good advice ...

  4. #4
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    171

    Default Re: Ruby update problem

    Do you have the RPM package ruby2.5-rubygem-rails-5_1 installed with dependencies? Can you check with
    • YaST → Software Management (search and select the package for install or unconditional update)
    • then change to Tab »Installation Summary« → Menu »Extras« → »Install All Matching Recommended Packages«
    • in the dialog, take note of the recommendation (anything surprising?), then close the dialog with »OK«
    • finally, select »Accept« on the lower right

    Does YaST complain about any package conflicts? Installing Rails really should be a 1.5-minute job just like on Fedora.
    Maybe we can crack this nut…

  5. #5

    Default Re: Ruby update problem

    Quote Originally Posted by unix111 View Post
    in the dialog, take note of the recommendation (anything surprising?)
    Nothing. Empty. Zero.

    Any ideas?

  6. #6
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    171

    Default Re: Ruby update problem

    Well, I can't seem to replicate this problem. Yet, if your installation isn't a production-critical server installation, then of the three choices offered by zypper in your initial posting…
    Code:
     Solution 1: deinstallation of ruby2.5-rubygem-activesupport-5_1-5.1.6-1.1.x86_64
     Solution 2: keep obsolete ruby2.5-rubygem-tzinfo-1.2.5-1.1.x86_64
     Solution 3: break ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64 by ignoring some of its dependencies
    … I would choose Solution 3 because it's very possible that Rails may work nevertheless. Otherwise, the output of »rails new your_project_name« would be helpful.

    You may also give the official openSUSE-one-click installer for Rails 5.2 a try if you're feeling adventurous (and if you don't have any version constraints):
    https://software.opensuse.org/packag...ygem-rails-5.2

  7. #7

    Default Re: Ruby update problem

    Quote Originally Posted by unix111 View Post
    You may also give the official openSUSE-one-click installer for Rails 5.2 a try if you're feeling adventurous (and if you don't have any version constraints):
    https://software.opensuse.org/packag...ygem-rails-5.2
    No, it does not work.

    Quote Originally Posted by unix111 View Post
    Well, I can't seem to replicate this problem.
    Really? It's simple:

    Code:
    alex@linux-1fj7:~> LC_ALL=C sudo zypper in ruby2.5-rubygem-rails-5_1
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides rubygem(ruby:2.5.0:tzinfo:1) >= 1.1 needed by ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64
     Solution 1: do not install ruby2.5-rubygem-rails-5_1-5.1.6.1-1.1.x86_64
     Solution 2: break ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c] (c): 
    
    alex@linux-1fj7:~> LC_ALL=C sudo zypper in ruby2.5-rubygem-rails-5_2
    Loading repository data...
    Reading installed packages...
    'ruby2.5-rubygem-rails-5_2' not found in package names. Trying capabilities.
    No provider of 'ruby2.5-rubygem-rails-5_2' found.
    
    
    alex@linux-1fj7:~> LC_ALL=C sudo zypper in ruby2.5-rubygem-railties-5.2
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides rubygem(ruby:2.5.0:tzinfo:1) >= 1.1 needed by ruby2.5-rubygem-activesupport-5.2-5.2.2-1.1.x86_64
     Solution 1: do not install ruby2.5-rubygem-railties-5.2-5.2.2-1.1.x86_64
     Solution 2: break ruby2.5-rubygem-activesupport-5.2-5.2.2-1.1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c] (c):

  8. #8

    Default Re: Ruby update problem

    Help please.
    I am a developer. I need a ruby.

    Code:
    NAME="openSUSE Tumbleweed" 
    # VERSION="20190121"
    

  9. #9
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    171

    Default Re: Ruby update problem

    Quote Originally Posted by aleksejsmir View Post
    No, it does not work.
    Code:
    alex@linux-1fj7:~> LC_ALL=C sudo zypper in ruby2.5-rubygem-rails-5_1
    [...]
     Solution 1: do not install ruby2.5-rubygem-rails-5_1-5.1.6.1-1.1.x86_64
     Solution 2: break ruby2.5-rubygem-activesupport-5_1-5.1.6.1-1.1.x86_64 by ignoring some of its dependencies
    Choose from above solutions by number or cancel [1/2/c] (c):
    Have you tried solution 2 there?

    Code:
    alex@linux-1fj7:~> LC_ALL=C sudo zypper in ruby2.5-rubygem-rails-5_2
    [...]
    No provider of 'ruby2.5-rubygem-rails-5_2' found.
    The repository from the 1-click-installer mentioned before seems missing — that's why »no provider«.
    Read up on openSUSE’s Website about any questions (there's also a FAQ there; also, most often, it's not really a one-click install.).
    So if you sure you want Rails 5.2 and not Rails 5.1:
    1. Try https://software.opensuse.org/packag...ygem-rails-5.2 again
    2. From there, download the package for Tumbleweed (currently, the official package is 5.2.2; alternatively, you can try the cutting-edge railties too: https://software.opensuse.org/packag...m-railties-5.2)
    3. Open your download folder, double-click the YMP file you've downloaded
    4. allow YaST to add the repositories; follow the instructions; YaST should resolve any missing dependencies automagically
    5. open a console window and create a test Rails project with »rails new your_project_name« (if any errors occur, post them here in this thread, please)
    6. … or check out David Heinemeier Hansson’s Rails 5 tour, following this video: https://www.youtube.com/watch?v=OaDhY_y8WTo (ca 20 minutes; again, please post any errors occuring, or anything out of the ordinary)


    Help please.
    I am a developer. I need a ruby.
    If it's only Ruby that you want, you already have it. Try a few one-liners in the shell:
    Code:
    ruby -v
    ruby -we '10.times {|r| puts "#{r} rubies"}'
    ruby -le '32.times {|y| print " "*(31-y), (0..y).map{|x|~y&x>0?" .":" A"}.join}'
    You don't even need an editor.

    Concerning those inconsistencies with zypper, I have no explanation for that. Wish somebody more experienced with Tumbleweed and zypper could join in.
    My experience with Tumbleweed was: too cutting-edge, too experimental, too many updates per week; if you'd like to concentrate on your work in a stable environment, give Leap 15 a try.
    And if you want to learn more about those software packages than zypper or the rpm command provide, (e.g. their dependencies, variants, providers, file lists; what removing them would entail; ), get comfortable with the YaST2 Software Management module. Its menus are packed with functionality. It's more versatile than one would think at first glance. Cheers, happy hacking!

  10. #10

    Default Re: Ruby update problem

    Quote Originally Posted by unix111 View Post
    Have you tried solution 2 there?
    hell, I don't know what to do...


    Code:
    alex@linux-1fj7:/mnt/a/Rails/test2> ruby -v
    ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-linux-gnu]
    alex@linux-1fj7:/mnt/a/Rails/test2> rails s
    Traceback (most recent call last):
            12: from /usr/bin/rails:23:in `<main>'
            11: from /usr/lib64/ruby/2.5.0/rubygems.rb:309:in `activate_bin_path'
            10: from /usr/lib64/ruby/2.5.0/rubygems.rb:309:in `synchronize'
             9: from /usr/lib64/ruby/2.5.0/rubygems.rb:310:in `block in activate_bin_path'
             8: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1440:in `activate'
             7: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1458:in `activate_dependencies'
             6: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1458:in `each'
             5: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1472:in `block in activate_dependencies'
             4: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1440:in `activate'
             3: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1458:in `activate_dependencies'
             2: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1458:in `each'
             1: from /usr/lib64/ruby/2.5.0/rubygems/specification.rb:1469:in `block in activate_dependencies'
    /usr/lib64/ruby/2.5.0/rubygems/dependency.rb:312:in `to_specs': Could not find 'tzinfo' (~> 1.1) - did find: 
    [tzinfo-2.0.0] (Gem::MissingSpecVersionError)
    Checked in 'GEM_PATH=/home/alex/.gem/ruby/2.5.0:/usr/lib64/ruby/gems/2.5.0', execute `gem env` for more infor
    mation
    
    

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •