Results 1 to 5 of 5

Thread: After resume eth network not working

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    429

    Default After resume eth network not working

    hi

    since a update or two, after resulme something i'm not able to get ip work from my ethernet card.
    i need to remove cable put it again to get ip

    thanks
    www.laboiteaprog.com

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    9,882
    Blog Entries
    1

    Default Re: After resume eth network not working

    You can use ethtool to verify whether your Linux system is correctly detecting your physical network connection status.
    Depending on whether your networking is managed by Wicked or NM, you can usually change state with a command line,
    I haven't researched current methods Linux uses to detect network media state, there used to be other methods but I think today is a udev function.

    As always, run an Upgrade (because this is TW) to see if that fixes the problem.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,083

    Question Re: After resume eth network not working

    @collinm:

    Please indicate if you're using Network Manager or Wicked to control the interface.

    In ‘/etc/sysconfig/network/ifcfg-eth0’ there's a parameter “ETHTOOL_OPTIONS”.
    You may need to set it up to something like «ETHTOOL_OPTIONS='-s eth0 wol g'» where “wol g” can be replaced by what ever “ethtool” is indicating for “Supports Wake-on:”.
    Documentation is in the ifcfg (5) man page and, there's this Red Hat information as well: <https://www.linuxunit.com/rhel7-wake...e-and-suspend/>.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    9,882
    Blog Entries
    1

    Default Re: After resume eth network not working

    Quote Originally Posted by dcurtisfra View Post
    @collinm:

    Please indicate if you're using Network Manager or Wicked to control the interface.

    In ‘/etc/sysconfig/network/ifcfg-eth0’ there's a parameter “ETHTOOL_OPTIONS”.
    You may need to set it up to something like «ETHTOOL_OPTIONS='-s eth0 wol g'» where “wol g” can be replaced by what ever “ethtool” is indicating for “Supports Wake-on:”.
    Documentation is in the ifcfg (5) man page and, there's this Red Hat information as well: <https://www.linuxunit.com/rhel7-wake...e-and-suspend/>.
    That's an interesting suggestion although strictly speaking should not apply to this scenario. "WOL" is when a machine is woken up remotely whereas this situation of course is simply detecting the physical connection automatically when returning from standby or hibernation.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,083

    Default Re: After resume eth network not working

    @tsu2:

    You're correct! — I was being muddled – again …

    But, it may be that, an additional script is needed to restart the systemd network.service when the system wakes up from hibernation; possibly triggered by the systemd-hibernate-resume@.service …

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •