Results 1 to 7 of 7

Thread: Update conflict on Leaf 15

  1. #1

    Question Update conflict on Leaf 15

    One of the leap 15 updates is 'python-cffi', which on my system which as both python2 and python3 installed consists of the 'python2-cffi' and 'python3-cffi' packages. Yet when I try to install this update I get a whole host of conflicts:

    Code:
    File /usr/lib64/python2.7/site-packages/_cffi_backend.so
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_cffi_errors.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_cffi_include.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_embedding.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/parse_c_type.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
    Is there a way to resolve this ?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,796

    Default AW: Update conflict on Leaf 15

    This is no Leap 15.0 package:
    python-cffi-1.11.5-51.4.x86_64 (@System)

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,168
    Blog Entries
    3

    Default Re: Update conflict on Leaf 15

    Quote Originally Posted by eldiener View Post
    Is there a way to resolve this ?
    The conflict is with something that you installed yourself, and not using a Leap 15.0 repo. So I guess you get to make the decisions on how to deal with the conflict.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,582
    Blog Entries
    14

    Default Re: Update conflict on Leaf 15

    Please show
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Update conflict on Leaf 15

    Quote Originally Posted by eldiener View Post
    One of the leap 15 updates is 'python-cffi', which on my system which as both python2 and python3 installed consists of the 'python2-cffi' and 'python3-cffi' packages. Yet when I try to install this update I get a whole host of conflicts:

    Code:
    File /usr/lib64/python2.7/site-packages/_cffi_backend.so
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/__init__.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_cffi_errors.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_cffi_include.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/_embedding.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/api.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/commontypes.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/cparser.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/error.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/lock.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/model.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/parse_c_type.h
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/recompiler.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.py
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.pyc
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
     
    
     File /usr/lib64/python2.7/site-packages/cffi/verifier.pyo
       from install of
          python2-cffi-1.11.2-lp150.3.3.1.x86_64 (Main Update Repository)
       conflicts with file from package
          python-cffi-1.11.5-51.4.x86_64 (@System)
    Is there a way to resolve this ?
    I had the devel:tools:compiler repository enabled. After I disabled that repository the particular python cffi packages diappeared from the list of those to be updated. Strangely enough, after re-enabling the devel:tools:compiler repository the python cffi packages are no longer among those to be updated, even if they are still listed among those that have been installed.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,398

    Talking Re: AW: Update conflict on Leaf 15

    Quote Originally Posted by Sauerland View Post
    This is no Leap 15.0 package:
    python-cffi-1.11.5-51.4.x86_64 (@System)
    I beg to differ: <https://software.opensuse.org/package/python-cffi>; <https://software.opensuse.org/package/python2-cffi>; <https://software.opensuse.org/package/python3-cffi>.
    • Searching for “python” only finds the ‘python’ RPM — searching for “cffi” finds all the ‘cffi’ packages.
    • “zypper search python” finds 5577 packages related to ‘python’ …
    • Possibly the <https://software.opensuse.org/> search is misbehaving WRT “python” …

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,398

    Talking Re: Update conflict on Leaf 15

    Quote Originally Posted by eldiener View Post
    I had the devel:tools:compiler repository enabled.
    You need to check the output of “zypper info --requires python2-cffi” and then, check the packages which are providing the “.so” libraries listed.
    • It's possible that, there was a version mismatch between the package versions in the “devel:tools:compiler” repository and the main update repository.
    • The only way out in such cases, is to manually apply the version changes to the packages via the YaST software management module …

    Just to be on the safe side, you should also “repair” your local copy of the RPM database: “rpm --rebuilddb” …

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •