Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: How to change the time seperator "." to ":"

  1. #1

    Default How to change the time seperator "." to ":"

    How to change the time seperator "." to ":"
    Leap 15
    Gnome
    Language: Hungarian

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    142

    Default Re: How to change the time seperator "." to ":"

    You can change date and time to a custom format using dconf (or dconf-editor), it seems to go something like this:
    Code:
    dconf write /com/canonical/indicator/datetime/time-format "'custom'"
    dconf write /com/canonical/indicator/datetime/custom-time-format "'%F %R'"
    %F is a placeholder for »yyyy-mm-dd«.
    %R is a placeholder for »HH:MM« (with 24-hour display, no AM/PM).

    Use the man page for »strftime« in a terminal window for more possibilities:
    Code:
    man strftime
    I don't know GNOME too well, maybe you need to log out and log in again in order for the changes to take effect.
    (Sad to see that, like KDE, the Gnome developers also dumbed their customizability down, unless macOS and Windows who have had full date+time customizability for over 30 years.)

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: How to change the time seperator "." to ":"

    Quote Originally Posted by unix111 View Post
    (Sad to see that, like KDE, the Gnome developers also dumbed their customizability down, unless macOS and Windows who have had full date+time customizability for over 30 years.)
    Correction. It was *not* KDE, it was QT that dumbed that down.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    830

    Default Re: How to change the time seperator "." to ":"

    Quote Originally Posted by nagybal View Post
    How to change the time seperator "." to ":"
    Leap 15
    Gnome
    Language: Hungarian
    No problem whatsoever when switching:

    Code:
    karl@erlangen:~> locale
    LANG=de_DE.UTF-8
    LC_CTYPE=de_DE.UTF-8
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"
    LC_ALL=
    karl@erlangen:~> export LANG=hu_HU.utf8
    karl@erlangen:~> locale
    LANG=hu_HU.utf8
    LC_CTYPE=de_DE.UTF-8
    LC_NUMERIC="hu_HU.utf8"
    LC_TIME="hu_HU.utf8"
    LC_COLLATE="hu_HU.utf8"
    LC_MONETARY="hu_HU.utf8"
    LC_MESSAGES="hu_HU.utf8"
    LC_PAPER="hu_HU.utf8"
    LC_NAME="hu_HU.utf8"
    LC_ADDRESS="hu_HU.utf8"
    LC_TELEPHONE="hu_HU.utf8"
    LC_MEASUREMENT="hu_HU.utf8"
    LC_IDENTIFICATION="hu_HU.utf8"
    LC_ALL=
    karl@erlangen:~> date
    2019. jan. 22., kedd, 08:44:54 CET
    karl@erlangen:~>
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  5. #5
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    142

    Default Re: How to change the time seperator "." to ":"

    Quote Originally Posted by Fraser_Bell View Post
    Correction. It was *not* KDE, it was QT that dumbed that down.
    I would argue both Qt and the KDE devs decided to almost solely use GNU's locale system to determine formatting of date and time strings.
    While I can see how Qt, as a framework and set of libraries, adopts GNU locales on Unixoid systems and wrap that within QLocale, I can't fathom how those KDE folks think it was a good idea to abandon KDE's hitherto excellent configurability. I still like and use KDE, but anybody can learn from discussions under https://bugs.kde.org/show_bug.cgi?id=340982 and similar exchanges how people miss these things because they are a given on other operating systems and GUIs.

    Just in order to have ISO-8601-formatted date- and timestamps I'm now forced to use "Sweden - English (en_SE)" as my KDE-wide date/time setting despite the fact that I don't live in Sweden, nor can I understand a word of Swedish, nor are all programs compiled with support for en_SE (evidenced by the numerous Gtk-WARNING entries in my Xorg logs: »Locale not supported by C library. Using the fallback 'C' locale.«) .

    Now, Qt5 does support ISO-8601, but KDE/Plasma doesn't yet. The ball is back with KDE devs.

    Rant over.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,733

    Default Re: How to change the time seperator "." to ":"

    Quote Originally Posted by unix111 View Post
    Just in order to have ISO-8601-formatted date- and timestamps I'm now forced to use "Sweden - English (en_SE)" as my KDE-wide date/time setting despite the fact that I don't live in Sweden, nor can I understand a word of Swedish, nor are all programs compiled with support for en_SE (evidenced by the numerous Gtk-WARNING entries in my Xorg logs: »Locale not supported by C library. Using the fallback 'C' locale.«) .
    I fully support this. I am still running 13.1 for my day to day work bcause thi is a show stopper for me.
    Quote Originally Posted by unix111 View Post
    Now, Qt5 does support ISO-8601, but KDE/Plasma doesn't yet. The ball is back with KDE devs.
    So there is still hope?
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,595
    Blog Entries
    14

    Default Re: How to change the time seperator "." to ":"

    Meanwhile we don't know where the OP wants to see the format changed.....
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,423

    Question Re: How to change the time seperator "." to ":"

    And, I can't find any reference to Linux/UNIX® time with a “.” in place of “:” as the separator between “HH”, “MM” and “SS” …

    @nagybal:
    Are you certain that, the system you're using, doesn't have a system-wide shell initialisation script which reformats the “normal” «also in Hungary» Linux ‘HH:MM:SS’ time representation?

  9. #9
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,490

    Default Re: How to change the time seperator "." to ":"

    My KDE3 and TDE desktops all have the logical ISO 8601 date format and : as hour:minute:seconds time separator.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    830

    Default Re: How to change the time seperator "." to ":"

    Quote Originally Posted by unix111 View Post
    I would argue both Qt and the KDE devs decided to almost solely use GNU's locale system to determine formatting of date and time strings.
    While I can see how Qt, as a framework and set of libraries, adopts GNU locales on Unixoid systems and wrap that within QLocale, I can't fathom how those KDE folks think it was a good idea to abandon KDE's hitherto excellent configurability. I still like and use KDE, but anybody can learn from discussions under https://bugs.kde.org/show_bug.cgi?id=340982 and similar exchanges how people miss these things because they are a given on other operating systems and GUIs.

    Just in order to have ISO-8601-formatted date- and timestamps I'm now forced to use "Sweden - English (en_SE)" as my KDE-wide date/time setting despite the fact that I don't live in Sweden, nor can I understand a word of Swedish, nor are all programs compiled with support for en_SE (evidenced by the numerous Gtk-WARNING entries in my Xorg logs: »Locale not supported by C library. Using the fallback 'C' locale.«) .

    Now, Qt5 does support ISO-8601, but KDE/Plasma doesn't yet. The ball is back with KDE devs.

    Rant over.
    You can always create your own locale and KDE will use that: http://mistelberger.net/Tumbleweed-en-DE.UTF-8.png

    More: https://forums.opensuse.org/showthre...06#post2837906
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •