Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

  1. #11

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by EGDFree View Post
    версия с ядра с которым собран модуль указывается в имени пакета nvidia-gfxG03-kmp-340.107_kВЕРСИЯ_ЯДРА-lp150.12.1
    А как же у меня работает эта на ядре 4.19?
    Code:
    i  | nvidia-gfxG03-kmp-default     | package    | 340.107_k4.12.14_lp150.11-lp150.12.1 | x86_64 | 9800

  2. #12

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by deepforest View Post
    А как же у меня работает эта на ядре 4.19?
    "с помощью чьей-то матери" ©
    «Если не говорить пользователям, что линукс это сложно и страшно, то им совершенно все равно, в чем не разбираться. » — ЛОР

  3. #13

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Я надеялся на большую четкость. Почему все же работает то, что по идее не должно работать? Интересно просто на будущее.
    Попробую еще как сказали выше поставить nvidia hard way.

  4. #14
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,028
    Blog Entries
    1

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by deepforest View Post
    Почему все же работает то, что по идее не должно работать?
    Я писал выше:
    Как мне показалось, потянул за собой дополнительные зависимости. И установка заняла приличное количество времени.
    Насколько понял, производилась компиляция модуля на локальном компьютере. Много дольше, чем установка из "нвидевского" установщика.
    Поэтому допускаю, что пакет из Leap компилирует модуль для ядра Tumbleweed и работает.
    Такое впечатление сложилось. Больше не пробовал. Интересно, кто-то может подтвердить или опровергнуть?

  5. #15
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    153

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by Lazy_Kent View Post
    Интересно, кто-то может подтвердить или опровергнуть?
    openSUSE 15.0, nvidia 410.93 из репозитория "nVidia Graphics Drivers"

    Каждый раз при установке/обновлении установщик останавливается в конце, на минуту или две, после чего выдаёт длинный отчёт. Я всегда думал, что в это время он компилирует модуль ядра, но отчёт не смотрел, так как драйвер после установки отлично работает, поэтому не могу на 100% подтвердить.

    И ещё:
    В зависимостях к пакету "nvidia-uvm-gfxG03-kmp-default" есть это:
    gcc
    kernel-default-devel
    make
    Вероятно для компилирования модуля ядра.

  6. #16
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    компилируется у юзера, к этому обязывает GPL-прослойка

  7. #17
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,028
    Blog Entries
    1

    Default Re: tumbleweed, nvidia driver 340.107 и ядро 4.20 совместимы или нет?

    Quote Originally Posted by kill_it View Post
    компилируется у юзера
    Ну вот и пришли к выводу.
    Откуда не ставь, всё работать будет.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •