Results 1 to 8 of 8

Thread: zypper dup suddenly doesn't respect --no-allow-vendor-change

  1. #1

    Default zypper dup suddenly doesn't respect --no-allow-vendor-change

    Hi,
    I've always updated Tumbleweed with
    Code:
    zypper dup --no-allow-vendor-change
    (well, --no-allow-vendor-change is actually default now, but anyway). Until last time, it worked fine: it didn't try to change vendors. Or occasionally it proposed changing vendors for a few packages because of some dependency conflict; in those cases I had to confirm the vendor change as a conflict resolution (as it's not allowed to change vendors on its own authority).

    Now I'm trying to upgrade, from 20181224-0 to 20190115-0, with the usual 'zypper dup --no-allow-vendor-change', and it wants to switch 248 packages from the official openSUSE vendor to all sorts of repositories I have added on my system: to Education, Games, KDE:Extra, packman, whatnot. It doesn't throw out any dependency conflict, just the final 'Continue?'. In fact it does the exact same thing as if I run 'zypper dup --allow-vendor-change'. Here is the zypper dup --no-allow-vendor-change output.

    If I lock a package on which it wants to switch vendors, it doesn't give me a conflict either, so there is no dependency reason for it to switch vendors. In /etc/zypp/zypp.conf, solver.allowVendorChange is left commented out (with the default being false), but nothing changes even if I explicitly set it to false. I've also tried updating the zypper package in the hope that it's a bug that has since been fixed, to no avail.

    Has this happened to anyone, or do you have any solution or idea what causes this behavior?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    please next time paste incl. the command.

    Could you show:
    Code:
    zypper lr -d
    and see if adding --no-allow-vendor-change makes a difference?

    A good thing to check is if the value
    Code:
    solver.dupAllowVendorChange = false
    set in /etc/zypp/zypp.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    Quote Originally Posted by groszdani View Post
    Hi,
    Now I'm trying to upgrade, from 20181224-0 to 20190115-0, with the usual 'zypper dup --no-allow-vendor-change', and it wants to switch 248 packages from the official openSUSE vendor to all sorts of repositories I have added on my system: to Education, Games, KDE:Extra, packman, whatnot.
    That's presumably because you have added those repos. However, I think it is supposed to give a conflict in that case and allow you to choose.

    Here, I have occasionally seen conflict resolution dialogues. Since I have my repo priorities set so that vendor change should be okay, I normally rerun with "--allow-vendor-change" so that I don't have to respond to all of those individual conflicts.

    I'm not sure why you are not seeing conflicts.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    Thank you for the quick reply,
    Quote Originally Posted by Knurpht View Post
    Code:
    solver.dupAllowVendorChange = false
    set in /etc/zypp/zypp.conf
    this fixed it. That option was not set in my /etc/zypp/zypp.conf (in any way, it wasn't even in the comments), after setting it to false it doesn't try to change vendors any more.

    In case you are still interested in it, here is my zypper lr -d output from before I set solver.dupAllowVendorChange to false; it's the same after setting it. zypper lr doesn't accept a --no-allow-vendor-change option (I'm not sure that's what you meant).

  5. #5

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    Note: now that I added
    Code:
    solver.dupAllowVendorChange = false
    , it won't change vendors even if I specify --allow-vendor-change. Not a problem for me, as I don't want to change vendors, and if I did, I could change the option in my zypp.conf, but it does look like the --no-allow-vendor-change/--allow-vendor-change options are broken.

  6. #6

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    On 1/17/19 11:56 AM, groszdani wrote:
    >
    > Note: now that I added
    > Code:
    > --------------------
    > solver.dupAllowVendorChange = false
    > --------------------
    > , it won't change vendors even if I specify --allow-vendor-change. Not a
    > problem for me, as I don't want to change vendors, and if I did, I could
    > change the option in my zypp.conf, but it does look like the
    > --no-allow-vendor-change/--allow-vendor-change options are broken.
    >
    >


    I agree, I'm having the same issue trying to use --allow-vendor-change.

    --
    Ken
    unix since 1986
    S.u.S.E.-openSUSE since 1998

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    Perhaps, report a bug???
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,577

    Default Re: zypper dup suddenly doesn't respect --no-allow-vendor-change

    zypp.conf and zypper.conf were recently changed again. Maybe therein lies a clue.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •