Results 1 to 4 of 4

Thread: Disabling Auto-Installation

  1. #1
    Join Date
    Nov 2011
    Location
    Toronto
    Posts
    4

    Default Disabling Auto-Installation

    Hi all,

    I am having a trouble with my Leap duo some software update.
    This week I had to reinstall Leap three times because after a 'mandatory' update my laptop was crashing during the boot (it hanged and the capslock light was blinking).
    Now I have it reinstalled and while I request to install Docky, Yast and Zypper are trying to force me to install a bunch of other softwares, what I don' t want to do.
    So how to install only what I want using Zypper or Yast?

    Also, does someone else had problem after update those 'mandatory' packages?

    Best regards,

    Emerson

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,718

    Default Re: Disabling Auto-Installation

    In YaST > Software Management, when you Right-Click on a package, there is a choice: Protect - do not change.

    in
    Code:
    man zypper
    search for the chapter on Package Locks Management
    Henk van Velden

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,473

    Default Re: Disabling Auto-Installation

    If you include
    Code:
    solver.onlyRequires = true
    in /etc/zypp/zypp.conf you will not have suggested or recommended packages foisted upon you, only required packages. This is best done at installation time in the YaST software menu under "Dependencies" deselecting "Install Recommended Packages".
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,666

    Default Re: Disabling Auto-Installation

    Quote Originally Posted by Emersonivo View Post
    Also, does someone else had problem after update those 'mandatory' packages?
    Something like the following?
    https://forums.opensuse.org/showthre...ocks-up-system
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •