Results 1 to 4 of 4

Thread: libvirtd failed to initialize libnetcontrol

  1. #1

    Default libvirtd failed to initialize libnetcontrol

    Since doing a rollback to get my system working from a kernel-firmware problem, it seems KVM has stopped working. When I try to start virt-manager I get the following error from the system logs:

    Code:
    libvirtd[2731]: 2019-01-16 04:47:32.641+0000: 2731: warning : netcfIfaceRegister:1193 : Failed to intialize libnetcontrol.  Management of interface devices is disabled
    Everything for the KVM host virtualization pattern still shows installed in yast. What is causing this error?

    Thanks.

  2. #2

    Default Re: libvirtd failed to initialize libnetcontrol

    Also, if I try to launch virt-manager from the command line, I get the following:

    Code:
    /usr/bin/virt-manager: line 3: /usr/share/virt-manager/virt-manager: Permission denied
    /usr/bin/virt-manager: line 3: /usr/share/virt-manager/virt-manager: Success
    Previously, it would just open with no messages displayed in the terminal. Any idea why it would give permission denied, then success on the same line?

    When KVM is installed does it automatically add the user to a kvm group? The only group my user is listed under is "users." I don't know if the rollback may have removed my user from a group or not, as I never checked it before I did the rollback.

  3. #3

    Default Re: libvirtd failed to initialize libnetcontrol

    I just thought I'd post that I resolved this issue by reinstalling the OS. No idea what happened, but it appeared to be caused by the rollback and probably some problem with the kernel-firmware issue everyone is having with the atheros wifi cards. Maybe rolling back to the previous firmware left some setting behind that messed up KVM. Reinstalling KVM did not fix the problem. I probably should have tried forcing a reinstall of the firmware, but I did not think about that until after I started the OS reinstall. In any case, reinstalling was faster than trying to narrow down the cause.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,219
    Blog Entries
    3

    Default Re: libvirtd failed to initialize libnetcontrol

    Thanks for reporting back.
    openSUSE Leap 15.0; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •