Results 1 to 7 of 7

Thread: Make Thunar Default File Manager Issue

  1. #1

    Default Make Thunar Default File Manager Issue

    Altough I downloaded and installed Thunar successfully,
    I made it the default file manager in the applications settings,
    I copied the "mimeapps.list" file into the system's /etc directory,
    apps like firefox, KTorrent etc recognize dolphin as the default file manager…

    Any Idea?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Make Thunar Default File Manager Issue

    Hi, welcome !!!

    Is this on the KDE Plasma5 desktop? If so, use Systemsettings/Configure Desktop - Applications - Default Applications. Thunar should show there.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Απ: Re: Make Thunar Default File Manager Issue

    Quote Originally Posted by Knurpht View Post
    Hi, welcome !!!

    Is this on the KDE Plasma5 desktop? If so, use Systemsettings/Configure Desktop - Applications - Default Applications. Thunar should show there.
    Hi and thank you

    Yes it's on the KDE Plasma5…

    I did this thing already

    I copied "mimeapps.list" file as well from -/.config to /etc/xdg

    but nothing happened.

    When I open a folder through menu or desktop opens with thunar,
    but applications use dolphin as file manager.
    That's the problem…

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Make Thunar Default File Manager Issue

    This also after a logout / login ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: Make Thunar Default File Manager Issue

    And, try copying mimeapps.list to ~/.config
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Απ: Make Thunar Default File Manager Issue

    I did all these things.

    Only Opera browser recognize thunar as default file manager.

    Firefox, Kate, Ktorrent etc use dolphin to open/save files and import/export data

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    959

    Default Re: Απ: Make Thunar Default File Manager Issue

    Quote Originally Posted by Joseph17 View Post
    I did all these things.

    Only Opera browser recognize thunar as default file manager.

    Firefox, Kate, Ktorrent etc use dolphin to open/save files and import/export data
    With Tumbleweed running on 2 systems, one would honor settings, the other would ignore them. The culprit was:

    Code:
    erlangen:~ # cat /usr/share/applications/defaults.list
    [Default Applications]
    x-scheme-handler/spotify=spotify.desktop
    text/html=google-chrome.desktop;
    text/xml=google-chrome.desktop;
    application/xhtml_xml=google-chrome.desktop;
    image/webp=google-chrome.desktop;
    x-scheme-handler/http=google-chrome.desktop;
    x-scheme-handler/https=google-chrome.desktop;
    x-scheme-handler/ftp=google-chrome.desktop;
    erlangen:~ #
    Make sure you redefine the above in your local settings. Otherwise the user will get the system settings.

    Code:
    erlangen:~ # cat /home/karl/.config/mimeapps.list
    [Added Associations]
    all/allfiles=jalbum.desktop;
    application/pdf=okularApplication_pdf.desktop;
    x-scheme-handler/http=firefox.desktop;
    x-scheme-handler/https=firefox.desktop;
    
    [Default Applications]
    all/allfiles=jalbum.desktop;
    text/html=fire.desktop
    x-scheme-handler/http=firefox.desktop
    x-scheme-handler/https=firefox.desktop
    
    [Removed Associations]
    application/jalbum=FoxitReader.desktop;
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •