Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: 2 possible problems: DNS resolution and "Networking disabled"

  1. #1

    Default 2 possible problems: DNS resolution and "Networking disabled"

    Hello. On May 25, 2018, the day 64-bit openSUSE Leap 15.0 Linux (“Leap 15”) was released, I upgraded to it from 64-bit openSUSE Leap 42.3 Linux (“Leap 42.3”). My main difficulty after this upgrade is in accessing the Internet properly, but only in certain ways.--That is I COULD access the Internet using commands like

    Code:
    newbie@linux-hdi0:~> ping 127.0.0.1
    PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
    64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.048 ms
    64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.085 ms
    64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.084 ms
    ^C
    --- 127.0.0.1 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2027ms
    rtt min/avg/max/mdev = 0.048/0.072/0.085/0.018 ms
    newbie@linux-hdi0:~>
    but NOT via the command

    Code:
    newbie@linux-hdi0:~> nslookup www.google.com
    ;; connection timed out; no servers could be reached
    
    newbie@linux-hdi0:~>
    According to Henk van Velden, a failed computer execution of the command “nslookup google.com” indicates that the “DNS” (Domain Name System) “server does not work properly” (https://forums.opensuse.org/showthre...n the Internet).

    The “host” command did not work for me either, as shown below:

    Code:
    newbie@linux-hdi0:~> host 172.217.5.228
    ;; connection timed out; no servers could be reached
    newbie@linux-hdi0:~>
    (The Internet Protocol address for http://www.google.com/ is 172.217.5.228.). Implementation for the command “host” is included in the software package bind-utils, which is installed in my installation of Leap 15.

    I could not download software updates from a Leap-15 repository via openSUSE’s YaST2’s (Yet another Setup Tool 2’s) Online Update or Software Management with the result “Repository is not cached”, or “visit” https://www.opensuse.org/searchPage/ via the Mozilla Firefox Web browser in Leap 15. When I tried to update my Leap-15 software I received the messages

    Code:
    Error code: Connection failed
    Error message: Could not resolve host: download.opensuse.org
    .

    After clicking on “Skip” a few times, for skipping accessing that Web site, I eventually received the message “No update repository configured yet.” But I had 11, Leap-15 repositories, with five of them enabled, including for which I received the above error code and message. I later ran my Leap-15 installation disc through the point at which some Leap-15 repositories were reinstalled and then exited that installation. But those reinstallations did not eliminate my Leap-15 problems.

    As shown below, mixed results regarding “server” were obtained for the command

    Code:
    newbie@linux-hdi0:~> dig @8.8.8.8 www.google.com
    
    ; <<>> DiG 9.11.2 <<>> @8.8.8.8 www.google.com
    ; (1 server found)
    ;; global options: +cmd
    ;; connection timed out; no servers could be reached
    newbie@linux-hdi0:~>
    .
    I have Leap 15 as a Virtual Machine (VM) in Oracle VM VirtualBox. And my network setting within VirtualBox is NAT (Network Address Translation).

    Below please see my results for three more commands:

    Code:
    newbie@linux-hdi0:~> /sbin/lspci -nnk
    00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
    00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
    00:01.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01)
    	Kernel driver in use: ata_piix
    	Kernel modules: ata_piix, pata_acpi, ata_generic
    00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]
    	Kernel driver in use: vboxvideo
    	Kernel modules: vboxvideo
    00:03.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 02)
    	Subsystem: Intel Corporation PRO/1000 MT Desktop Adapter [8086:001e]
    	Kernel driver in use: e1000
    	Kernel modules: e1000
    00:04.0 System peripheral [0880]: InnoTek Systemberatung GmbH VirtualBox Guest Service [80ee:cafe]
    	Kernel driver in use: vboxguest
    	Kernel modules: vboxguest
    00:05.0 Multimedia audio controller [0401]: Intel Corporation 82801AA AC'97 Audio Controller [8086:2415] (rev 01)
    	Subsystem: Dell Device [1028:0177]
    	Kernel driver in use: snd_intel8x0
    	Kernel modules: snd_intel8x0
    00:06.0 USB controller [0c03]: Apple Inc. KeyLargo/Intrepid USB [106b:003f]
    	Kernel driver in use: ohci-pci
    	Kernel modules: ohci_pci
    00:07.0 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 08)
    	Kernel driver in use: piix4_smbus
    	Kernel modules: i2c_piix4
    00:0b.0 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller [8086:265c]
    	Kernel driver in use: ehci-pci
    	Kernel modules: ehci_pci
    00:0d.0 SATA controller [0106]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] [8086:2829] (rev 02)
    	Kernel driver in use: ahci
    	Kernel modules: ahci
    newbie@linux-hdi0:~>
    Code:
    newbie@linux-hdi0:~> sudo -i traceroute www.google.com
    [sudo] password for root: 
    www.google.com: Name or service not known
    Cannot handle "host" cmdline arg `www.google.com' on position 1 (argc 1)
    newbie@linux-hdi0:~>
    Code:
    newbie@linux-hdi0:~> ifconfig
    If 'ifconfig' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf ifconfig
    newbie@linux-hdi0:~>
    From YaST2’s Software Management I learned that ifconfig WAS a part of net-tools, but on May 26, 2018 WAS NOT a part of net-tools, a software package installed in my Leap-15 installation; instead on May 26, 2018 implementation for the command ifconfig is a part of the software package net-tools-deprecated, which appears not to be installed in my Leap-15 installation. So this explains why the command ifconfig was not recognized in my Leap-15 installation on May 26, 2018. According to YaST2’s Software Management ifconfig was obsoleted by one or more software tools in the software package iproute2, which IS installed in my Leap-15 installation.

    Partly following advice from https://theos.in/desktop-linux/resol...linux-example/ in the file /etc/resolv.conf I tried inputting

    Code:
    search google.com
    nameserver 172.217.5.228
    , beginning in column one in each of these lines, and deleting the line reading

    Code:
    ### Please remove (at least) this line when you modify the file!
    But still I had no success in visiting a Web page in the Mozilla Firefox Web browser in openSUSE. I inserted one tab before each of the “search..” and “nameserver...” additions in /etc/resolv.conf. But those insertions did not eliminate my problems.

    After writing much of the above content I learned from a search of https://forums.openSUSE.org/ that the DNS problem was reported as a “bug” on https://bugzilla.opensuse.org/show_bug.cgi?id=1092352. I tried the “workaround” posted by S.B. there of effectively removing the file resolv.conf from the directory /etc (He actually suggested deleting that file. I at least temporarily moved it to my desktop and to “Trash.”). But unfortunately afterward I still could not have a Web page displayed in my installation of the Mozilla Firefox Web browser in Leap 15.

    I think after my upgrade to Leap 15 I seem to have lost access to the Internet in Leap 15 via a software connection called eth0 or eth1 which used to be active! In Leap 15 when I placed my computer’s touchpad arrow over the icon which looked like two computer monitors I saw “Networking disabled.” In YaST2’s Network Settings on the Global Options tab I found “82540EM Gigabit Ethernet Controller” and “Not configured.” Leap 15 is a Virtual Machine (VM) installed inside VirtualBox, in my case. Is this 82540EM Gigabit Ethernet Controller a piece of real hardware of my computer or virtual hardware made to work with VirtualBox? I found no such hardware device or software “device” listed among the controllers in Device Manager in my 64-bit Windows 10 Home Edition, host operating system. Yet http://download.opensuse.org/distrib...0/repo/non-oss shows that it is clearly a physical device of Intel Corporation with an operating temperature range of zero to 70 degrees Centigrade. So I am inclined to think that the 82540EM Gigabit Ethernet Controller may not be a physical device of my physical computer. I suspect it might be a virtual “device” in VirtualBox or Leap 15. Nevertheless am I supposed to configure this “device?” If so, how?

    A lengthy diagnostic procedure for network-related problems applicable to Leap 15 exists on https://doc.opensuse.org/documentati...c.nm.configure. As I discussed here, I have troubleshot a few of the items discussed there. In the past few years I have mostly been using WiFi service to access the Internet with my Dell notebook computer. Before my upgrade from Leap 42.3 to Leap 15 I could update my Leap 42.3 computer software via the Internet.

    In my installation of Leap 15 on the evening of May 26, 2018 in the eastern United States there might be two different problems in what I have discussed here: 1) the DNS problem I think resolving Internet Protocol (IP) addresses as names and vice versa and 2) “Networking disabled.” I wonder if this second problem could be because I presently don’t have an Internet connection configured properly in Leap 15. Please help me with these problems.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    You can check your IP address with
    Code:
    ip a
    Personally, I prefer the formatting from "ifconfig", so I installed "net-tools-deprecated".

    It is possible that you do not have an IP address at all. If that's a problem, check
    Bug 1080832 (especially comment #5).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,705
    Blog Entries
    1

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    If it's just name resolution that's not working for you, try removing /etc/resolv.conf and restarting the network with
    Code:
    systemctl restart network
    or do
    Code:
    netconfig f update
    then see if you can resolve hostnames.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,470
    Blog Entries
    2

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Just a FYI...

    Within the past 12 hrs,
    I've done LEAP 42.3 > LEAP 15 upgrades both by using the DVD and online using "zypper dup" and both completed successfully without any network problems.

    That said, upgrading can be complex and not all upgrades can ever be a guaranteed success, only nearly 100%.

    You need to use the nslookup tool to analyze your situation more closely...
    - Instead of running a complex nslookup command, I instead recommend entering a nslookup session with simply "nslookup" so that you don't need to keep typing nslookup repetitively. You can type "exit" to leave an nslookup session.
    - Try pointing to a different server, for example the following command re-points to Google DNS. You can re-point again and again to various DNS servers if you wish.
    Code:
    > server 8.8.8.8
    - Always query for a different domain to avoid cached results.
    - Clear your name cache to avoid cached results (both failed as well as successful)
    Code:
    systemctl restart nscd.service
    Related to what you've already done
    - You can edit /etc/resolv.conf to point to a DNS server, but be aware that change won't likely survive a reboot. Permanent changes should be done differently, and if DNS is provided by your DHCP then you've probably got a bigger problem.
    - If you're running a virtual machine like Virtualbox, fire up a different Guest which has been known to work. Make sure the Guest network connections are same or similar. There shouldn't be a problem, but I've always been very suspicious of VBox's NAT connection which sets up the Guest without its own IP address (The Guest shares the Host IP address). Instead, I recommend configuring "NAT-network" which sets up a conventional network connection when the Guest has its own, unique IP address.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Code:
    newbie@linux-hdi0:~> ping 127.0.0.1
    Others will correct me if I got this wrong, but pinging one's self is not going to give you any info that's useful as you obviously can connect to yourself (especially a special IP number like 127.0.0.1).
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,470
    Blog Entries
    2

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by kerijan2003 View Post
    Code:
    newbie@linux-hdi0:~> ping 127.0.0.1
    Others will correct me if I got this wrong, but pinging one's self is not going to give you any info that's useful as you obviously can connect to yourself (especially a special IP number like 127.0.0.1).
    Yes,
    The localhost interface (typically assigned 127.x.y.z) is <not> exposed to physical network devices.
    It's completely different than the interface for which as an example a DHCP configuration might be applied.

    So, it would be useful to ping the assigned network address instead of the localhost interface address.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Thanks to all of you who kindly took some time to post postings in this “thread” of postings. I found that my computer software was set to use the so-called “wicked” method via YaST Contol Center, System, Network Settings, under Network Setup Method on the Global Options tab. Accordingly in https://bugzilla.opensuse.org/show_bug.cgi?id=1080832 I saw that Nimroy Das suggested making a file /etc/wicked/local.xml with the contents

    Code:
    <config>
       <addrconf>
           <dhcp4>
              <create-cid>rfc2132</create-cid>
           </dhcp4>
       </addrconf>
    </config>
    on the hunch that the DHCP server didn’t “like” rfc4361 client-id. Neil Rickert followed that advice and had good results after entering “systemctrl restart wickedd” or else “systemctrl restart wicked” and “rebooting” into openSUSE Tumbleweed. The version of openSUSE there on February 2, 2018 was reported as “Current.” Perhaps “Current” meant the currently tested version of openSUSE Tumbleweed, so maybe version 15.0 on February 2, 2018.

    Given Neil Rickert’s reported success, I did what he did, namely making local.xml, entering both “systemctrl restart wickedd” and “systemctrl restart wicked”, and then rebooting into Leap 15.0. I entered the command “ip a” and obtained the following results (But later “systemctrl” was not “recognized” in my installation of Leap 15.):

    newbie@linux-hdi0:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 08:00:27:24:85:7d brd ff:ff:ff:ff:ff:ff
    newbie@linux-hdi0:~>

    I still saw “Networking disabled” in a context-sensitive menu when my computer’s touchpad arrow was placed over an icon looking like two computer monitors on the lower-right side of my Leap-15 computer screen. I compared the above output with the first example output under “Show IP Addresses” on https://www.rootusers.com/11-ip-comm...les-for-linux/. Afterward I decided that for the Internet connection eth1 no Internet Protocol (IP) version-4 (IPv4) or version-6 address had been assigned to it! And I wonder if the word “DOWN” could mean that eth1 was not active at the time the above output was produced.

    Below are my results for some experiments with the command “nslookup”.

    newbie@linux-hdi0:~> nslookup
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > server 64.4.11.37
    Default server: 64.4.11.37
    Address: 64.4.11.37#53
    > exit

    newbie@linux-hdi0:~>

    The IP address 64.4.11.37 is one of the IP addresses for microsoft.com. These nslookup results look good to me.

    On the other hand,

    newbie@linux-hdi0:~> nslookup
    > server www.google.com
    nslookup: couldn't get address for 'www.google.com': not found
    newbie@linux-hdi0:~> nslookup www.google.com
    ;; connection timed out; no servers could be reached

    newbie@linux-hdi0:~>
    .
    So a summary of today’s results in my installation of Leap 15.0 is that

    1) a Web site appears to be reachable via its IP address, but not via its Uniform Resource Locator (URL), for example, www.google.com.

    2) While online my so-called "ethernet" connection eth1 in Leap 15.0 has no IP address within VirtualBox.

    3) In Leap 15.0 I continued to see “Networking disabled.”

    Consider me ignorant concerning the details of the relevant computer software. What should I do or try next?

    Further question: If I see “RESOLVED FIXED” on the top of a https://bugzilla.opensuse.org/ posting for openSUSE Tumbleweed or Leap, is it safe for me to assume that that matter has been fixed in the next or current release of openSUSE Leap so that I can ignore such a bugzilla posting?

  8. #8

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Sorry, several examples of terminal commands and computer responses were not placed in code format in my previous posting:

    Code:
    newbie@linux-hdi0:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 08:00:27:24:85:7d brd ff:ff:ff:ff:ff:ff
    newbie@linux-hdi0:~>
    I still saw “Networking disabled” in a context-sensitive menu when my computer’s touchpad arrow was placed over an icon looking like two computer monitors on the lower-right side of my Leap-15 computer screen. I compared the above output with the first example output under “Show IP Addresses” on https://www.rootusers.com/11-ip-comm...les-for-linux/. Afterward I decided that for the Internet connection eth1 no Internet Protocol (IP) version-4 (IPv4) or version-6 address had been assigned to it! And I wonder if the word “DOWN” could mean that eth1 was not active at the time the above output was produced.

    Below are my results for some experiments with the command “nslookup”.

    Code:
    newbie@linux-hdi0:~> nslookup
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > server 64.4.11.37
    Default server: 64.4.11.37
    Address: 64.4.11.37#53
    > exit
    
    newbie@linux-hdi0:~>
    .
    The IP address 64.4.11.37 is one of the IP addresses for microsoft.com. These nslookup results look good to me.

    On the other hand,

    Code:
    newbie@linux-hdi0:~> nslookup
    > server www.google.com
    nslookup: couldn't get address for 'www.google.com': not found
    newbie@linux-hdi0:~> nslookup www.google.com
    ;; connection timed out; no servers could be reached
    
    newbie@linux-hdi0:~>

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    [QUOTE=2009Newbie;2866894]
    Code:
    newbie@linux-hdi0:~> nslookup
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > server 64.4.11.37
    Default server: 64.4.11.37
    Address: 64.4.11.37#53
    > exit
    That doesn't actually tell you anything, other than that the command "nslookup" exists on your system.

    I'm now thinking that you might have a hardware issue. Perhaps your network card requires a driver that isn't installed.

    1) a Web site appears to be reachable via its IP address, but not via its Uniform Resource Locator (URL), for example, www.google.com.
    I am not actually seeing where you reached a server by its IP address.

    Further question: If I see “RESOLVED FIXED” on the top of a https://bugzilla.opensuse.org/ posting for openSUSE Tumbleweed or Leap, is it safe for me to assume that that matter has been fixed in the next or current release of openSUSE Leap so that I can ignore such a bugzilla posting?
    You have to read the fine print. In the case of bug 1080832, the "FIXED" means that they have added documentation explaining the issue and describing the workaround.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    I have a similar (or maybe the same) problem: after zypper dup went without problems, when entered the system there was no internet connection through browser.

    If I issue on konsole

    Code:
    ping 172.217.5.228
    I get an answer, but if I input that address on firefox or chromium they turn it into "www.google.com" but then tell me they cannot connect to the server. Chromium even says "cannot find the IP of the server www.google.com". A "ping google.com" fails.

    My system is set to use NetworkManager. I really do not have any idea where to start to look to fix this problem. Do I need to perform a clean install?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •