Results 1 to 6 of 6

Thread: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

  1. #1

    Default KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    Hello, after years on Windows machines I've finally decided to switch to linux. I've been using Tumbleweed (KDE Plasma) for 2 weeks now and I'm pretty happy with it, except for one small thing.

    From Windows I'm used to switch between opened windows with Meta+1, Meta+2, ... shortcuts. This is mostly not working in KDE for me. I assume it's because I'm using CZ keyboard layout. I've located these shortcuts in settings, mapped alternative versions for my locale and it's only working for first window (Meta+1). Default symbol for "key 1" in CZ layout is "+" and this is working. But defaults for keys 2, 3, etc. are localized symbols like ě,š,č,ř, etc. and those are not working. I press Meta+2 (Meta+ě) and nothing happens. Unfortunately I can't use US layout as I need to communicate in my mother tongue a lot and I would miss those symbols. Is there any workaround to this or am I doing it all wrong?

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,144

    Default Re: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    I do not have a Cz keyboard, but
    The way to switch between virtual screens in Plasma is with <Ctrl>+<F1>, <Ctrl>+<F2>, etc. Hold the Control Key down and use the numbered Function Keys to select the appropriate virtual screen.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3

    Default Re: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    @eng-int: I did not mean to switch between virtual screens (pressing Ctrl+F1/F2 indeed works). I meant windows, i.e. icons on task manager. For example I have pinned Firefox as #1, Konsole as #2, Dolphin as #3 and Lutris as #4. Now I want to press Meta+1/2/3/4 (actually Meta++/ě/š/č in my locale) to either start corresponding application or switch to it if it's already running. And I can't seem to figure this out :-(

  4. #4
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    450

    Default Re: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    Quote Originally Posted by kurcatovium View Post
    @eng-int: I did not mean to switch between virtual screens (pressing Ctrl+F1/F2 indeed works). I meant windows, i.e. icons on task manager. For example I have pinned Firefox as #1, Konsole as #2, Dolphin as #3 and Lutris as #4. Now I want to press Meta+1/2/3/4 (actually Meta++/ě/š/č in my locale) to either start corresponding application or switch to it if it's already running. And I can't seem to figure this out :-(
    Try Left Alt + Tab
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  5. #5
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,144

    Default Re: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    @kurcatovium
    Also you might also want to look in:
    System Settings > Workspace > Shortcuts
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  6. #6

    Default Re: KDE Plasma shortcut for Activate Task Manager Entry 1/2/3 with CZ keybord layout not working

    @kerijan2003: I know, it's the same shortcut as in Windows for general window swapping, but it's not exactly what I want. With my setup I know that when I press Meta+1, it's always fast way to Firefox. Meta+2 would always instantly put me to Konsole. Etc. I know it's nitpicking, but I'm really used to it and muscle memory is muscle memory...

    @eng-int: That's where I set the shortcuts. It's just it seems it doesn't work with CZ layout even when I set it up explicitly to work with our special characters (ěščř).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •