Results 1 to 2 of 2

Thread: iBus issues on Plasma 5

  1. #1

    Default iBus issues on Plasma 5

    I recently just switched to openSuSE as my daily and development system again, after many years. I have to say, I'm quite impressed and it's a pretty robust system (apart from the one frustrating issue of how dependencies are set up in RPM causing it to break most 3rd party RPMs, but that's a different issue) . Plasma 5 and iBus are new to me, and I'm having a few issues that are very frustrating.

    While I live in the US, I have a UK layout keyboard. However, iBus only gives two layouts for English (UK): Either Dvorak or UK with extended WinKeys. Dvorak is most definitely NOT my layout, and the WinKeys layout is mostly correct, but a few of the deadkeys are messed up, just in an annoying way. How do I get a plain old regular UK Qwerty layout in iBus?

    I used iBus because it was installed and I have to switch between layouts easily. I use Japanese - Anthy (Romaji input) as I also type in Japanese, and that works as it should from what I can tell (at least better than Mozc, which did not work at all).

    The other issue I have, is that the context menu for the iBus icon on the task panel will RANDOMLY open. As in it opens of it's own will, with no rhyme or reason. How do I get this to stop? It is driving me nuts. My mouse is definitely not right-clicking on that on it's own.

    Thanks so much in advance!

    (Apologies if this isn't in the right spot)
    Last edited by abjumpr; 09-Jan-2019 at 20:05. Reason: Added note PS

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: iBus issues on Plasma 5

    Quote Originally Posted by abjumpr View Post
    I recently just switched to openSuSE as my daily and development system again, after many years. I have to say, I'm quite impressed and it's a pretty robust system (apart from the one frustrating issue of how dependencies are set up in RPM causing it to break most 3rd party RPMs, but that's a different issue) . Plasma 5 and iBus are new to me, and I'm having a few issues that are very frustrating.

    While I live in the US, I have a UK layout keyboard. However, iBus only gives two layouts for English (UK): Either Dvorak or UK with extended WinKeys. Dvorak is most definitely NOT my layout, and the WinKeys layout is mostly correct, but a few of the deadkeys are messed up, just in an annoying way. How do I get a plain old regular UK Qwerty layout in iBus?

    I used iBus because it was installed and I have to switch between layouts easily. I use Japanese - Anthy (Romaji input) as I also type in Japanese, and that works as it should from what I can tell (at least better than Mozc, which did not work at all).

    The other issue I have, is that the context menu for the iBus icon on the task panel will RANDOMLY open. As in it opens of it's own will, with no rhyme or reason. How do I get this to stop? It is driving me nuts. My mouse is definitely not right-clicking on that on it's own.

    Thanks so much in advance!

    (Apologies if this isn't in the right spot)
    give fcitx a try instead of ibus. I believe it is more up to date and better supported in openSUSE.
    It has multiple EnglishUK keyboards and also fcitx-anthy (or better yet, fcitx-mozc) for Japanese input.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •