Results 1 to 7 of 7

Thread: Network Connectivity issues after upgrade to LEAP 15.0

  1. #1
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default Network Connectivity issues after upgrade to LEAP 15.0

    Hi guys,
    I upgraded from LEAP 42.3 to LEAP 15.0 on Friday and since then everytime I (re)boot up I experience chaallenges with network connectivity. It isn't until I select and enable Network Manager (Network Settings > Network Setup Method) and then switch back to Wicked Service that it gets back up and running. I use static IP configuration. Please advise

    I have included logs from my journalctl -xe

    https://pastebin.com/qk1SVxYc

    Code:
    doofenshmirtz:~ # systemctl status network.service
    ● wicked.service - wicked managed network interfaces
       Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
       Active: active (exited) since Mon 2019-01-14 11:22:08 EAT; 47s ago
      Process: 4141 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
     Main PID: 4141 (code=exited, status=0/SUCCESS)
    
    Jan 14 11:22:03 doofenshmirtz systemd[1]: Starting wicked managed network interfaces...
    Jan 14 11:22:08 doofenshmirtz wicked[4141]: lo              up
    Jan 14 11:22:08 doofenshmirtz wicked[4141]: em1             up
    Jan 14 11:22:08 doofenshmirtz systemd[1]: Started wicked managed network interface

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    My output from "systemctl status network.service" is almost identical to yours, except for the times.
    Code:
    # systemctl status network.service
    ● wicked.service - wicked managed network interfaces
       Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
       Active: active (exited) since Mon 2019-01-14 07:22:52 CST; 16h ago
      Process: 1527 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
     Main PID: 1527 (code=exited, status=0/SUCCESS)
        Tasks: 0 (limit: 4915)
       CGroup: /system.slice/wicked.service
    
    Jan 14 07:22:44 nwr2 systemd[1]: Starting wicked managed network interfaces...
    Jan 14 07:22:52 nwr2 wicked[1527]: lo              up
    Jan 14 07:22:52 nwr2 wicked[1527]: p4p2            enslaved
    Jan 14 07:22:52 nwr2 wicked[1527]: br0             up
    Jan 14 07:22:52 nwr2 systemd[1]: Started wicked managed network interfaces.
    I also have a bridge device for virtual machines, which is where that "br0" comes from.

    If you are using a static IP, you need to define the subnet mask, the Internet gateway and you need to define the DNS servers. My guess is that you missed something, and the switch to NetworkManager is fixing that for you -- but only temporarily.

    Things to check:

    Code:
    ip a
    route
    cat /etc/resolv.conf
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    Hi there, thank you for your response.
    I double and triple checked whether I had the IP, subnet mask and DNS configured as first point of troubleshooting before posting this

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    Did you check routing? Have you tried ping to other computers on your home LAN (using IP address)?
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Apr 2014
    Location
    Kampala, Uganda
    Posts
    95

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    Quote Originally Posted by nrickert View Post
    Did you check routing? Have you tried ping to other computers on your home LAN (using IP address)?
    I am not able to reach my GW (network unreachable) or any other IP until I switch to/from Network Manager which is when everything comes up. I had this same setup whilst on LEAP 42.3 and until I decided to upgrade I had no issues with my network setup. I run the upgrade by editing the repositories from 42.3 to 15.0.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    Okay. That's some more information.

    You should be able to ping other computers on your LAN, using IP address in the ping command, even without routing.

    To me, this suggests that the network card is not being completely initialized, and that NetworkManager is completing that job for you.

    Please file a bug report on this problem. And then post the bug number back in this thread.

    You can file the bug report here:

    openSUSE:Submitting bug reports

    Your forum login credentials should also work at the bugzilla.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    885

    Default Re: Network Connectivity issues after upgrade to LEAP 15.0

    Quote Originally Posted by MissSB View Post
    Hi guys,
    I upgraded from LEAP 42.3 to LEAP 15.0 on Friday and since then everytime I (re)boot up I experience chaallenges with network connectivity. It isn't until I select and enable Network Manager (Network Settings > Network Setup Method) and then switch back to Wicked Service that it gets back up and running. I use static IP configuration. Please advise
    Mine is:
    Code:
    erlangen:~ # journalctl -b -u wicked*
    -- Logs begin at Sun 2018-08-26 08:48:18 CEST, end at Wed 2019-01-16 15:42:06 CET. --
    Jan 16 09:24:28 erlangen systemd[1]: Starting wicked DHCPv6 supplicant service...
    Jan 16 09:24:29 erlangen systemd[1]: Starting wicked DHCPv4 supplicant service...
    Jan 16 09:24:29 erlangen systemd[1]: Starting wicked AutoIPv4 supplicant service...
    Jan 16 09:24:29 erlangen systemd[1]: Started wicked DHCPv6 supplicant service.
    Jan 16 09:24:29 erlangen systemd[1]: Started wicked DHCPv4 supplicant service.
    Jan 16 09:24:29 erlangen systemd[1]: Started wicked AutoIPv4 supplicant service.
    Jan 16 09:24:29 erlangen systemd[1]: Starting wicked network management service daemon...
    Jan 16 09:24:29 erlangen systemd[1]: Started wicked network management service daemon.
    Jan 16 09:24:29 erlangen systemd[1]: Starting wicked network nanny service...
    Jan 16 09:24:29 erlangen systemd[1]: Started wicked network nanny service.
    Jan 16 09:24:29 erlangen systemd[1]: Starting wicked managed network interfaces...
    Jan 16 09:24:29 erlangen wickedd[1033]: unable to translate eap protocol PWD
    Jan 16 09:24:30 erlangen wickedd-dhcp4[953]: wlp3s0: Request to acquire DHCPv4 lease with UUID 3dea3e5c-1fbd-0300-0904-000004000000
    Jan 16 09:24:30 erlangen wickedd-dhcp6[938]: wlp3s0: Request to acquire DHCPv6 lease with UUID 3dea3e5c-1fbd-0300-0904-000005000000 in mode auto
    Jan 16 09:24:31 erlangen wickedd-dhcp4[953]: wlp3s0: Committed DHCPv4 lease with address 192.168.178.29 (lease time 864000 sec, renew in 432000 sec, rebind in 756000 sec)
    Jan 16 09:24:34 erlangen wickedd-dhcp6[938]: wlp3s0: Committed DHCPv6 lease
    Jan 16 09:24:39 erlangen wicked[1050]: lo              up
    Jan 16 09:24:39 erlangen wicked[1050]: wlp3s0          up
    Jan 16 09:24:39 erlangen systemd[1]: Started wicked managed network interfaces.
    erlangen:~ #
    What is yours?
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •