Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Phonon device list incompelte

  1. #11
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: Phonon device list incompelte

    Sure!

    Code:
    cristiano@xmper8q3 [~]$ rpm -qa|grep phonon
    libphonon4-4.10.1-1.2.x86_64
    phonon4qt5-backend-vlc-0.10.1-1.3.x86_64
    phonon-backend-vlc-0.10.1-1.3.x86_64
    libphonon4qt5-4.10.1-1.2.x86_64
    phonon4qt5-backend-gstreamer-4.9.0-1.8.x86_64
    phonon-backend-gstreamer-4.9.0-1.9.x86_64
    Code:
    cristiano@xmper8q3 [~]$ LANG=C zypper lr -d
    #  | Alias                | Name                                      | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                   | Service
    ---+----------------------+-------------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
     1 | Insync               | Insync                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://yum.insynchq.com/fedora/28/                                                    |
     2 | code                 | Visual Studio Code                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://packages.microsoft.com/yumrepos/vscode                                        |
     3 | dukto                | home:colomboem                            | Yes     | (r ) Yes  | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/home:/colomboem/openSUSE_Tumbleweed/        |
     4 | home:munix9          | home:munix9:unstable                      | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/home:/munix9:/unstable/openSUSE_Tumbleweed/ |
     5 | home_ColinDuquesnoy  | home:ColinDuquesnoy (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/ColinDuquesnoy/openSUSE_Tumbleweed/   |
     6 | opensuseitalia       | home:opensuseitalia                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/opensuseitalia/openSUSE_Tumbleweed/   |
     7 | packman              | packman                                   | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                   |
     8 | repo-debug           | repo-debug                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/debug                                    |
     9 | repo-non-oss         | repo-non-oss                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss                                  |
    10 | repo-oss             | repo-oss                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss                                      |
    11 | repo-update          | repo-update                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                       |
    12 | skypeforlinux        | skypeforlinux                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable                                                     |
    13 | snappy               | snappy                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/system:/snappy/openSUSE_Tumbleweed/         |
    14 | sublime-text         | Sublime Text - x86_64 - Stable            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.sublimetext.com/rpm/stable/x86_64                                    |
    15 | teamviewer           | TeamViewer - x86_64                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://linux.teamviewer.com/yum/stable/main/binary-x86_64/                            |
    16 | telred-opensuse-42.2 | telred-opensuse-42.2                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://tel.red/repos/opensuse/42.2/                                                  |
    17 | vivaldi-beta         | vivaldi-beta                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://repo.vivaldi.com/snapshot/rpm/x86_64/                                          |
    18 | wavebox_beta         | Wavebox Beta - x86_64                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://wavebox.io/dl/client/repo_beta/yum/
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #12
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,179
    Blog Entries
    1

    Default Re: Phonon device list incompelte

    Hi Chris. Referring back to the system setting images you shared back in posts #1 and #9, I noticed that you only have the 'Device Preference' and 'Backend' tabs present. Usually, I would expect there to be 'Device Preferences', 'Audio Hardware Setup, and 'Backend'. FWIW, if I disable pulseaudio with
    Code:
    sudo setup-pulseaudio --disable
    and then examine the KDE multimedia tabs, I get just the tabs you have shown. (Note at this stage the pulseaudio daemon is still present, and will only be missing if restarting the desktop.)

    If I enable again with
    Code:
    sudo setup-pulseaudio --enable
    all three tabs are present again. So, it does seem that you have a problem with PA here. What is shown by the following?

    Code:
    sudo setup-pulseaudio --status
    Last edited by deano_ferrari; 16-Jan-2019 at 02:16.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #13
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: Phonon device list incompelte

    Hi Deano!

    Quote Originally Posted by deano_ferrari View Post
    Hi Chris. Referring back to the system setting images you shared back in posts #1 and #9, I noticed that you only have the 'Device Preference' and 'Backend' tabs present. Usually, I would expect there to be 'Device Preferences', 'Audio Hardware Setup, and 'Backend'. FWIW, if I disable pulseaudio with
    Code:
    sudo setup-pulseaudio --disable
    and then examine the KDE multimedia tabs, I get just the tabs you have shown. (Note at this stage the pulseaudio daemon is still present, and will only be missing if restarting the desktop.)

    If I enable again with
    Code:
    sudo setup-pulseaudio --enable
    all three tabs are present again. So, it does seem that you have a problem with PA here. What is shown by the following?

    Code:
    sudo setup-pulseaudio --status
    Here is mine:
    Code:
    cristiano@xmper8q3 [~]$ sudo setup-pulseaudio --status
    [sudo] password di root:
    enabled
    After reading your message I tried disabling and re-enabling, but I see no difference in system settings.

    Also, if you look at the thread I cited in my first post (this one) you'll see that he only has two tabs like me, but his Phonon device list is working properly.
    Maybe the 'Audio Hardware Setup' tab is hardware dependent?
    Out of curiosity, what backend are you using?

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,179
    Blog Entries
    1

    Default Re: Phonon device list incompelte

    Quote Originally Posted by Cris70 View Post
    Hi Deano!



    Here is mine:
    Code:
    cristiano@xmper8q3 [~]$ sudo setup-pulseaudio --status
    [sudo] password di root:
    enabled
    After reading your message I tried disabling and re-enabling, but I see no difference in system settings.
    Ok, it was worth a shot.

    [/QUOTE]Also, if you look at the thread I cited in my first post (this one) you'll see that he only has two tabs like me, but his Phonon device list is working properly.
    Maybe the 'Audio Hardware Setup' tab is hardware dependent?[/QUOTE]
    I'm not sure. I'm using openSUSE Leap 15, with KDE v5.12.6 so that might make a difference perhaps. Another TW user might be able to compare/verify here perhaps.

    Out of curiosity, what backend are you using?

    Cris
    I'm using the GStreamer backend (default).
    openSUSE Leap 15.0; KDE Plasma 5

  5. #15
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,179
    Blog Entries
    1

    Default Re: Phonon device list incompelte

    Quote Originally Posted by Cris70 View Post
    Hi Deano!



    Here is mine:
    Code:
    cristiano@xmper8q3 [~]$ sudo setup-pulseaudio --status
    [sudo] password di root:
    enabled
    After reading your message I tried disabling and re-enabling, but I see no difference in system settings.
    Ok, it was worth a shot.

    Also, if you look at the thread I cited in my first post (this one) you'll see that he only has two tabs like me, but his Phonon device list is working properly.
    Maybe the 'Audio Hardware Setup' tab is hardware dependent?
    I'm not sure. I'm using openSUSE Leap 15, with KDE v5.12.6 so that might make a difference perhaps. Another TW user might be able to compare/verify here perhaps.

    Out of curiosity, what backend are you using?

    Cris
    I'm using the GStreamer backend (default).
    openSUSE Leap 15.0; KDE Plasma 5

  6. #16
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: Phonon device list incompelte

    Suddenly today my home desktop computer is back to normal:

    Tomorrow I'll see if my work laptop is ok, too.

    Thank you to everyone who tried to help me with suggestions!
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  7. #17
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,179
    Blog Entries
    1

    Default Re: Phonon device list incompelte

    Thanks for the update. Good to read that it is working as expected currently.
    openSUSE Leap 15.0; KDE Plasma 5

  8. #18
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: Phonon device list incompelte

    Yes!! It works on the laptop too!


    I suspect this is due to the update of alsa-plugins-pulse:
    Code:
    (238/345) Installazione di: alsa-plugins-pulse-1.1.8-1.1.x86_64 ....................................................................................................................[fine]
    Output aggiuntivo di rpm:
    Enabling PulseAudio for ALSA...                                                                                                                                                           
    Enabling PulseAudio for libao...                                                                                                                                                          
    Default driver is pulse already in /etc/libao.conf                                                                                                                                        
    Enabling PulseAudio for mplayer...                                                                                                                                                        
    Enabling PulseAudio for OSS...                                                                                                                                                            
    Application aumix already setup for PulseAudio                                                                                                                                            
    Application sox already setup for PulseAudio                                                                                                                                              
    Enabling PulseAudio for SDL...                                                                                                                                                            
    Enabling PulseAudio for Timidity...                                                                                                                                                       
    Timidity already setup for using PulseAudio                                                                                                                                               
    Enabling PulseAudio for Phonon...                                                                                                                                                         
    Enabling PulseAudio for Kmix...                                                                                                                                                           
    Enabling PulseAudio for speech dispatcher...                                                                                                                                              
    Enabling PulseAudio for SoX...                                                                                                                                                            
    Setting auto sink/src for gstreamer                                                                                                                                                       
    Enabling PulseAudio for QEMU/KVM                                                                                                                                                          
    Enabling PulseAudio autospawn...                                                                                                                                                          
    Enabling PulseAudio for ALSA...                                                                                                                                                           
    Enabling PulseAudio for libao...                                                                                                                                                          
    Default driver is pulse already in /etc/libao.conf                                                                                                                                        
    Enabling PulseAudio for mplayer...                                                                                                                                                        
    Enabling PulseAudio for OSS...                                                                                                                                                            
    Application aumix already setup for PulseAudio                                                                                                                                            
    Application sox already setup for PulseAudio                                                                                                                                              
    Enabling PulseAudio for SDL...                                                                                                                                                            
    Enabling PulseAudio for Timidity...                                                                                                                                                       
    Timidity already setup for using PulseAudio                                                                                                                                               
    Enabling PulseAudio for Phonon...                                                                                                                                                         
    Enabling PulseAudio for Kmix...                                                                                                                                                           
    Enabling PulseAudio for speech dispatcher...                                                                                                                                              
    Enabling PulseAudio for SoX...                                                                                                                                                            
    Setting auto sink/src for gstreamer                                                                                                                                                       
    Enabling PulseAudio for QEMU/KVM                                                                                                                                                          
    Enabling PulseAudio autospawn...

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  9. #19
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,179
    Blog Entries
    1

    Default Re: Phonon device list incompelte

    I suspect this is due to the update of alsa-plugins-pulse:
    Perhaps so.
    openSUSE Leap 15.0; KDE Plasma 5

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •