Results 1 to 10 of 10

Thread: KPDF won't print PDF files

  1. #1

    Default KPDF won't print PDF files

    I don't often print PDF files, so I don't know when this problem appeared on my system; but when I try to print PDF files from KPDF in the Trinity DE suite, now I get these messages:

    Code:
    "The MIME type application/postscript is not supported as input of the filter chain (this may happen with non-CUPS spoolers when performing page selection on a non-Postscript file). Do you want TDE to convert the file to a supported format?           [Convert]               [Cancel]
    and after pressing [Convert]:

    Code:
    Select the target format for the conversion:
    text/html
    text/plain
    text/sgml
    text/x-c++hdr
    text/x-c++src
    text/x-chdr
    text/x-csrc
    text/x-java
    text/x-makefile
    text/x-pascal
    text/x-python
    text/x-tcl
    text/xml
    text/x-fortran
    application/x-perl
    application/x-perl-module
    application/x-python
    text/docbook
    text/x-log
    text/x-diff
    application/x-ruby
    [OK]         [Cancel]
    Selecting any of the above causes KPDF to close immediately without printing.

    It's not clear to me what 'filter chain' this message is referring to: a CUPS filter? a TDEprint filter? something in the MIME database that's maintained by Konqueror? or ?

    The Trinity-User mailing list suggests that I'm missing some printing component, but in all of the installations I've done from OpenSuSE 7 to Leap 15, all of the printing components (except the printer PPD) have been automagically installed by YaST, and printing PDFs has worked for me without doing anything special beyond installing the required PPD file; yet, now (relatively) suddenly I can't print PDFs.

    My printer is a Brother HL4150CDN laser printer, using the PPD packages provided by Brother (they haven't changed for years, and I doubt that the problem happens that far along in the printing process).

    Suggestions?
    Last edited by MisterSlippery; 28-Dec-2018 at 19:34. Reason: Clarification

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,645

    Default Re: KPDF won't print PDF files

    Did you install a driver from Brother's web site? Via linux-brprinter-installer script? i386 rpm? Last time I looked for my Brother HL5470DL (which I have on cat5e ethernet only), only i386 packages were available.

    With 42.3 and KDE3, KPDF prints normally. Same page on host gx62b in 15.0 with TDE 14.0.5 KPDF, trying to print same file to preview mode, with dmesg -w running in Konsole trying to monitor activity, pops up message "Preview failed: unable to start program Compress/Extract Files. Do you want to continue printing anyway?" Answering yes produced no dmesg or other apparent response. Tail of journal:
    Code:
    Dec 28 23:24:24 gx62b systemd[1]: Created slice User Slice of tst2000.
    Dec 28 23:24:24 gx62b systemd[1]: Starting User Manager for UID 2000...
    Dec 28 23:24:24 gx62b systemd[1409]: pam_unix(systemd-user:session): session opened for user tst2000 by (uid=0)
    Dec 28 23:24:24 gx62b systemd-logind[561]: New session 5 of user tst2000.
    Dec 28 23:24:24 gx62b systemd[1]: Started Session 5 of user tst2000.
    Dec 28 23:24:24 gx62b systemd[1409]: Starting D-Bus User Message Bus Socket.
    Dec 28 23:24:24 gx62b systemd[1409]: Reached target Paths.
    Dec 28 23:24:24 gx62b systemd[1409]: Reached target Timers.
    Dec 28 23:24:24 gx62b systemd[1409]: Listening on D-Bus User Message Bus Socket.
    Dec 28 23:24:24 gx62b systemd[1409]: Reached target Sockets.
    Dec 28 23:24:24 gx62b systemd[1409]: Reached target Basic System.
    Dec 28 23:24:24 gx62b systemd[1409]: Reached target Default.
    Dec 28 23:24:24 gx62b systemd[1409]: Startup finished in 126ms.
    Dec 28 23:24:24 gx62b systemd[1]: Started User Manager for UID 2000.
    Dec 28 23:24:24 gx62b [1179]: pam_unix(xdm-np:session): session opened for user tst2000 by (uid=0)
    Dec 28 23:24:24 gx62b systemd[1409]: Started D-Bus User Message Bus.
    Dec 28 23:24:24 gx62b dbus-daemon[1449]: [session uid=2000 pid=1449] Successfully activated service 'org.freedesktop.systemd1'
    Dec 28 23:25:15 gx62b su[1729]: (to root) tst2000 on pts/5
    Dec 28 23:25:15 gx62b su[1729]: pam_systemd(su-l:session): Cannot create session: Already running in a session or user slice
    Dec 28 23:25:15 gx62b su[1729]: pam_unix(su-l:session): session opened for user root by tst2000(uid=2000)
    Dec 28 23:33:41 gx62b systemd[1]: Starting Cleanup of Temporary Directories...
    Dec 28 23:33:41 gx62b systemd-tmpfiles[21843]: [/usr/lib/tmpfiles.d/tmp.conf:13] Duplicate line for path "/var/tmp", ignoring.
    Dec 28 23:33:41 gx62b systemd-tmpfiles[21843]: [/usr/lib/tmpfiles.d/var.conf:21] Duplicate line for path "/var/lib", ignoring.
    Dec 28 23:33:41 gx62b systemd-tmpfiles[21843]: [/usr/lib/tmpfiles.d/var.conf:23] Duplicate line for path "/var/spool", ignoring
    /var/log/cups/access_log seems to indicate only success:
    Code:
    localhost - - [13/Jan/2016:03:19:36 -0500] "POST /printers/HL5470DW HTTP/1.1" 200 493 Send-Document successful-ok
    localhost - - [28/Dec/2018:23:28:39 -0500] "POST /printers/HL5470DW HTTP/1.1" 200 234 Create-Job successful-ok
    localhost - - [28/Dec/2018:23:28:39 -0500] "POST /printers/HL5470DW HTTP/1.1" 200 82015 Send-Document successful-ok
    localhost - - [28/Dec/2018:23:37:25 -0500] "POST /printers/HL5470DW HTTP/1.1" 200 253 Create-Job successful-ok
    localhost - - [28/Dec/2018:23:37:25 -0500] "POST /printers/HL5470DW HTTP/1.1" 200 82015 Send-Document successful-ok
    I have no idea what tail of /var/log/cups/error_log means (other than IPV6 not supposed to be used):
    Code:
    E [22/Nov/2018:20:59:49 -0500] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
    W [22/Nov/2018:21:24:39 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [22/Nov/2018:21:24:39 -0500] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [22/Nov/2018:21:24:39 -0500] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
    W [28/Dec/2018:23:19:22 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [28/Dec/2018:23:19:22 -0500] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [28/Dec/2018:23:19:22 -0500] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
    Oh, Firefox and Konq produce similar non-response from the Brother. So, I tried another PC with 15.0 and TDE, fi965, with same PDF file, also to preview mode. This too produced a popup:
    Code:
    Preview failed: neither the internal TDE PostScript viewer (KGhostView) nor any other external PostScript viewer could be found.
    So I tried printing to the Brother from Firefox, and get nothing from it either, even though root gets a good test page from YaST2. Trying lpr somefile produces a no default printer message. lpr -P /dev/lp0 somefile produces no such file or directory. Next PC I wanted to try hasn't had the HL5470DL installed yet, so I'm going to wait with it until this gets resolved.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  3. #3

    Default Re: KPDF won't print PDF files

    Printing PDFs via lpr works just fine, but kpdf won't work. In the past, printing from kpdf has worked on Leap 15 since I upgraded to it (until this started happening). I checked my installation and the Brother drivers are installed properly, and as I say, lpr has no problem printing PDFs, so it has to be an issue with kpdf (or some other component(s) of Trinity R14.0.5).

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: KPDF won't print PDF files

    IMHO you'd best contact the Trinity/KPDF devs.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: KPDF won't print PDF files

    Quote Originally Posted by Knurpht View Post
    IMHO you'd best contact the Trinity/KPDF devs.
    Yes. I did, and they suggested I should talk with you. :-) I am still pursuing the issue with them; I mostly wanted to check with you to get an understanding of what the business of the MIME stuff is all about.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,289
    Blog Entries
    1

    Default Re: KPDF won't print PDF files

    Do you have the 'cups-filters' package installed? Other printing components that might be relevant here are the 'ghostscript' and 'poppler' packages.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,645

    Default Re: KPDF won't print PDF files

    Quote Originally Posted by deano_ferrari View Post
    Do you have the 'cups-filters' package installed? Other printing components that might be relevant here are the 'ghostscript' and 'poppler' packages.
    Maybe one of more of these is my problem (a result of failing dependencies, packages that maybe Brother's scripts should require but don't?). I routinely run
    Code:
    zypper pa --unneeded; df /
    and then remove whatever it lists. I recall *cups*, ghostscript* and *poppler* commonly showing up in that output.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,289
    Blog Entries
    1

    Default Re: KPDF won't print PDF files

    Quote Originally Posted by mrmazda View Post
    Maybe one of more of these is my problem (a result of failing dependencies, packages that maybe Brother's scripts should require but don't?). I routinely run
    Code:
    zypper pa --unneeded; df /
    and then remove whatever it lists. I recall *cups*, ghostscript* and *poppler* commonly showing up in that output.
    I don't know that the problem you describe is related to the OP's at all. In any case, I would recommend putting CUPS into debug mode first with
    Code:
    cupsctl --debug-logging
    then examine /var/log/cups/error_log for filter errors (or similar).
    Last edited by deano_ferrari; 16-Jan-2019 at 10:53.
    openSUSE Leap 15.0; KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,289
    Blog Entries
    1

    Default Re: KPDF won't print PDF files

    This Fedora CUPS debugging guide is a good reference IMHO...
    https://fedoraproject.org/wiki/How_t...nting_problems
    openSUSE Leap 15.0; KDE Plasma 5

  10. #10

    Default Re: KPDF won't print PDF files

    Quote Originally Posted by deano_ferrari View Post
    I don't know that the problem you describe is related to the OP's at all. In any case, I would recommend putting CUPS into debug mode first with
    Code:
    cupctl --debug-logging
    then examine /var/log/cups/error_log for filter errors (or similar).
    I doubt very much that CUPS is the problem. I am able to print PDF files with lpr and also with Document Viewer (which is a Gnome app, I think).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •