Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: No broadband access on Thinkpad T430

  1. #1

    Default No broadband access on Thinkpad T430

    I have no broadband access on a Thinkpad T430 running Leap 15.0 with a KDE/Plasma desktop, Do I need to install (k)networkmanager. I use Ethernet to a hub and to an AT&T modem. Light in the TPs RJ socket is lit when Ethernet plug is inserted and lights on the hub's RJ socket are lit,, but not flashsing. The light of the Ethernet cable from the modem to the hub is lit and flashing. It appears that I don't have firewall installed. Broadband was working and perhaps installation of xorg-x11-driver-video may be associated with loss of broadband. Wireless on the T430 is turned off.

  2. #2

    Default Re: No broadband access on Thinkpad T430

    Leap 15 - KDE/Plasma

    I have loaded Ubuntu 18 from a live DVD and found that I have a broadband connection, so this problem must be in the way that I have Leap 15 configured and not a problem with my broadband service.

    Wireless is disabled in BIOS

    From the popup from the Leap 15 Networks icon in the task bar:

    Wired connection 1

    Automatically connect to this network when it is available
    All users may connect to this network

    Restrict to device: eth0 (28:2:44:18:BO:CC)
    Duplex: Half
    (Other fields are blank)

    Use 802.1x security for this connection - Not checked

    IPv4 and IPv6 are both set to Automatic and IPv6 Privacy: Default

    Hope that helps.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,989
    Blog Entries
    3

    Default Re: No broadband access on Thinkpad T430

    Quote Originally Posted by b_martin View Post
    Do I need to install (k)networkmanager.
    Both NetworkManager and the KDE applet should be installed already. They are a part of a standard KDE install.

    You might need to use:

    Yast --> System --> Network settings

    to switch to using NetworkManager instead of "wicked". However, I would have expected that to be the default setting already.
    openSUSE Leap 15.0; KDE Plasma 5;

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,370
    Blog Entries
    1

    Default Re: No broadband access on Thinkpad T430

    Quote Originally Posted by b_martin View Post
    From the popup from the Leap 15 Networks icon in the task bar:
    Wired connection 1

    Automatically connect to this network when it is available
    All users may connect to this network

    Restrict to device: eth0 (28:2:44:18:BO:CC)
    Duplex: Half
    (Other fields are blank)

    The half duplex reported is a bit strange. I would normally expect full duplex, and this might be indicative of a faulty cable, port, or driver.

    Some definitive information would be useful here...

    Network hardware details
    Code:
    /sbin/lspci -nnk|grep -iA3 net
    Query ethernet negotiation and hardware details
    Code:
    /usr/sbin/ethtool eth0
    IP address assigned (if any)
    Code:
    ip a
    Route(s) (if any)
    Code:
    ip r
    I suggest copy/pasting the output to a text file, transfer to a memory stick, and then post the info via a machine with internet connectivity.
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5

    Default Re: No broadband access on Thinkpad T430

    I thought it was unlikely that cables or external ports were the problem, but in case I swapped cables with the Thinkpad I am using here running 13.2 and this one still works while the T430 still doesn't. I also think it is unlikely that the ethernet port on the T430 is faulty since it worked with the live ubuntu boot. Both Thinkpads are connected to a Netgear hub. Drivers might be involved since I had broadband connectivity on the T430 before installing the video driver -- xorg-x11-driver-video. I have also run these cmds getting the video problems sorted:

    Code:
    mkinitrd
    Code:
    mkinitrf -A
    ...although I didn't think to save the responses, though both succeeded.

    Here is the trace of the commands you suggested, run as root:

    Code:
    Password: 
    linux-muav:~ # /sbin/lspci -nnk|grep -iA3 net
    00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) [8086:1502] (rev 04)
            Subsystem: Lenovo Device [17aa:21f3]
            Kernel driver in use: e1000e
            Kernel modules: e1000e
    --
    03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
            Subsystem: Intel Corporation Centrino Advanced-N 6205 (802.11a/b/g/n) [8086:1311]
            Kernel driver in use: iwlwifi
            Kernel modules: iwlwifi
    linux-muav:~ # /usr/sbin/ethtool eth0
    Settings for eth0:
            Supported ports: [ TP ]
            Supported link modes:   10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Full 
            Supported pause frame use: No
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Full 
            Advertised pause frame use: No
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: Twisted Pair
            PHYAD: 1
            Transceiver: internal
            Auto-negotiation: on
            MDI-X: off (auto)
            Supports Wake-on: pumbg
            Wake-on: d
            Current message level: 0x00000007 (7)
                                   drv probe link
            Link detected: yes
    linux-muav:~ # ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo                                                                                      
           valid_lft forever preferred_lft forever                                                                          
        inet6 ::1/128 scope host                                                                                            
           valid_lft forever preferred_lft forever                                                                          
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000                   
        link/ether 28:d2:44:18:b0:cc brd ff:ff:ff:ff:ff:ff                                                                  
        inet 192.168.1.67/24 brd 192.168.1.255 scope global noprefixroute dynamic eth0                                      
           valid_lft 85840sec preferred_lft 85840sec                                                                        
        inet6 2600:1702:30b0:b710:692c:d412:4988:5f67/64 scope global temporary dynamic                                     
           valid_lft 3537sec preferred_lft 3537sec
        inet6 2600:1702:30b0:b710:774b:c057:10b0:3882/64 scope global mngtmpaddr noprefixroute dynamic 
           valid_lft 3537sec preferred_lft 3537sec
        inet6 fe80::50bb:892b:15fd:ee50/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether de:c2:a8:31:94:80 brd ff:ff:ff:ff:ff:ff
    linux-muav:~ # ip r
    default via 192.168.1.254 dev eth0 proto dhcp metric 20100 
    192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.67 metric 100 
    linux-muav:~ #
    Would it have been preferable here to have reported these as separate code blocks?

    While in yast I noticed that the firewall is apparently installed, but not configured. I checked to see if Yast was controlling networks and it was not; the install default is apparently networkmanager.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,370
    Blog Entries
    1

    Default Re: No broadband access on Thinkpad T430

    The ethtool output confirms a problem with negotiation (10Mbps, half-duplex), but it appears that the NIC is getting a DHCP assigned IP address and a valid default route exists.

    FWIW, I recall a similar thread a few months back where a user had an unintended NetworkManager connection configuration where the negotiation was set incorrectly. (Usually, no explicit configuration is required.) Anyway, you can check that via the connection editor or examine the connection profile located in the
    /etc/NetworkManager/system-connections/ directory.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,370
    Blog Entries
    1

    Default Re: No broadband access on Thinkpad T430

    openSUSE Leap 15.0; KDE Plasma 5

  8. #8

    Default Re: No broadband access on Thinkpad T430

    Quote Originally Posted by deano_ferrari View Post

    Yes it seems to be a similar problem, though there a working connection existed, where here NetworkManager thinks there is a connection, where there actually isn't:

    Re: Slow internet on Tumbleweed compared to Fedora
    Originally Posted by equeim
    Yep, after reboot it's ok too. Connection config file in /etc/NetworkManager/system-connections/ had fields that disabled auto-negotiation and enabled half duplex. No idea how they got there (maybe when I switched from wicked to NetworkManager). I just removed this file and NetworkManager set up everything correctly.


    I was a little hesitant to delete an existing configuration file without a backup, so I tried this:

    Code:
    linux-muav:/etc/NetworkManager/system-connections # cp Wired connection 1 /home/n_nullo/Buffer/
    cp: cannot stat 'Wired': No such file or directory
    cp: cannot stat 'connection': No such file or directory
    cp: cannot stat '1': No such file or directory
    linux-muav:/etc/NetworkManager/system-connections # ls
    Wired connection 1
    linux-muav:/etc/NetworkManager/system-connections #
    I am not familiar with the Kate editor or with file naming rules in Leap, but since the OS named this connection file, it seems odd that it objects to an attempt to copy that file to another directory. Maybe I am not understanding the error msg "cannot stat <file name>".

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,989
    Blog Entries
    3

    Default Re: No broadband access on Thinkpad T430

    Quote Originally Posted by b_martin View Post
    Code:
    linux-muav:/etc/NetworkManager/system-connections # cp Wired connection 1 /home/n_nullo/Buffer/
    That needs to be:
    Code:
    cp "Wired connection 1" /home/n_nullo/Buffer/
    A space is a word separator. So you need quotes to treat that name as a single word.

    Yes, connection files copy without a problem. I've done that here, to make a backup. However, normally that file does not exist unless you have modified the connection by changing from some of the defaults.
    openSUSE Leap 15.0; KDE Plasma 5;

  10. #10

    Default Re: No broadband access on Thinkpad T430

    Quote Originally Posted by nrickert View Post
    That needs to be:
    Code:
    cp "Wired connection 1" /home/n_nullo/Buffer/
    A space is a word separator. So you need quotes to treat that name as a single word.

    .
    Just curious. I remember a file system rule in the Windows/OS2 world that disallowed spaces in file names, but then I think that got relaxed. That seems to be still a safe rule for Linux file names but not always followed?


    Re: Slow internet on Tumbleweed compared to Fedora
    Originally Posted by equeim
    Yep, after reboot it's ok too. Connection config file in /etc/NetworkManager/system-connections/ had fields that disabled auto-negotiation and enabled half duplex. No idea how they got there (maybe when I switched from wicked to NetworkManager). I just removed this file and NetworkManager set up everything correctly.


    I copied then deleted the "Wired connection 1" file, rebooted and that file got recreated, still with Allow auto-negotiation initially not enabled. I clicked the enable box, rebooted and the Allow auto-negotiation was still enabled, but no broadband connection.

    I think the screens I am seeing in the Edit your Network Connections frame may be slightly different than before. For example, I think it was on the then second tab that I saw this:

    Restrict to device: eth0 (28:2:44:18:BO:CC)
    Duplex: Half
    (Other fields are blank)

    ...and now the Wired tab has no Duplex information, only the Restrict to device, Cloned MAC address and MTU fields plus the Allow auto-negotiation switch.

    I have rerun the diagnostic cmds that you sent earlier in the chance that some things have changed.

    Code:
    Password: 
    linux-muav:~ # /sbin/lspci -nnk|grep -iA3 net
    00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) [8086:1502] (rev 04)
            Subsystem: Lenovo Device [17aa:21f3]
            Kernel driver in use: e1000e
            Kernel modules: e1000e
    --
    03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
            Subsystem: Intel Corporation Centrino Advanced-N 6205 (802.11a/b/g/n) [8086:1311]
            Kernel driver in use: iwlwifi
            Kernel modules: iwlwifi
    linux-muav:~ # /usr/sbin/ethtool eth0
    Settings for eth0:
            Supported ports: [ TP ]
            Supported link modes:   10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Full 
            Supported pause frame use: No
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Full 
            Advertised pause frame use: No
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: Twisted Pair
            PHYAD: 1
            Transceiver: internal
            Auto-negotiation: on
            MDI-X: off (auto)
            Supports Wake-on: pumbg
            Wake-on: d
            Current message level: 0x00000007 (7)
                                   drv probe link
            Link detected: yes
    linux-muav:~ # ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo                                                                                      
           valid_lft forever preferred_lft forever                                                                          
        inet6 ::1/128 scope host                                                                                            
           valid_lft forever preferred_lft forever                                                                          
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000                   
        link/ether 28:d2:44:18:b0:cc brd ff:ff:ff:ff:ff:ff                                                                  
        inet 192.168.1.67/24 brd 192.168.1.255 scope global noprefixroute dynamic eth0                                      
           valid_lft 83672sec preferred_lft 83672sec                                                                        
        inet6 2600:1702:30b0:b710:b8fc:f57b:e712:4f53/64 scope global temporary dynamic                                     
           valid_lft 3512sec preferred_lft 3512sec
        inet6 2600:1702:30b0:b710:774b:c057:10b0:3882/64 scope global mngtmpaddr noprefixroute dynamic 
           valid_lft 3512sec preferred_lft 3512sec
        inet6 fe80::50bb:892b:15fd:ee50/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether 9e:4f:d0:c7:cc:cb brd ff:ff:ff:ff:ff:ff
    linux-muav:~ # ip r
    default via 192.168.1.254 dev eth0 proto dhcp metric 20100 
    192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.67 metric 100 
    linux-muav:~ #
    I've also done screenshots of the Network Settings screen:

    ...Well I thought I could, but the Insert Image tool wants a url and doesn't allow me to browse local volumes for a file. If there is a way to refer to a local file as a url, I'd be glad to learn how.

    I think I am here:

    • Hardware/cables have been proven good
    • NetworkManager has control of network parameters
    • NetworkManager thinks I have a network connection, but I don't
    • DCHP has assigned an address
    • According to the LEDs on my hub, the port to the TP 430 is at least getting polled
    • Deleting and allowing the connection file to be recreated doesn't solve the problem

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •