Results 1 to 5 of 5

Thread: Can't run FreeCAD on latest tumbleweed

  1. #1

    Unhappy Can't run FreeCAD on latest tumbleweed

    rparkins48:~ # zypper install FreeCAD
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following NEW package is going to be installed:
    FreeCAD

    1 new package to install.
    Overall download size: 170.1 MiB. Already cached: 0 B. After the operation, additional
    270.2 MiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    Retrieving package FreeCAD-0.17.1534399137.9948ee4f1-1.4.x86_64
    (1/1), 170.1 MiB (270.2 MiB unpacked)
    Retrieving: FreeCAD-0.17.1534399137.9948ee4f1-1.4.x86_64.rpm ........[done (786.3 KiB/s)]
    Checking for file conflicts: ......................................................[done]
    (1/1) Installing: FreeCAD-0.17.1534399137.9948ee4f1-1.4.x86_64 ....................[done]

    rparkins@rparkins48:~> FreeCAD
    FreeCAD: /usr/lib64/libQt5Qml.so.5: version `Qt_5.11.2_PRIVATE_API' not found (required by /usr/lib64/libpyside2.cpython-36m-x86_64-linux-gnu.so.5.11)

    Details of my system:
    rparkins48:~ # uname -a
    Linux rparkins48 4.19.11-1-default #1 SMP PREEMPT Thu Dec 20 09:45:14 UTC 2018 (096f733) x86_64 x86_64 x86_64 GNU/Linux
    rparkins48:~ # cat /etc/issue
    Welcome to openSUSE Tumbleweed 20181224 - Kernel \r (\l).

    em1: \4{em1} \6{em1}
    rparkins48:~ # zypper repos
    Repository priorities are without effect. All enabled repositories share the same priority.

    # | Alias | Name | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------+---------+-----------+--------
    1 | NVIDIA | NVIDIA | Yes | (r ) Yes | Yes
    2 | http-download.opensuse.org-9ec80e91 | home:szotsaki | Yes | (r ) Yes | Yes
    3 | http-download.opensuse.org-b4bf2097 | security | Yes | (r ) Yes | Yes
    4 | http-download.opensuse.org-de18b7db | openSUSE:Factory | Yes | (r ) Yes | Yes
    5 | openSUSE-20181219-0 | openSUSE-20181219-0 | Yes | (r ) Yes | No
    6 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ----
    7 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes
    8 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes
    9 | repo-source | openSUSE-Tumbleweed-Source | Yes | (r ) Yes | Yes
    10 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes
    rparkins48:~ # zypper list-updates
    Loading repository data...
    Reading installed packages...
    No updates found.


  2. #2

    Default Re: Can't run FreeCAD on latest tumbleweed

    As requested:-
    Code:
    rparkins48:~ # zypper lr -d
    #  | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                        | Service
    ---+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------+--------
     1 | NVIDIA                              | NVIDIA                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.0                             |        
     2 | http-download.opensuse.org-9ec80e91 | home:szotsaki               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/szotsaki/openSUSE_Factory/ |        
     3 | http-download.opensuse.org-b4bf2097 | security                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_Factory/       |        
     4 | http-download.opensuse.org-de18b7db | openSUSE:Factory            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory/snapshot/      |        
     5 | openSUSE-20181219-0                 | openSUSE-20181219-0         | Yes     | (r ) Yes  | No      |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-MATSHITA_DVD+_-RW_UJ8E2_H086_510462     |        
     6 | repo-debug                          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                    |        
     7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                      |        
     8 | repo-oss                            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                          |        
     9 | repo-source                         | openSUSE-Tumbleweed-Source  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/source/tumbleweed/repo/oss/                   |        
    10 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                            |

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,864

    Default Re: Can't run FreeCAD on latest tumbleweed

    I am not a Tumbleweed user. nor do I use FreeCad, thus my remarks maybe a bit off topic.

    1. repo #5 is your installation device. Better disable that one, else it could be that it is asked for every time you start zypper or YaST > Software;
    2. I am not sure it is a good idea to have a Factory repo when you are already using Tumbleweed.
    Henk van Velden

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,887

    Default AW: Can't run FreeCAD on latest tumbleweed


  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    899

    Default Re: Can't run FreeCAD on latest tumbleweed

    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •