I have a strange problem. The phone I'm talking about is an HTC ONE A9. I have also tried with a Microsoft Lumia 640XL with the same result.

This is what happens:
STEP 1> Connect the phone using a data cable to an USB port of the laptop.

STEP 2> Pop up appears on phone asking me to select an option.
My available choices are:
(a) Charge the device- just charge this phone,
(b) Transfer Files- Transfer Media to/ from your computer,
(c) CD Installer- install HTC SyncManager on Windows or Mac,
(d) USB Tether- Share this phones data connection with your computer,
(e) Use device as MIDI- Connect to MIDI instruments.

STEP 3> I touch on option (b) Transfer Files,,,

STEP 4> KDE Device Notifier pops up, and asks if I want to import pictures or open in file manager.



STEP 5> I click on "Open with file manager", and get this message:



The same problem is present with my Lumia phone as well.
I have tried them on my Windows laptop, both phones work fine in Windows, and allow me to access the phone memory/ memory card in Windows Explorer.
In OpenSuse, my Android phone (HTC) works fine with KDE Connect (allows me to control the computer from my phone), but when connected with USB, the above behavior returns.
What's causing this? Can it be fixed?
Thank you.