Results 1 to 9 of 9

Thread: opengl can not use in livecd

  1. #1

    Exclamation opengl can not use in livecd

    livecd

    there is no libGLU.so
    so , opengl can not use.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: opengl can not use in livecd

    Which livecd?

    Did you actually attempt to do something that requires openGL?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: opengl can not use in livecd

    Quote Originally Posted by aman2019 View Post
    livecd

    there is no libGLU.so
    so , opengl can not use.
    I fail to see any connection with "Forums Comments/Suggestioons were this is posted.

    Please inform us about which version of openSUSE this is and it will then most probably be moved to Install/Boot/Login.
    Henk van Velden

  4. #4

    Default Re: opengl can not use in livecd

    openSUSE-Leap-15.0-GNOME-Live-x86_64-Current.iso

    /usr/lib64

    there have libGL.so libGLE.so
    but , no libGLU.so

    so,program use opengl can not run.

  5. #5

    Default Re: opengl can not use in livecd

    Quote Originally Posted by nrickert View Post
    Which livecd?

    Did you actually attempt to do something that requires openGL?
    openSUSE-Leap-15.0-GNOME-Live-x86_64-Current.iso

    cp libGLU.so.x /usr/lib64
    or
    sudo apt-get install libGLU*

    then,all ok!

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: opengl can not use in livecd

    This will be moved to Instal/Boot/Login and is CLOSED for the moment.
    Henk van Velden

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: opengl can not use in livecd

    Quote Originally Posted by aman2019 View Post
    I'm still not sure what live iso that is, because they are updated from time to time.

    If I look there, I currently see Snapshot20.116, and if you downloaded in the last few days that would be what you have. If you downloaded earlier than that, it might be an earlier snapshot.

    Gnome won't even load without openGL, but perhaps it doesn't use that particular library.

    Last evening, soon after you posted, I checked the live KDE, though an older version. And libGLU.so.1 was there. I'll download and check the Gnome media later today.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: opengl can not use in livecd

    Quote Originally Posted by aman2019 View Post
    livecd

    there is no libGLU.so
    so , opengl can not use.
    Moved from Forums Comments/Suggestions and open again.
    Henk van Velden

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: opengl can not use in livecd

    I have downloaded:
    Code:
    -rw-r--r-- 1 qemu    qemu   970981376 Dec 22 14:35 openSUSE-Leap-15.0-GNOME-Live-x86_64-Snapshot20.116-Media.iso
    which is probably the live iso that you used (it also goes by the name "openSUSE-Leap-15.0-GNOME-Live-x86_64-Current.iso", but I prefer the more specific name).

    I then booted it in a KVM virtual machine. And it seems to run fine. So the live CD has all of the openGL libraries needed by Gnome. It does not seem to have the library that you mentioned, but apparently Gnome does not need that.

    The live CD is a demo. It's purpose is to demonstrate the software.

    If you use the live CD to install, that install does not simply copy what's on the CD. Rather, it will install from the repos. So you should end up with a pretty good collection of useful software. Maybe give that a try.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •