Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: starting kde it shows and use always english US keyboard insteda english UK

  1. #1

    Default starting kde it shows and use always english US keyboard insteda english UK

    starting kde it shows and use always english US keyboard insteda english UK, I have to switch every time to english UK keyboard.
    yast>hardware>system keyboard layout settings shows at first position English(UK) and second English(US)
    yast>system>language settings>primary language settings shows as primary language English (UK)
    kde system settings>input devices>keyboard>layouts label shows at first position English(UK) and English(US) is absent
    kde system settings>regional settings>language shows at first position british english (default) and at second position American english
    what I have to set to have english (UK) as default keyboard layout?? and so, when I boot in kde it will be used and I have not to switch to it from english (US)
    manythanks and happy christmas :-)

    P.S.
    may be this can help, when I launch konsole as superuser it ask me password, and gives this error:
    Code:
    Password: 
    -bash: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8,LANG=en_GB.UTF-8): No such file or directory

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    816

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by pier_andreit View Post
    starting kde it shows and use always english US keyboard insteda english UK, I have to switch every time to english UK keyboard.
    yast>hardware>system keyboard layout settings shows at first position English(UK) and second English(US)
    yast>system>language settings>primary language settings shows as primary language English (UK)
    kde system settings>input devices>keyboard>layouts label shows at first position English(UK) and English(US) is absent
    kde system settings>regional settings>language shows at first position british english (default) and at second position American english
    what I have to set to have english (UK) as default keyboard layout?? and so, when I boot in kde it will be used and I have not to switch to it from english (US)
    manythanks and happy christmas :-)

    P.S.
    may be this can help, when I launch konsole as superuser it ask me password, and gives this error:
    Code:
    Password: 
    -bash: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8,LANG=en_GB.UTF-8): No such file or directory
    Make sure your locale exists:

    Code:
    erlangen:~ # rpm -qf /usr/lib/locale/en_GB.utf8/
    glibc-locale-2.27-6.1.x86_64
    erlangen:~ #
    You may want to reinstall or generate: https://forums.opensuse.org/showthre...o-I-set-locale and https://forums.opensuse.org/showthre...de_CH-problems
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  3. #3

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by karlmistelberger View Post
    Make sure your locale exists:

    Code:
    erlangen:~ # rpm -qf /usr/lib/locale/en_GB.utf8/
    glibc-locale-2.27-6.1.x86_64
    erlangen:~ #
    does this means that my locale exist?
    Code:
    pla-3-TW:~ # rpm -qf /usr/lib/locale/en_GB.utf8/
    glibc-locale-2.26-lp150.11.9.1.x86_64
    pla-3-TW:~ #
    Quote Originally Posted by karlmistelberger View Post
    I cannot find what and how to reinstall or generate and where to put the file when generated :-) I will read better
    manythanks, ciao, pier :-)

  4. #4

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    ...and furthermore, my problem is keyboard layout not language. why does keyboard layout interest or is involved with language??

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    816

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by pier_andreit View Post
    ...and furthermore, my problem is keyboard layout not language. why does keyboard layout interest or is involved with language??
    From your original post:

    may be this can help, when I launch konsole as superuser it ask me password, and gives this error:
    Code:

    Password:
    -bash: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8,LANG=en_GB.UTF-8): No such file or directory
    Bash warning is related to language, which has system defaults and user settings: https://forums.opensuse.org/showthre...82#post2890082

    Keyboard system defaults are defined here: /etc/sysconfig/keyboard

    You may select user settings at System Settings > Hardware > Input Devices > Keyboard > Keyboard model.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #6

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by karlmistelberger View Post
    From your original post:

    Bash warning is related to language, which has system defaults and user settings: https://forums.opensuse.org/showthre...82#post2890082

    Keyboard system defaults are defined here: /etc/sysconfig/keyboard

    You may select user settings at System Settings > Hardware > Input Devices > Keyboard > Keyboard model.
    ..uh, sorry, you are right, I was thinking that it could be useful to the keyboard problem :-)
    and here is the content of /etc/sysconfig/keyboard, ...it seems UK YAST_KEYBOARD="english-uk,pc104"
    Code:
    ## Path:        Hardware/Keyboard
    ## Description: Keyboard settings for the text console
    ## Type:        integer
    ## Default:
    ## ServiceRestart: kbdsettings
    #
    # Keyboard delay time in ms (250, 500, 750, 1000)
    KBD_DELAY=""
    
    ## Type:    string(2.0,2.1,2.3,2.5,2.7,3.0,3.3,3.7,4.0,4.3,4.6,5.0,5.5,6.0,6.7,7.5,8.0,8.6,9.2,10.0,10.9,12.0,13.3,15.0,16.0,17.1,18.5,20.0,21.8,24.0,26.7,30.0)
    ## Default:
    #
    # Keyboard repeat rate (2.0 - 30.0)
    KBD_RATE=""
    
    ## Type:        list(bios,yes,no)
    ## Default:     bios
    #
    # NumLock on? ("yes" or "no" or empty or "bios" for BIOS setting)
    # This setting may interfere with GNOME /desktop/gnome/peripherals/keyboard/remember_numlock_state GConf key.
    KBD_NUMLOCK="bios"
    
    ## Type:        yesno
    ## Default:     no
    #
    # ScrollLock on? ("yes" or "no")
    KBD_SCRLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # CapsLock on? ("yes" or "no")
    KBD_CAPSLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # Disable CAPS LOCK and make it a normal Shift key?
    # (Ctrl Caps Lock will still toggle Caps Lock functionality)
    # Note that you need to tweak the xkb maps or use xmodmap
    # if you want to do the same under X-Windows. In ~/.Xmodmap:
    # keycode 0x42 = Shift_L Shift_L
    #
    KBD_DISABLE_CAPS_LOCK="no"
    
    ## Type:        string
    ## Default:
    #
    # ttys for the above settings 
    # Example: "tty1 tty2"
    # "" for tty's 1-6
    #
    KBD_TTY=""
    
    # The YaST-internal identifier of the attached keyboard.
    #
    YAST_KEYBOARD="english-uk,pc104"

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    816

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by pier_andreit View Post
    ..uh, sorry, you are right, I was thinking that it could be useful to the keyboard problem :-)
    and here is the content of /etc/sysconfig/keyboard, ...it seems UK YAST_KEYBOARD="english-uk,pc104"
    Code:
    ## Path:        Hardware/Keyboard
    ## Description: Keyboard settings for the text console
    ## Type:        integer
    ## Default:
    ## ServiceRestart: kbdsettings
    #
    # Keyboard delay time in ms (250, 500, 750, 1000)
    KBD_DELAY=""
    
    ## Type:    string(2.0,2.1,2.3,2.5,2.7,3.0,3.3,3.7,4.0,4.3,4.6,5.0,5.5,6.0,6.7,7.5,8.0,8.6,9.2,10.0,10.9,12.0,13.3,15.0,16.0,17.1,18.5,20.0,21.8,24.0,26.7,30.0)
    ## Default:
    #
    # Keyboard repeat rate (2.0 - 30.0)
    KBD_RATE=""
    
    ## Type:        list(bios,yes,no)
    ## Default:     bios
    #
    # NumLock on? ("yes" or "no" or empty or "bios" for BIOS setting)
    # This setting may interfere with GNOME /desktop/gnome/peripherals/keyboard/remember_numlock_state GConf key.
    KBD_NUMLOCK="bios"
    
    ## Type:        yesno
    ## Default:     no
    #
    # ScrollLock on? ("yes" or "no")
    KBD_SCRLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # CapsLock on? ("yes" or "no")
    KBD_CAPSLOCK="no"
    
    ## Type:        yesno
    ## Default:     no
    #
    # Disable CAPS LOCK and make it a normal Shift key?
    # (Ctrl Caps Lock will still toggle Caps Lock functionality)
    # Note that you need to tweak the xkb maps or use xmodmap
    # if you want to do the same under X-Windows. In ~/.Xmodmap:
    # keycode 0x42 = Shift_L Shift_L
    #
    KBD_DISABLE_CAPS_LOCK="no"
    
    ## Type:        string
    ## Default:
    #
    # ttys for the above settings 
    # Example: "tty1 tty2"
    # "" for tty's 1-6
    #
    KBD_TTY=""
    
    # The YaST-internal identifier of the attached keyboard.
    #
    YAST_KEYBOARD="english-uk,pc104"
    I think YAST_KEYBOARD="english-uk,pc104" is what you want. Ever tried to adjust YAST2 > language > Primary Language > English (UK) and checked Adapt Keyboard Layout to English (UK)?
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  8. #8

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by karlmistelberger View Post
    I think YAST_KEYBOARD="english-uk,pc104" is what you want. Ever tried to adjust YAST2 > language > Primary Language > English (UK) and checked Adapt Keyboard Layout to English (UK)?
    Manythanks karl, have a happy 2019 :-) ...it result non checkable (grey) I tried to change to english US click ok then back to english UK, it happened something like install or uninstall software, but the behaviour remained the same, at boot english US keyboard result selected

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    816

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by pier_andreit View Post
    Manythanks karl, have a happy 2019 :-) ...it result non checkable (grey) I tried to change to english US click ok then back to english UK, it happened something like install or uninstall software, but the behaviour remained the same, at boot english US keyboard result selected
    That looks good! Check for YaST2 > /etc/sysconfig Editor > System > Environment > Language > RC_LANG=en_GB.UTF-8.

    You get (after logging in again):

    Code:
    karl@erlangen:~> locale
    LANG=en_GB.UTF-8
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=
    karl@erlangen:~>
    Beware of Plasma settings:

    Code:
    karl@erlangen:~> cat .config/plasma-localerc 
    [Formats]
    LANG=en_GB.UTF-8
    
    [Translations]
    LANGUAGE=en_GB:de
    karl@erlangen:~>
    You may verify:

    Code:
    erlangen:~ # cat /etc/locale.conf 
    LANG=en_GB.UTF-8
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  10. #10

    Default Re: starting kde it shows and use always english US keyboard insteda english UK

    Quote Originally Posted by karlmistelberger View Post
    That looks good! Check for YaST2 > /etc/sysconfig Editor > System > Environment > Language > RC_LANG=en_GB.UTF-8.

    You get (after logging in again):

    Code:
    karl@erlangen:~> locale
    LANG=en_GB.UTF-8
    LC_CTYPE="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_COLLATE="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_MESSAGES="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_ALL=
    karl@erlangen:~>
    tried, it didn't work,
    Code:
    pla@pla-3-TW:~> locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_DK.UTF-8
    LC_CTYPE=en_US.UTF-8,LANG=en_GB.UTF-8
    LC_NUMERIC="en_DK.UTF-8"
    LC_TIME="en_DK.UTF-8"
    LC_COLLATE="en_DK.UTF-8"
    LC_MONETARY=it_IT.UTF-8
    LC_MESSAGES="en_DK.UTF-8"
    LC_PAPER="en_DK.UTF-8"
    LC_NAME="en_DK.UTF-8"
    LC_ADDRESS="en_DK.UTF-8"
    LC_TELEPHONE="en_DK.UTF-8"
    LC_MEASUREMENT="en_DK.UTF-8"
    LC_IDENTIFICATION="en_DK.UTF-8"
    LC_ALL=
    pla@pla-3-TW:~>
    and yast>/etc/sysconfig>system>language =en_GB.UTF-8

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •