Results 1 to 10 of 10

Thread: after the last update luckybackup as superuser don't start

  1. #1

    Default after the last update luckybackup as superuser don't start

    in my leap 15 using kde, In the past luckybackup as superuser didn't start clicking on its icon in the application menu, so I started to launch it using the command in the icon properties:
    Code:
    xdg-su -c luckybackup
    in a konsole window
    today, after the last update it doesn't start in no way.
    using
    Code:
    xdg-su -c luckybackup
    in a konsole window start kdesu I insert the correct password but this is the error:
    Code:
    pla@pla-3-TW:~> xdg-su -c luckybackup
    Invalid MIT-MAGIC-COOKIE-1 keyNo X authentication info set for display ":0"
    QProcess: Destroyed while process ("xauth") is still running.
    No X authentication info set for display ":0"
    QProcess: Destroyed while process ("xauth") is still running.
    libGL error: unable to load driver: nouveau_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: nouveau
    No X authentication info set for display ":0"
    QProcess: Destroyed while process ("xauth") is still running.
    pla@pla-3-TW:~>
    it only run opening konsole in superuser mode and launching luckybackup, when luckybackup is running it woeks but gives this error:
    Code:
    libGL error: unable to load driver: nouveau_dri.so libGL error: driver pointer missing libGL error: failed to load driver: nouveau 



    any suggestion? :-)
    Last edited by hcvv; 27-Dec-2018 at 11:34. Reason: repaired CODE tags

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,503
    Blog Entries
    3

    Default Re: after the last update luckybackup as superuser don't start

    A completely wild guess, which might be totally wrong.

    Try uninstalling pam_kwallet. And then test whether it works.

    You can always reinstall pam_kwallet afterwards.

    And, of course, if pam_kwallet is not installed then my guess is wrong.

    I'm suggesting this, because I have seen pam_kwallet interfere with some other things, and some of the messages look similar to what you are describing.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: after the last update luckybackup as superuser don't start

    Also does it run as user??

  4. #4

    Default Re: after the last update luckybackup as superuser don't start

    Quote Originally Posted by nrickert View Post
    A completely wild guess, which might be totally wrong.

    Try uninstalling pam_kwallet. And then test whether it works.

    You can always reinstall pam_kwallet afterwards.

    And, of course, if pam_kwallet is not installed then my guess is wrong.

    I'm suggesting this, because I have seen pam_kwallet interfere with some other things, and some of the messages look similar to what you are describing.
    manythanks nrickert :-), but pam_kwallet is not installed, a tenth of kwallet stuff are installed but not pam_kwallet...

  5. #5

    Default Re: after the last update luckybackup as superuser don't start

    Quote Originally Posted by gogalthorp View Post
    Also does it run as user??
    manythanks gogal :-), as user it works, but luckybackup don't match my needs as user...

  6. #6

    Default Re: after the last update luckybackup as superuser don't start

    looking here it seems that is a known problem
    "** luckyBackup superuser does not start **.
    Due to a change of many distros policy, su-to-root is depracated from menu items and it cannot be used to run LB with super-user privileges.
    Please use an alternative like the sudo -H luckybackup command or pkexec together with a suitable policykit if you need to run LB as root, until this issue is resolved.
    This issue is solved at v.0.5.0"
    where can I ask to upgrade the luckybackup version in the opensuse repositories??

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,503
    Blog Entries
    3

    Default Re: after the last update luckybackup as superuser don't start

    Quote Originally Posted by pier_andreit View Post
    where can I ask to upgrade the luckybackup version in the opensuse repositories??
    I guess you could file a bug report.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: after the last update luckybackup as superuser don't start

    I installed the 0.5.0 version of luckybackup and now it works as superuser as before, launching the
    Code:
    xdg-su -c luckybackup
    command from konsole, it continues to not working clicking on the icon, I contacted the developer to have some help...

  9. #9

    Default Re: after the last update luckybackup as superuser don't start

    SOLVED!!!
    I contacted the developer that gently answered me this:
    .....Due to all distro's new policy the new LB (0.5) uses pkexec to run with super-user privileges.
    For that reason, there should be an extra script installed as /usr/bin/luckybackup-pkexec and there should be a luckybackup-su.desktop file under /usr/share/applications that runs the command "/usr/bin/luckybackup-pkexec"

    Could you please check if the version you have installed from the KDE-extra repo has maintained this ?
    eg Try to run:
    /usr/bin/luckybackup-pkexec

    Does it run or does it output a "command not found" error ?

    Is the file "/usr/share/applications/luckybackup-su.desktop" present ?

    Loukas
    and I did this:
    ...the file "/usr/share/applications/luckybackup-su.desktop" is present.
    So I looked the properties>application tab of the LB as superuser icon in the opensuse kde application menu and of the icon in the panel and in the command: field there was the old command "xdg-su -c luckybackup".
    So I removed the icon on the panel and I uninstalled LB from https://download.opensuse.org/reposi...USE_Leap_15.0/, checked that there wasn't the LB icon in the application menu and reinstalled LB from
    https://download.opensuse.org/reposi...USE_Leap_15.0/
    now the properties>application tab of the LB as superuser icon in the opensuse kde application menu in the command: field there is the new command "/usr/bin/luckybackup-pkexec", and everything works fine.
    It seems that when I ubgraded LB from KDE-extra to the new LB (0.5) from https://download.opensuse.org/reposi...USE_Leap_15.0/ leap 15 didn't update the command of the icon in the kde application menu, the procedure to uninstall and reinstall produced this.
    Mnythanks again Loukas
    ciao Pier
    and now luckybackup as superuser works perfectly

  10. #10
    ecsos NNTP User

    Default Re: after the last update luckybackup as superuser don't start

    Am Thu, 27 Dec 2018 17:36:03 +0000 schrieb pier andreit:

    > in my leap 15 using kde, In the past luckybackup as superuser didn't
    > start clicking on its icon in the application menu, so I started to
    > launch it using the command in the icon properties:


    You must nothing to do.


    Only install from:
    http://download.opensuse.org/reposit...ecsos:/Backup/
    openSUSE_Leap_15.0/x86_64/luckybackup-0.5.0-lp150.11.1.x86_64.rpm

    Than you can start in 4 ways:

    - Icon
    - Icon SU
    - In console with: luckbackup
    - In console with: luckybackup-pkexec


    Regards
    Eric

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •