Results 1 to 8 of 8

Thread: setting language to de_CH problems

  1. #1

    Default setting language to de_CH problems

    Hi all
    I am not sure if this the right place for this. So if in the wrong place, kindly move to the right place:

    We got Leap 15.0 laptops throughout our family, using plasma. My sons machine is dead now, so I tried to set an old lenovo T500 up as a substitute from scratch. It was on Leap 42.3, where locale was set to de_CH throught YaST2. After installing Leap 15.0, I tried to set de_CH in YaST2/language, but it says it cannot find it, as /usr/share/YaST2/data/languages/language_de_DE.ycp is missing. In fact:

    /usr/share/YaST2/data/languages # ls | grep -i DE
    language_de_DE.ycp
    However:

    locale -a | grep -i DE
    de_AT
    de_AT@euro
    de_AT.utf8
    de_BE
    de_BE@euro
    de_BE.utf8
    de_CH
    de_CH.utf8
    de_DE
    de_DE@euro
    de_DE.utf8
    de_IT
    de_IT.utf8
    de_LI.utf8
    de_LU
    de_LU@euro
    de_LU.utf8
    fy_DE
    gez_ER@abegede
    gez_ET@abegede
    hsb_DE
    hsb_DE.utf8
    ks_IN@devanagari
    nds_DE
    sd_IN@devanagari
    1] So, my conclusion basically YaST2 lists de_CH.utf8 but as the file "language_de_CH.ycp", it cannot set the locale correctly. Am I right?

    2] If, where are all these "language_de_XX.ycp" gone?

    Suggested workaround:

    cp language_de_DE.ycp language_de_CH.ycp
    Change the following in language_de_CH.ycp:
    {
    textdomain "languages_db";

    return
    $[
    // 1. information for language selection:
    // Format is
    // <LANG-Code> : [
    // <Language-to-display-UTF8-coded>,
    // <Language-to-display-ASCII-coded-if-needed>,
    // <LANG modifier used when UTF-8 enconding is selected>
    // <LANG modifier used when no UTF-8 enconding is selected>
    // <translated Language-to-display-UTF8-coded> ]
    //
    "de_CH" : [
    "Deutsch",
    "Deutsch",
    ".UTF-8",
    "@euro",
    // language name
    _("German")
    ],
    // 2. what time zone propose for this language
    "timezone" : "Europe/Zurich",
    // 3. which keyboard layout propose for this language
    "keyboard" : "german-ch",
    ];
    }
    After this, I could set de_CH in YaST2. However, in KDE Systemsettings, Swiss German is not directly selectable. I can select German and then set Region to Switzerland. If I logout/in and open a system terminal, all the menus are still in English.
    3] Is there more to it?
    4] If, what?

    Any help greatly appreciated

    Greez
    chris

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    888

    Default Re: setting language to de_CH problems

    Quote Originally Posted by seuchato View Post
    Hi all
    I am not sure if this the right place for this. So if in the wrong place, kindly move to the right place:

    We got Leap 15.0 laptops throughout our family, using plasma. My sons machine is dead now, so I tried to set an old lenovo T500 up as a substitute from scratch. It was on Leap 42.3, where locale was set to de_CH throught YaST2. After installing Leap 15.0, I tried to set de_CH in YaST2/language, but it says it cannot find it, as /usr/share/YaST2/data/languages/language_de_DE.ycp is missing. In fact:



    However:



    1] So, my conclusion basically YaST2 lists de_CH.utf8 but as the file "language_de_CH.ycp", it cannot set the locale correctly. Am I right?

    2] If, where are all these "language_de_XX.ycp" gone?

    Suggested workaround:


    Change the following in language_de_CH.ycp:


    After this, I could set de_CH in YaST2. However, in KDE Systemsettings, Swiss German is not directly selectable. I can select German and then set Region to Switzerland. If I logout/in and open a system terminal, all the menus are still in English.
    3] Is there more to it?
    4] If, what?

    Any help greatly appreciated

    Greez
    chris
    There is a fine thread: https://forums.opensuse.org/showthre...o-I-set-locale Feel free to browse thoroughly.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  3. #3

    Default Re: setting language to de_CH problems

    Quote Originally Posted by karlmistelberger View Post
    There is a fine thread: https://forums.opensuse.org/showthre...o-I-set-locale Feel free to browse thoroughly.
    Karl,
    thanks, I read that thread. I'll reread it. I'll report back afterwards.
    Greez
    Chris

  4. #4

    Default Re: setting language to de_CH problems

    Karl

    Thanks again for the hint. No sleep for the time being, so some time to spend on this

    https://forums.opensuse.org/showthre...41#post2837041
    suggests, I need to install glibc-i18ndata. However, as shown in my OP, "de_CH" exists. What is missing is the file "language_de_CH.ycp". If I copy it from "language_de_DE.ycp" with the mentioned adjustments, I can select de_CH. One of my points (or maybe THE point) is, that "language_de_CH.ycp" is missing. I do not see, how "localedef" could create that file.

    And then, I am not sure, if my "adjustments" (hacking rather I guess) in "language_de_CH.ycp" do all the trick. I have a strong feeling, my hacks are not complete. Also, I guess others would really prefer those "language_de_XX.ycp" files would be available. I am postive that this was the case in 42.1 at least, not 100% sure it was in 42.3.

    Any thoughts? Should I place a request at https://features.opensuse.org/?

    greez
    chris

  5. #5
    Join Date
    Sep 2012
    Posts
    4,972

    Default Re: setting language to de_CH problems

    Quote Originally Posted by seuchato View Post
    Should I place a request at https://features.opensuse.org/?
    if it worked in 42.3 and stopped working in 15 it is not missing feature, it is bug (regression). You should open bug report.

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    888

    Default Re: setting language to de_CH problems

    Quote Originally Posted by seuchato View Post
    Karl

    Thanks again for the hint. No sleep for the time being, so some time to spend on this

    https://forums.opensuse.org/showthre...41#post2837041
    suggests, I need to install glibc-i18ndata. However, as shown in my OP, "de_CH" exists. What is missing is the file "language_de_CH.ycp". If I copy it from "language_de_DE.ycp" with the mentioned adjustments, I can select de_CH. One of my points (or maybe THE point) is, that "language_de_CH.ycp" is missing. I do not see, how "localedef" could create that file.

    And then, I am not sure, if my "adjustments" (hacking rather I guess) in "language_de_CH.ycp" do all the trick. I have a strong feeling, my hacks are not complete. Also, I guess others would really prefer those "language_de_XX.ycp" files would be available. I am postive that this was the case in 42.1 at least, not 100% sure it was in 42.3.

    Any thoughts? Should I place a request at https://features.opensuse.org/?

    greez
    chris
    When creating a new en_DE locale on my machine I never worried about some "language_en_DE.ycp". You may verify:
    Code:
    erlangen:~ # rpm -qf /usr/share/i18n/locales/de_CH 
    glibc-i18ndata-2.27-6.1.noarch
    erlangen:~ #
    Then try: localedef -f UTF-8 -i de_CH de_CH.UTF-8

    Make sure:

    Code:
    erlangen:~ # grep -C 3 LANG ~charlemagne/.config/plasma-localerc
    [Formats]
    LANG=de_CH.UTF-8
    
    [Translations]
    LANGUAGE=
    erlangen:~ #
    That is what works on my boxes.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7

    Default Re: setting language to de_CH problems

    Hi all
    @arvidjaar
    I am 100% sure about 42.1, as I would be in tax declaration (Consider me a 100% honest guy and that's what I am.), not though 100% sure on 42.3. Why? I wrote a documentation for 42.1 which included screen shots for the very problem. That documentation unfortunately never got updated to 42.3. But still: Missing all these "language_de_XX.ycp" looks to me at leats like like a flaw. I'll report it as a bug - see below.

    @Karl
    I will setup a spare box and try to verify your sugestion. Honestly, I doubt it will bring a valid "language_de_CH.ycp".I do however expect your suggestion to solve the problem. I am afraid. I won't be able to do this before Jan. 8 2019. Hope you bare with me until then.

    Happy new Year and
    Guetä Rutsch

    chris

  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    888

    Default Re: setting language to de_CH problems

    Quote Originally Posted by seuchato View Post
    I will setup a spare box and try to verify your sugestion. Honestly, I doubt it will bring a valid "language_de_CH.ycp".
    Checked my box again and found:

    • System default is defined as RC_LANG="de_DE.UTF-8" in /etc/sysconfig/language. You may have de_CH.UTF-8 without further tinkering.
    • Users System Settings > Regional Settings > Language is empty, but Format defaults to "de_DE.UTF-8". You may select one from several hundred(!) items, even Schwiiz Schwiizertüütsch (gsw_CH).


    I do however expect your suggestion to solve the problem. I am afraid. I won't be able to do this before Jan. 8 2019. Hope you bare with me until then.
    Happy new Year and Guetä Rutsch
    You are welcome. Happy new year to you!
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •