Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Kan geen nas mounten met nfs

  1. #21
    Join Date
    Aug 2016
    Location
    Netherlands
    Posts
    141

    Default Re: Kan geen nas mounten met nfs

    Code:
    FlyingDutchman@linux-gjw1:~> systemctl status nfs-mountd.service
    Unit nfs-mountd.service could not be found.

    Code:
    FlyingDutchman@linux-gjw1:~> sudo mount -a
    
    [sudo] wachtwoord voor root: 
    Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /usr/lib/systemd/system/rpc-statd.service.
    mount.nfs: access denied by server while mounting as6204t-7f3e.home:/volume1/Multimedia

  2. #22
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,264

    Default Re: Kan geen nas mounten met nfs

    You show a mount -a, which should mount all that is in /etc/fstab. But you forgot to show /etc/fstab.
    Henk van Velden

  3. #23
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,203
    Blog Entries
    14

    Default Re: Kan geen nas mounten met nfs

    Quote Originally Posted by hcvv View Post
    You show a mount -a, which should mount all that is in /etc/fstab. But you forgot to show /etc/fstab.
    Nee, die heeft ie al laten zien, en daarin staat de nfs mount.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #24
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,203
    Blog Entries
    14

    Default Re: Kan geen nas mounten met nfs

    Kun je 's van beide systemen, dus 42.3 en 15.0 dit laten zien:

    Code:
    cat /etc/nfs.conf
    cat /etc/nfsmount.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #25
    Join Date
    Aug 2016
    Location
    Netherlands
    Posts
    141

    Default Re: Kan geen nas mounten met nfs

    Code:
    lyingDutchman@linux-gjw1:~> cat /etc/nfs.conf
    #
    # This is a general configuration for the
    # NFS daemons and tools
    # DO NOT MAKE CHANGES TO THIS FILE as they will
    # be lost on the next software update.  Make changes
    # to /etc/sysconfig/nfs or /etc/nfs.conf.local instead.
    # /etc/nfs.conf.local can include multiple sections, just
    # like this file.
    
    [environment]
    include = /etc/sysconfig/nfs
    include = /etc/nfs.conf.local
    [general]
     pipefs-directory=$RPC_PIPEFS_DIR
    #
    #[exportfs]
    # debug=0
    #
    #[gssd]
    # use-memcache=0
    # use-machine-creds=1
     avoid-dns=$NFS_GSSD_AVOID_DNS
    # limit-to-legacy-enctypes=0
    # context-timeout=0
    # rpc-timeout=5
    # keytab-file=/etc/krb5.keytab
    # cred-cache-directory=
    # preferred-realm=
    #
    [lockd]
     port=$LOCKD_TCPPORT
     udp-port=$LOCKD_UDPPORT
    #
    [mountd]
    # debug=0
    # manage_gids=n
    # descriptors=0
     port= $MOUNTD_PORT
    # threads=1
    # reverse-lookup=n
    # state-directory-path=/var/lib/nfs
    # ha-callout=
    #
    #[nfsdcltrack]
    # debug=0
    # storagedir=/var/lib/nfs/nfsdcltrack
    #
    [nfsd]
    # debug=0
     threads= $USE_KERNEL_NFSD_NUMBER
    # host=
    # port=0
    # grace-time=90
     lease-time=$NFSV4LEASETIME
    # udp=y
    # tcp=y
    # vers2=n
     vers3=$NFS3_SERVER_SUPPORT
     vers4=$NFS4_SUPPORT
    # vers4.0=y
    # vers4.1=y
    # vers4.2=y
    # rdma=n
    #
    [statd]
    # debug=0
     port=$STATD_PORT
    # outgoing-port=0
     name=$STATD_HOSTNAME
    # state-directory-path=/var/lib/nfs/statd
    # ha-callout=
    #
    #[sm-notify]
    # debug=0
    # retry-time=900
    # outgoing-port=
    # outgoing-addr=
    #
    #[svcgssd]
    # principal=

  6. #26
    Join Date
    Aug 2016
    Location
    Netherlands
    Posts
    141

    Default Re: Kan geen nas mounten met nfs

    Code:
    FlyingDutchman@linux-gjw1:~> cat /etc/nfsmount.conf
    #
    # /etc/nfsmount.conf - see nfsmount.conf(5) for details
    #
    # This is an NFS mount configuration file. This file can be broken
    # up into three different sections: Mount, Server and Global
    # 
    # [ MountPoint "Mount_point" ] 
    # This section defines all the mount options that
    # should be used on a particular mount point. The '<Mount_Point>'
    # string need to be an exact match of the path in the mount 
    # command. Example:
    #     [ MountPoint "/export/home" ]
    #       background=True
    # Would cause all mount to /export/home would be done in
    # the background
    #
    # [ Server "Server_Name" ]
    # This section defines all the mount options that
    # should be used on mounts to a particular NFS server. 
    # Example:
    #     [ Server "nfsserver.foo.com" ]
    #       rsize=32k
    #       wsize=32k
    # All reads and writes to the 'nfsserver.foo.com' server 
    # will be done with 32k (32768 bytes) block sizes.
    #
    [ NFSMount_Global_Options ]
    # This statically named section defines global mount 
    # options that can be applied on all NFS mount.
    #
    # Protocol Version [2,3,4]
    # This defines the default protocol version which will
    # be used to start the negotiation with the server.
    # Defaultvers=4
    #
    # Setting this option makes it mandatory the server supports the
    # given version. The mount will fail if the given version is 
    # not support by the server. 
    # Nfsvers=4
    #
    # Network Protocol [udp,tcp,rdma] (Note: values are case sensitive)
    # This defines the default network protocol which will
    # be used to start the negotiation with the server.
    # Defaultproto=tcp
    #
    # Setting this option makes it mandatory the server supports the
    # given network protocol. The mount will fail if the given network
    # protocol is not supported by the server.
    # Proto=tcp
    #
    # The number of times a request will be retired before 
    # generating a timeout 
    # Retrans=2
    #
    # The number of minutes that will retry mount
    # Retry=2
    #
    # The minimum time (in seconds) file attributes are cached
    # acregmin=30
    #
    # The Maximum time (in seconds) file attributes are cached
    # acregmin=60
    #
    # The minimum time (in seconds) directory attributes are cached
    # acregmin=30
    #
    # The Maximum time (in seconds) directory attributes are cached
    # acregmin=60
    #
    # Enable Access  Control  Lists
    # Acl=False
    #
    # Enable Attribute Caching
    # Ac=True
    #
    # Do mounts in background (i.e. asynchronously)
    # Background=False
    #
    # Close-To-Open cache coherence
    # Cto=True
    #
    # Do mounts in foreground (i.e. synchronously)
    # Foreground=True
    #
    # How to handle times out from servers (Hard is STRONGLY suggested)
    # Hard=True
    # Soft=False
    #
    # Enable File Locking
    # Lock=True
    #
    # Enable READDIRPLUS on NFS version 3 mounts
    # Rdirplus=True
    #
    # Maximum Read Size (in Bytes)
    # Rsize=8k
    #
    # Maximum Write Size (in Bytes)
    # Wsize=8k
    #
    # Maximum Server Block Size (in Bytes)
    # Bsize=8k
    #
    # Ignore unknown mount options
    # Sloppy=False
    #
    # Share Data and Attribute Caches
    # Sharecache=True
    #
    # The amount of time, in tenths of a seconds, the client
    # will wait for a response from the server before retransmitting
    # the request.
    # Timeo=600
    #
    # Sets all attributes times to the same time (in seconds)
    # actimeo=30
    #
    # Server Mountd port mountport
    # mountport=4001
    #
    # Server Mountd Protocol
    # mountproto=tcp
    #
    # Server Mountd Version
    # mounvers=3
    #
    # Server Mountd Host
    # mounthost=hostname
    #
    # Server Port
    # Port=2049
    #
    # RPCGSS security flavors 
    # [none, sys, krb5, krb5i, krb5p ]
    # Sec=sys
    #
    # Allow Signals to interrupt file operations
    # Intr=True
    #
    # Specifies  how the kernel manages its cache of directory
    # Lookupcache=all|none|pos|positive
    #
    # Turn of the caching of that access time
    # noatime=True
    Deze 2 zijn van mijn laptop (Leap 15)

  7. #27
    Join Date
    Aug 2016
    Location
    Netherlands
    Posts
    141

    Default Re: Kan geen nas mounten met nfs

    Code:
    FlyingDutchman@linux-s4pw:~> cat /etc/nfs.conf
    cat: /etc/nfs.conf: Bestand of map bestaat niet
    Code:
    FlyingDutchman@linux-s4pw:~> cat /etc/nfsmount.conf
    #
    # /etc/nfsmount.conf - see nfsmount.conf(5) for details
    #
    # This is an NFS mount configuration file. This file can be broken
    # up into three different sections: Mount, Server and Global
    # 
    # [ MountPoint "Mount_point" ] 
    # This section defines all the mount options that
    # should be used on a particular mount point. The '<Mount_Point>'
    # string need to be an exact match of the path in the mount 
    # command. Example:
    #     [ MountPoint "/export/home" ]
    #       background=True
    # Would cause all mount to /export/home would be done in
    # the background
    #
    # [ Server "Server_Name" ]
    # This section defines all the mount options that
    # should be used on mounts to a particular NFS server. 
    # Example:
    #     [ Server "nfsserver.foo.com" ]
    #       rsize=32k
    #       wsize=32k
    # All reads and writes to the 'nfsserver.foo.com' server 
    # will be done with 32k (32768 bytes) block sizes.
    #
    [ NFSMount_Global_Options ]
    # This statically named section defines global mount 
    # options that can be applied on all NFS mount.
    #
    # Protocol Version [2,3,4]
    # This defines the default protocol version which will
    # be used to start the negotiation with the server.
    # Defaultvers=4
    #
    # Setting this option makes it mandatory the server supports the
    # given version. The mount will fail if the given version is 
    # not support by the server. 
    # Nfsvers=4
    #
    # Network Protocol [udp,tcp,rdma] (Note: values are case sensitive)
    # This defines the default network protocol which will
    # be used to start the negotiation with the server.
    # Defaultproto=tcp
    #
    # Setting this option makes it mandatory the server supports the
    # given network protocol. The mount will fail if the given network
    # protocol is not supported by the server.
    # Proto=tcp
    #
    # The number of times a request will be retired before 
    # generating a timeout 
    # Retrans=2
    #
    # The number of minutes that will retry mount
    # Retry=2
    #
    # The minimum time (in seconds) file attributes are cached
    # acregmin=30
    #
    # The Maximum time (in seconds) file attributes are cached
    # acregmin=60
    #
    # The minimum time (in seconds) directory attributes are cached
    # acregmin=30
    #
    # The Maximum time (in seconds) directory attributes are cached
    # acregmin=60
    #
    # Enable Access  Control  Lists
    # Acl=False
    #
    # Enable Attribute Caching
    # Ac=True
    #
    # Do mounts in background (i.e. asynchronously)
    # Background=False
    #
    # Close-To-Open cache coherence
    # Cto=True
    #
    # Do mounts in foreground (i.e. synchronously)
    # Foreground=True
    #
    # How to handle times out from servers (Hard is STRONGLY suggested)
    # Hard=True
    # Soft=False
    #
    # Enable File Locking
    # Lock=True
    #
    # Enable READDIRPLUS on NFS version 3 mounts
    # Rdirplus=True
    #
    # Maximum Read Size (in Bytes)
    # Rsize=8k
    #
    # Maximum Write Size (in Bytes)
    # Wsize=8k
    #
    # Maximum Server Block Size (in Bytes)
    # Bsize=8k
    #
    # Ignore unknown mount options
    # Sloppy=False
    #
    # Share Data and Attribute Caches
    # Sharecache=True
    #
    # The amount of time, in tenths of a seconds, the client
    # will wait for a response from the server before retransmitting
    # the request.
    # Timeo=600
    #
    # Sets all attributes times to the same time (in seconds)
    # actimeo=30
    #
    # Server Mountd port mountport
    # mountport=4001
    #
    # Server Mountd Protocol
    # mountproto=tcp
    #
    # Server Mountd Version
    # mounvers=3
    #
    # Server Mountd Host
    # mounthost=hostname
    #
    # Server Port
    # Port=2049
    #
    # RPCGSS security flavors 
    # [none, sys, krb5, krb5i, krb5p ]
    # Sec=sys
    En deze zijn van mijn Desktop (Leap 42.3)

  8. #28
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,203
    Blog Entries
    14

    Default Re: Kan geen nas mounten met nfs

    Mmmm, het lijkt alsof de server de mountpoging weigert, kun je ook 's
    Code:
    sudo journalctl | grep -i nfs
    van de laptop laten zien?

    Hoe heb je de share op de laptop precies toegevoegd?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #29
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,264

    Default Re: Kan geen nas mounten met nfs

    Quote Originally Posted by hcvv View Post
    You show a mount -a, which should mount all that is in /etc/fstab. But you forgot to show /etc/fstab.
    Mijn excuses. Ik had zelfs niet door dat dit pagina drie van een Nederlandse draad was. Ik dacht dat het de eerste post van een Engelse thread was.

    Nogmaals, sorry voor het inbreken met onzin.
    Henk van Velden

  10. #30
    Join Date
    Aug 2016
    Location
    Netherlands
    Posts
    141

    Default Re: Kan geen nas mounten met nfs

    Code:
    linux-gjw1:/home/FlyingDutchman # journalctl | grep -i nfs
    jan 02 14:32:12 linux-gjw1 systemd[1]: Starting Alias for NFS client...
    jan 02 14:32:12 linux-gjw1 systemd[1]: Starting Notify NFS peers of a restart...
    jan 02 14:32:12 linux-gjw1 systemd[1]: Started Alias for NFS client.
    jan 02 14:32:12 linux-gjw1 systemd[1]: Started Notify NFS peers of a restart.
    jan 02 14:32:13 linux-gjw1 kernel: RPC: Registered tcp NFSv4.1 backchannel transport module.
    jan 02 14:32:13 linux-gjw1 systemd[1]: Reached target NFS client services.
    jan 02 18:31:31 linux-gjw1 kernel: FS-Cache: Netfs 'nfs' registered for caching
    jan 02 18:31:31 linux-gjw1 kernel: NFS: Registering the id_resolver key type
    jan 02 18:31:31 linux-gjw1 systemd[1]: Starting NFS status monitor for NFSv2/3 locking....
    jan 02 18:31:31 linux-gjw1 systemd[1]: Starting Notify NFS peers of a restart...
    jan 02 18:31:31 linux-gjw1 systemd[1]: Started Notify NFS peers of a restart.
    jan 02 18:31:31 linux-gjw1 systemd[1]: Started NFS status monitor for NFSv2/3 locking..
    Ik Heb het zelfde gedaan, als onder Leap 42.3 YAST/NFS-client/Toevoegen/ en toen alle informatie ingevult

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •