Results 1 to 4 of 4

Thread: Can't get OBS to build x86_64 targets any more

  1. #1

    Default Can't get OBS to build x86_64 targets any more

    I am backporting OpenSSL 1.1.1a to Debian 8 and 9. It builds properly on an actual Debian 8 x86_64 and when I first brought this into OBS it built correctly in Debian 8 on x86_64, but threw an error during the post-build tests on i586. I wanted to see if this was an issue in Debian 8, so I added a Debian 9 repository. This is when it started getting funny. After I added the Debian 9 repository, the i586 target would show up, but x86_64 for Debian 9 didn't appear.

    To make a long story short, after several times completely removing and re-adding the package and even the whole subproject, x86_64 will not build. On Debian 8 it shows a "finished" status for x86_64, and if I mouse over the cog icon with the attention symbol it says "State needs recalculations, former state was build job exists". On every other architecture it shows the eye and mousing over it says unknown state for x86_64 as shown below:



    This is on my subproject page. On the package page, the x86_64 architectures for each OS don't even show up. I have tried to trigger a build for x86_64 many times, it never occurs.

    No matter what I do I can't get x86_64 to build. The funny thing is, the original error I got building on i586 no longer shows up and it builds fine. I would think I had done something wrong in my backport, but it builds on the actual Debian Jessie x86_64 machine just fine, and it built here the first time I tried.

    It has been like this for almost a day. Am I doing something wrong?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,291
    Blog Entries
    15

    Default Re: Can't get OBS to build x86_64 targets any more

    Hi
    Don't think so, seems there are issues with OBS and x86_64 targets;
    https://lists.opensuse.org/opensuse-.../msg00147.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,796

    Default AW: Can't get OBS to build x86_64 targets any more


  4. #4

    Default Re: Can't get OBS to build x86_64 targets any more

    I saw that, but that's just back_home. There is back_stage, back_other, and back_main too. And a whole pile of x86_64 workers below that appear to be actively doing things. So I have no idea how to interpret that page. At least it's not a just me thing, though. Being new I wasn't sure if it was a PEBCAK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •