Results 1 to 9 of 9

Thread: Update to Qt5.12 not possible

  1. #1

    Default Update to Qt5.12 not possible

    Hello,
    i tried to do the latest updates on Tumbleweed and got the following error messages:

    Problem: libQt5WebView5-5.11.2-1.1.x86_64 benötigt libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libQt5Scxml5-5.11.2-1.1.x86_64 benötigt libQt5Qml.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libQt5WebView5-5.11.2-1.1.x86_64 benötigt libQt5WebEngine.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libqt5-qtwebengine-5.11.2-1.2.x86_64 benötigt libQt5Gui.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libQtQuick5-5.11.2-1.1.x86_64 benötigt libQt5Test.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Problem: libQtQuick5-5.11.2-1.1.x86_64 benötigt libQt5Widgets.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden

    Problem: libQt5WebView5-5.11.2-1.1.x86_64 benötigt libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    Gelöschte Anbieter: libQt5Core5-5.11.2-2.3.x86_64
    Lösung 1: Folgende Aktionen werden ausgeführt:
    veraltetes libQt5Core5-5.11.2-2.3.x86_64 beibehalten
    veraltetes libQt5DBus5-5.11.2-2.3.x86_64 beibehalten
    Lösung 2: Deinstallation von libQt5WebView5-5.11.2-1.1.x86_64
    Lösung 3: libQt5WebView5-5.11.2-1.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen


    In english its essential:
    Problem: libQt5WebView5-5.11.2-1.1.x86_64 neets libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but cannot be provided

    An AFAICS the same message is for all libs using Qt.

    Do I have a wrong repository configuration? But, up to now everything went smooth..

    My repositories are:
    Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.

    # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung
    --+-------------------------------------+-----------------------------+-----------+-----------------+---------------
    1 | http-download.opensuse.org-b2d252f8 | KDE:Extra | Ja | (r ) Ja | Ja
    2 | http-download.opensuse.org-eda20a3c | KDE:Frameworks5 | Ja | (r ) Ja | Ja
    3 | http-ftp.gwdg.de-e2919d67 | Packman Repository | Ja | (r ) Ja | Ja
    4 | http-opensuse-guide.org-72f26795 | libdvdcss repository | Ja | (r ) Ja | Ja
    5 | openSUSE-20180803-0 | openSUSE-20180803-0 | Ja | (r ) Ja | Ja
    6 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ----
    7 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja
    8 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ----
    9 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja


    Thangs,
    Johannes

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Update to Qt5.12 not possible

    1.
    You "tried to do the latest updates", then please SHOW waht you did in that trial. How can we check if you tried the correct thing if we do not see anything?
    And remember that the only supported way of upgrading Tumbleweed is
    Code:
    zypper dup
    2.
    There is an important, but not easy to find feature on the forums.

    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    3.
    A trick to let tools use the English language when executed: add LANG=C before the command. Example
    Code:
    LANG=C zypper dup
    That spares you providing tranlations.

    4.
    To show your repository list, please use
    Code:
    zypper lr -d
    Now we see only the names and aliases local on your system, but the URLs are the only way to see what they are.
    Last edited by hcvv; 22-Dec-2018 at 04:09.
    Henk van Velden

  3. #3

    Default Re: Update to Qt5.12 not possible

    Hi,
    OK, I tried to follow your recommendations. But it is exactly the same.

    All commands are done as root.

    1. Yes, the update is/was done with
    Code:
    zypper dup
    2. (done)

    3. This is the output of
    Code:
    zypper dup
    :
    Code:
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    6 Problems:
    Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQt5Scxml5-5.11.2-1.1.x86_64 requires libQt5Qml.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5WebEngine.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libqt5-qtwebengine-5.11.2-1.2.x86_64 requires libQt5Gui.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQtQuick5-5.11.2-1.1.x86_64 requires libQt5Test.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQtQuick5-5.11.2-1.1.x86_64 requires libQt5Widgets.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    
    Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
      deleted providers: libQt5Core5-5.11.2-2.3.x86_64
     Solution 1: Following actions will be done:
      keep obsolete libQt5Core5-5.11.2-2.3.x86_64
      keep obsolete libQt5DBus5-5.11.2-2.3.x86_64
     Solution 2: deinstallation of libQt5WebView5-5.11.2-1.1.x86_64
     Solution 3: break libQt5WebView5-5.11.2-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): c
    4. Output of
    Code:
    LANG=C zypper lr -d
    Code:
    # | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                       | Service
    --+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-b2d252f8 | KDE:Extra                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Frameworks5_openSUSE_Tumbleweed/ |        
    2 | http-download.opensuse.org-eda20a3c | KDE:Frameworks5             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/              |        
    3 | http-ftp.gwdg.de-e2919d67           | Packman Repository          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                            |        
    4 | http-opensuse-guide.org-72f26795    | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                       |        
    5 | openSUSE-20180803-0                 | openSUSE-20180803-0         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                         |        
    6 | repo-debug                          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                   |        
    7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                                     |        
    8 | repo-source                         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                  |        
    9 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/
    
    Thanks,
    Johannes

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Update to Qt5.12 not possible

    Ok, thanks for all the information. And I hope people can now start helping you.

    I am not a TW user, but aren't those two Framework5 repos (one for TW and one Factory(?) the cause of your problems?

    There is one thing though that you missed. Easiest is to copy/paste inclusing the prompt command line, the output and the next prompt line. This you e.g. do not do
    ==============================
    This is the output of
    Code:
    uname -a
    Code:
    Linux boven 3.12.67-64-desktop #1 SMP PREEMPT Fri Dec 9 15:56:17 UTC 2016 (35c7b99) x86_64 x86_64 x86_64 GNU/Linux
    ==============================
    but simply, all in one, no further explanation needed:
    ==============================
    Code:
    henk@boven:~> uname -a
    Linux boven 3.12.67-64-desktop #1 SMP PREEMPT Fri Dec 9 15:56:17 UTC 2016 (35c7b99) x86_64 x86_64 x86_64 GNU/Linux
    henk@boven:~>
    Also, the fonts in both CODE sections in your post are different. That should not be possible when you simply copy/paste from the terminal.
    Remember that the trust people will have in what you post depends very much on what you show. And people trust that you did a copy/paste of what you saw directly between the CODE tags (no changes, additions, removals) so that they see exactly the same.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,590
    Blog Entries
    14

    Default Re: Update to Qt5.12 not possible

    Remove the 2 KDE / Frameworks repos ( the top 2 ), and run 'zypper dup' again. TW always has the latest KDE builds, no use to enable these repos, it will only lead to situations like you landed in now.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Update to Qt5.12 not possible

    Thanks,
    removing the "factory" repo solved the problem.
    I need the KDE:Extra repo for "smb4k". It is only contained in this repo.

    For sure, the factory also came in, because I installed something thats not contained in the other repos.

    Anyway, thanks again, it works.

    Johannes

  7. #7

    Default Re: Update to Qt5.12 not possible

    Hi, I'm having some similar conflicts right now:
    Code:
    > sudo zypper dup
    [sudo] password for root: 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    2 Problems:
    Problem: python3-pyside2-5.11.2-1.2.x86_64 requires libQt5Quick.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    Problem: libQtQuick5-5.11.2-1.1.x86_64 requires libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    
    Problem: python3-pyside2-5.11.2-1.2.x86_64 requires libQt5Quick.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
      deleted providers: libQtQuick5-5.11.2-1.1.x86_64
     Solution 1: Following actions will be done:
      keep obsolete libQtQuick5-5.11.2-1.1.x86_64
      keep obsolete libQt5Gui5-5.11.2-2.3.x86_64
      keep obsolete libQt5Test5-5.11.2-2.3.x86_64
      keep obsolete libQt5Widgets5-5.11.2-2.3.x86_64
      keep obsolete libQt5DBus5-5.11.2-2.3.x86_64
     Solution 2: deinstallation of python3-pyside2-5.11.2-1.2.x86_64
     Solution 3: break python3-pyside2-5.11.2-1.2.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
    What requires "python3-pyside2" was FreeCAD:

    Code:
    > zypper se --requires python3-pyside2
    Loading repository data...
    Reading installed packages...
    
    S | Name                  | Summary                        | Type   
    --+-----------------------+--------------------------------+--------
    i | FreeCAD               | General Purpose 3D CAD Modeler | package
      | python3-pyside2-devel | Header Files for PySide2       | package
    And all three packages mentioned above came from the tumbleweed oss repository:
    Code:
    > zypper if libQtQuick5 python3-pyside2 FreeCAD
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libQtQuick5:
    ------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                   
    Name           : libQtQuick5                               
    Version        : 5.12.0-1.1                                
    Arch           : x86_64                                    
    Vendor         : openSUSE                                  
    Installed Size : 12.1 MiB                                  
    Installed      : Yes (automatically)                       
    Status         : out-of-date (version 5.11.2-1.1 installed)
    Source package : libqt5-qtdeclarative-5.12.0-1.1.src       
    Summary        : Qt 5 Declarative Library                  
    Description    :                                           
        Qt is a set of libraries for developing applications.
    
        This package contains base tools, like string, xml, and network
        handling.
    
    
    Information for package python3-pyside2:
    ----------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss        
    Name           : python3-pyside2                
    Version        : 5.11.2-1.2                     
    Arch           : x86_64                         
    Vendor         : openSUSE                       
    Installed Size : 37.0 MiB                       
    Installed      : Yes (automatically)            
    Status         : up-to-date                     
    Source package : python3-pyside2-5.11.2-1.2.src 
    Summary        : PySide - python bindings for Qt
    Description    :                                
        The PySide2 project provides Python bindings for the Qt
        application and UI framework.
    
    
    Information for package FreeCAD:
    --------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                  
    Name           : FreeCAD                                  
    Version        : 0.17.1534399137.9948ee4f1-1.4            
    Arch           : x86_64                                   
    Vendor         : openSUSE                                 
    Installed Size : 270.2 MiB                                
    Installed      : Yes (automatically)                      
    Status         : up-to-date                               
    Source package : FreeCAD-0.17.1534399137.9948ee4f1-1.4.src
    Summary        : General Purpose 3D CAD Modeler           
    Description    :                                          
        FreeCAD is a parametric 3D modeler made primarily to design real-life objects of any size. Parametric modeling allows you
        to easily modify your design by going back into your model history and changing its parameters. FreeCAD is open-source
        and highly customizable, scriptable and extensible.
    Is there anything I can do other than uninstalling FreeCAD?

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,820

    Default AW: Update to Qt5.12 not possible

    Is there anything I can do other than uninstalling FreeCAD?
    Waiting?
    Bugreport?

    Code:
    zypper in FreeCAD 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libQt5Quick.so.5(Qt_5.11.2_PRIVATE_API)(64bit) needed by python3-pyside2-5.11.2-1.2.x86_64
     Solution 1: do not install FreeCAD-0.17.1534399137.9948ee4f1-1.4.x86_64
     Solution 2: break python3-pyside2-5.11.2-1.2.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Update to Qt5.12 not possible

    Please, please, start a new thread with your own problem. Only add information to other threads when it is about the same problem, not "similar".

    Specialy in this case where the OP explained his problem is solved, not many people will look at this thread anymore. And what you probably want is that many people look at your problem.

    The reasoning is simple: you have a problem, you want help from volunteers, thus post in the best fitting sub-forum (where the volunteers in that area of interest will browse), with a good title that shows the keywords that will draw the attention of those that are best equiped to help you. In short, it is you that must advertise your problem, not hide it at the end of something else.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •