Results 1 to 5 of 5

Thread: Remove bad repository

  1. #1
    Join Date
    Jan 2010
    Location
    New Jersey, USA
    Posts
    66

    Default Remove bad repository

    I am getting a very long error message from
    a bad entry in the repository list. How do I scan the list
    and delete this bad repo ?? (find text then delete)
    Also, what part of this error message represents the
    bad repo name ? Guessing the bold text
    Thanks in advance !!


    An error occurred during repository initialization.
    [http-download.opensuse.org-5d4c14c6|http://download.opensuse.org/reposit...:/Ports/ports/]
    Valid metadata not found at specified URL History: - [http-download.opensuse.org-5d4c14c6|http://download.opensuse.org/reposit.../Ports/ports/] Repository type can't be determined.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Remove bad repository

    Hi, looks like you tried to add some ARM repo. Is this on an ARM machine?
    Please show:
    Code:
    uname -a
    zypper lr -d
    In the output you will see a list of repos, incl. URLs, proceeded by an index number. You can remove the repo with the incorrect URL by
    Code:
    zypper rr Index_No_of_Wrong_Repo
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: Remove bad repository

    If you use Yast Software Repositories, you will probably recognize the repo immediately from that "5d4c14c6" part of the repo alias. And you can remove it (or disable it) from there.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Remove bad repository

    Please open a terminal and issue the following command, then post the result here between CODE tags (the # button above the web editing window):
    Code:
    zypper lr -d
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5
    Join Date
    Jan 2010
    Location
    New Jersey, USA
    Posts
    66

    Default Re: Remove bad repository

    Thanks everyone.
    Was able to remove it.
    All is OK now

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •