It was helpful that when I clicked on a script file (say, a .sh or perl file) that KDE/Dolphin would ask me whether to edit or run the file. I accidentally clicked on "always edit" - and now I can't figure out how to get back to Dolphin offering the choice of run/edit. Does anyone know how to reset that option?

Edit: Just figured it out - Dolphin > Control > Configure Dolphin > "Defaults" button.