Results 1 to 9 of 9

Thread: Printer stopped working: Had to downgrade ghostscript

  1. #1
    Join Date
    Feb 2017
    Posts
    22

    Default Printer stopped working: Had to downgrade ghostscript

    I don't need help anymore with this but my Canon MG2520 printer stopped printing today except for photocopies and test pages. I had to downgrade ghostscript from 9.26 to 9.25 to get the printer to work again. I'm posting it in case somebody might be having the same problem.

  2. #2

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Thanks for the info, I wonder what reason it stopping the printer.

  3. #3
    Join Date
    Feb 2017
    Posts
    22

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by madilyn View Post
    Thanks for the info, I wonder what reason it stopping the printer.
    Don't know. I don't have the necessary knowledge to diagnose it.

    In the meantime I protected the package from upgrades. I'll wait for 9.27.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,450
    Blog Entries
    1

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by gacl View Post
    Don't know. I don't have the necessary knowledge to diagnose it.

    In the meantime I protected the package from upgrades. I'll wait for 9.27.
    In general, CUPS troubleshooting can be performed by examining the output captured to /var/log/cups/error_log when printing, and verbose debug-logging invoked (prior to sending a print job) with
    Code:
    cupsctl --debug-logging
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5
    Join Date
    Feb 2017
    Posts
    22

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Upgraded to 9.26a but the printer fails just the same

    /var/log/cups/error_log:

    Code:
    W [01/Feb/2019:12:07:25 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service filesW [01/Feb/2019:12:07:25 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [01/Feb/2019:12:07:25 -0500] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [01/Feb/2019:13:46:57 -0500] [CGI] cups-brf must be called as root
    E [01/Feb/2019:13:46:57 -0500] [cups-deviced] PID 12669 (cups-brf) stopped with status 1!
    E [01/Feb/2019:13:46:57 -0500] [cups-deviced] PID 12673 (gutenprint52+usb) stopped with status 1!
    I installed glibc-32bit as suggested in this thread:
    https://forums.opensuse.org/showthre...t-can-t-print/

    I did
    Code:
    sudo rccups restart
    and got nothing

    I'm going back to 9.25 again

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,450
    Blog Entries
    1

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by gacl View Post
    I installed glibc-32bit as suggested in this thread:
    https://forums.opensuse.org/showthre...t-can-t-print/

    I did
    Code:
    sudo rccups restart
    and got nothing
    That advice was specifically for a user installing a Brother printer driver.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,450
    Blog Entries
    1

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by gacl View Post
    Upgraded to 9.26a but the printer fails just the same

    /var/log/cups/error_log:

    Code:
    W [01/Feb/2019:12:07:25 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service filesW [01/Feb/2019:12:07:25 -0500] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [01/Feb/2019:12:07:25 -0500] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [01/Feb/2019:13:46:57 -0500] [CGI] cups-brf must be called as root
    E [01/Feb/2019:13:46:57 -0500] [cups-deviced] PID 12669 (cups-brf) stopped with status 1!
    E [01/Feb/2019:13:46:57 -0500] [cups-deviced] PID 12673 (gutenprint52+usb) stopped with status 1!
    I'm going back to 9.25 again
    Did you submit a bug report?
    openSUSE Leap 15.0; KDE Plasma 5

  8. #8
    Join Date
    Feb 2017
    Posts
    22

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by deano_ferrari View Post
    Did you submit a bug report?
    No. Where do I do that? And how?

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,450
    Blog Entries
    1

    Default Re: Printer stopped working: Had to downgrade ghostscript

    Quote Originally Posted by gacl View Post
    No. Where do I do that? And how?
    Have a read of this guide...
    https://en.opensuse.org/openSUSE:Submitting_bug_reports

    Submit the bug report here...
    https://bugzilla.opensuse.org/index.cgi
    openSUSE Leap 15.0; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •