Results 1 to 2 of 2

Thread: Tumbleweed 20181211 - libmpfr.so.4 or libmpfr.so.6

  1. #1

    Exclamation Tumbleweed 20181211 - libmpfr.so.4 or libmpfr.so.6

    Hello,

    I want to install geogebra software :
    Code:
    Linux-JP:/home/jpmartin # rpm -ivh geogebra-classic-6.0.513.0-201811291622.x86_64.rpm 
    attention : geogebra-classic-6.0.513.0-201811291622.x86_64.rpm: Entête V4 RSA/SHA1 Signature, clé ID 83a736cf: NOKEY
    erreur : Dépendances requises:
            /usr/lib64/libmpfr.so.4 est nécessaire pour geogebra-classic-6.0.513.0-201811291622.x86_64
    I do a symbolic link libmpfr.so.4 -> libmpfr.so.6 :
    Code:
    Linux-JP:/home/jpmartin # ls /usr/lib64/libmpfr.so.6
    /usr/lib64/libmpfr.so.6
    
    Linux-JP:/home/jpmartin # ls /usr/lib64/libmpfr.so.4
    /usr/lib64/libmpfr.so.4
    
    Linux-JP:/home/jpmartin # ls -l /usr/lib64/libmpfr.so.4
    lrwxrwxrwx 1 root root 12 13 déc.  13:53 /usr/lib64/libmpfr.so.4 -> libmpfr.so.6
    
    Linux-JP:/home/jpmartin # rpm -qa | grep libmpfr
    libmpfr6-4.0.1-3.5.x86_64
    What is the good name libmpfr.so.4 or libmpfr.so.6 ?
    in yast, it is libmpfr.so.4 but install a libmpfr.so.6 ???

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Tumbleweed 20181211 - libmpfr.so.4 or libmpfr.so.6

    Install it from here, instead of from a single downloaded rpm https://software.opensuse.org/package/geogebra
    Or, if you already have the repository active, install it using zypper
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •