Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

  1. #1

    Exclamation Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Hallo zusammen,
    mein erster Post in einem Linux Forum...bitte entschuldigt, wenn ich wesentliche Informationen vielleicht vergesse.
    ich verfolge nun seit anbeginn der Zeiten die Historie von OpenSuse Versionen und habe auch diesmal den Schritt gewagt, auf die Version 15 hochzugehen. Mehr oder weniger gezungendermassen, da durch Installation einer Anwendung (gocr) ein vendor change für einige libs "reingerutscht" ist (das vermeide ich sonst immer). Nach dem Einspielen war keine Bedienung der KDE Oberfläche mehr möglich, auch zurück (zypper/snapper) brachte nicht den Erfolg, sodass ich mich zu dem Update entschloss.
    Jetzt, nach upgrade, stertet KDE nicht mehr:
    Code:
    could not start kdeinit5 check installation
    Dazu gibt es einige Threads, die mich jedoch nicht weiter gebracht haben.
    Und zuvor bei Auswahl des Plasma Desktop
    Code:
    current theme cannot be loaded...
    file.... breeze...cannot load /usr/lib64/qt5/... Qt_5_11 not found
    und auch:
    Code:
    ldd kdeinit5
    bringt
    QT_5_11 not found. In der Tat habe ich nur Qt 5.9.0.
    Ich tippe mal auf eine inkonsistente KDE Umgebung. Alle Analyse-tools (zypper ve, rmp -V, ...) geben mir jedoch keinen Fehler aus.
    Wie muss ich vorgehen? Leider bin ich eher n anderen Themen unterwegs und habe die KDE immer so als stabil laufend hingenommen.
    - deinstallation kde?
    - habe ich (noch) kde4?
    - sollte unter 15 nicht kde5 überall aufleuchten?
    - zusätzliche Installation von libQt5Core5 (und andere) und höherer Version (kann ich mir nicht vorstellen)

    Installation auf einem Wald-und-Wiesen PC, läuft seit 2 Jahren fehlerfrei mit 42.2,43.3.
    ratlos verblebe ich in der Hoffnung auf eine baldige Antwort
    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Hallo, willkommen !!!

    Es schaut sich an, daß du einen Mix hast von mehrere Qt Versionen. Bitte zeig mal
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Ich habe in der Zwischenzeit die drei obenen mit Prio 98 hinzugefügt und einige der KDE Komponenten auf höhere Versionen mit zypper dup gebracht, ohne erfolg.
    die QT Komponenten sind immer noch bei 9.2
    Code:
     1 | KDE_Frameworks5_openSUSE_Leap_15.0 | KDE apps                                | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | https://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_15.0 |
     2 | download.opensuse.org-non-oss      | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                               |
     3 | download.opensuse.org-non-oss_1    | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                                          |
     4 | download.opensuse.org-oss          | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                                   |
     5 | download.opensuse.org-oss_1        | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                                               |
     6 | openSUSE-Leap-15.0-1               | openSUSE-Leap-15.0-1                    | No      | ----      | ----    |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-24F1ST_a_S13A68EF500AC2                             |
     7 | openSUSE_Leap_15.0                 | KQ                                      | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.0                           |
     8 | openSUSE_Leap_15.0_1               | KDE framework                           | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.0                   |
     9 | repo-debug                         | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/                             |
    10 | repo-debug-non-oss                 | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/                         |
    11 | repo-debug-update                  | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/oss/                                        |
    12 | repo-debug-update-non-oss          | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/non-oss/                                    |
    13 | repo-source                        | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/                            |
    14 | repo-source-non-oss                | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/

  4. #4

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    und hier eins meiner Probleme, genauso wie auf dem login screen wird 5.11 verlangt:
    Code:
    ldd /usr/bin/kdeinit5
    /usr/bin/kdeinit5: /usr/lib64/libQt5Core.so.5: version `Qt_5.11' not found (required by /usr/lib64/libKF5WindowSystem.so.5)
    ein Update auf die Version in den neuen Repositories (5.12) traue ich mich (noch) nicht. Zur Zeit arbeite ich mit ICE twm (sehr ungewohnt) und ssh von meinem Win Laptop , um die notwendigen Ausgaben zu kopieren etc, daher bitte Geduld
    Beste Grüße
    Michael

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Quote Originally Posted by michael_10 View Post
    Ich habe in der Zwischenzeit die drei obenen mit Prio 98 hinzugefügt und einige der KDE Komponenten auf höhere Versionen mit zypper dup gebracht, ohne erfolg.
    die QT Komponenten sind immer noch bei 9.2
    Code:
     1 | KDE_Frameworks5_openSUSE_Leap_15.0 | KDE apps                                | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | https://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_15.0 |
     2 | download.opensuse.org-non-oss      | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                               |
     3 | download.opensuse.org-non-oss_1    | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                                          |
     4 | download.opensuse.org-oss          | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                                   |
     5 | download.opensuse.org-oss_1        | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                                               |
     6 | openSUSE-Leap-15.0-1               | openSUSE-Leap-15.0-1                    | No      | ----      | ----    |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-24F1ST_a_S13A68EF500AC2                             |
     7 | openSUSE_Leap_15.0                 | KQ                                      | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.0                           |
     8 | openSUSE_Leap_15.0_1               | KDE framework                           | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.0                   |
     9 | repo-debug                         | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/                             |
    10 | repo-debug-non-oss                 | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/                         |
    11 | repo-debug-update                  | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/oss/                                        |
    12 | repo-debug-update-non-oss          | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/non-oss/                                    |
    13 | repo-source                        | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/                            |
    14 | repo-source-non-oss                | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/
    Ich hab noch niet den Prioritäten geändert, sondern immer "Vendor Switch" benützt. Das kann man von YaST machen, sondern auch von zypper. Also mit obenen Repos:
    Code:
    zypper dup --from 1 7 8
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Hallo!
    Soll ich also auf diese Weise versuchen, auch die Qt Komponenten zu aktualisiern? (zypper dup --from 1 7 8)
    Es kann nur besser werden
    Gruß
    Michael

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Quote Originally Posted by michael_10 View Post
    Hallo!
    Soll ich also auf diese Weise versuchen, auch die Qt Komponenten zu aktualisiern? (zypper dup --from 1 7 8)
    Es kann nur besser werden
    Gruß
    Michael
    Ja, damit sagst du zypper daß die Pakkete aus diese Quellen installiert werden müssen.
    Eine andere Lösung ist, um die Quellen 1, 7 und 8 ab zu schalten, und dann
    Code:
    zypper dup
    zu machen.

    Aber, 'snapper' soll auch funktzionieren wenn es da ein Snapshot gibt von bevor den extra Repos.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Hallo!
    Wir sind einen wesentlichen Schritt weiter: das Login läuft (bis auf ein paar Grafikprobleme, flackern) und auch der Desktop kommt hoch, Thunderbird läßt sich starten...
    Aber jetzt Popup:
    Code:
    KWin is unstable. It seems to have crashed several times in a row. use kwin_X11 ?

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Quote Originally Posted by michael_10 View Post
    Hallo!
    Wir sind einen wesentlichen Schritt weiter: das Login läuft (bis auf ein paar Grafikprobleme, flackern) und auch der Desktop kommt hoch, Thunderbird läßt sich starten...
    Aber jetzt Popup:
    Code:
    KWin is unstable. It seems to have crashed several times in a row. use kwin_X11 ?
    Du benütztest KDE Plasma auf Wayland? Beim Login umschalten auf Plasma, statt Plasma auf Wayland.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Upgrade 42.3 -> 15 kdeinit QT5Core Versionen 5.9 / 5.11

    Ok, es sieht so aus, als ob nun das KDE stabil läuft. Keine Fehlermeldungen.
    Resume:
    - upgrade 42.3 -> 15 mit Standard repositories reicht nicht
    - zusätzliche repos für KDE app, framework & KDE:Qt, zypper dup

    erst dann ein sabiles System.
    Ein einfacher Weg, aber nicht nach Upgrade Dokumentation

    bTW: in ksysguard habe ich drei kwin_X11, zwei davon im Zustand CPU%=stopped. Muss ich mir Sorgen machen?
    Beste Grüße und falls alles jetzt gut läuft vielen Dank für die tolle Unterstützung!!
    Michael

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •