Results 1 to 4 of 4

Thread: VirtualBox wouldn' start

  1. #1
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default VirtualBox wouldn' start

    After I did a forced reboot on my machine as root my OracleVM would not start. I decided to reinstall the pkg downloaded from the virtualbox site and here are my steps:

    sudo zypper install VirtualBox-5.2-5.2.22_126460_openSUSE150-1.x86_64.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by VirtualBox-5.2-5.2.22_126460_openSUSE150-1.x86_64
    Solution 1: do not install VirtualBox-5.2-5.2.22_126460_openSUSE150-1.x86_64
    Solution 2: break VirtualBox-5.2-5.2.22_126460_openSUSE150-1.x86_64 by ignoring some of its dependencies

    IlibQt5Core.so.5(Qt_5.9) has a dependency on

    sudo zypper install libQt5Core5-5.9.4-lp150.4.8.x86_64.rpm
    [sudo] password for root:
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libicui18n.so.60.2()(64bit) needed by libQt5Core5-5.9.4-lp150.4.8.x86_64
    Solution 1: do not install libQt5Core5-5.9.4-lp150.4.8.x86_64
    Solution 2: break libQt5Core5-5.9.4-lp150.4.8.x86_64 by ignoring some of its dependencies
    and I was able to find only libicu60_2-60.2-lp150.1.4.x86_64.rpm which had also a dependency on libicu60_2-60.2-lp150.1.4.x86_64. After installing libicu60_2-ledata-60.2-lp150.1.4.noarch.rpm and libicu60_2-60.2-lp150.1.4.x86_64.rpm
    when trying to install libQt5Core5-5.9.4-lp150.4.8.x86_64.rpm i got this long list of files to replace and I have no ideea how that will affect my os. and that's where i need advice on what to do.

    sudo zypper install libQt5Core5-5.9.4-lp150.4.8.x86_64.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: libqt5-qtwebengine-5.6.2-6.2.x86_64 requires libQt5Core.so.5(Qt_5.6.2_PRIVATE_API)(64bit), but this requirement cannot be provided
    uninstallable providers: libQt5Core5-5.6.2-6.1.x86_64[repo-oss]
    Solution 1: Following actions will be done:
    deinstallation of libqt5-qtwebengine-5.6.2-6.2.x86_64
    deinstallation of kdenlive-18.08.3-15.1.x86_64
    deinstallation of k3b-18.08.3-10.1.x86_64
    deinstallation of k3b-lang-18.08.3-10.1.noarch
    deinstallation of libmlt6-modules-6.10.0-11.2.x86_64
    downgrade of melt-6.10.0-11.2.x86_64 to melt-6.4.1-1.3.x86_64
    install melt-6.4.1-1.3.x86_64 (with vendor change)
    http://packman.links2linux.de --> openSUSE
    deinstallation of libQt5Multimedia5-5.6.2-1.4.x86_64
    deinstallation of libQt5Positioning5-5.6.2-1.4.x86_64
    deinstallation of libQt5Script5-5.6.2-1.18.x86_64
    deinstallation of libQt5Sensors5-5.6.2-1.4.x86_64
    deinstallation of libQt5SerialPort5-5.6.2-1.3.x86_64
    deinstallation of libQt5Svg5-5.6.2-1.4.x86_64
    deinstallation of libQt5WebChannel5-5.6.2-1.3.x86_64
    deinstallation of libQt5WebSockets5-5.6.2-1.3.x86_64
    deinstallation of libQt5XmlPatterns5-5.6.2-1.4.x86_64
    deinstallation of libQtQuick5-5.6.2-2.3.x86_64
    deinstallation of libqt5-linguist-5.6.2-1.23.x86_64
    deinstallation of libQt5DBus5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Gui5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Network5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5OpenGL5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5PrintSupport5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Sql5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Sql5-mysql-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Sql5-sqlite-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Test5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Widgets5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Xml5-5.6.2-7.3.1.x86_64
    deinstallation of libQt5Concurrent5-5.6.2-7.3.1.x86_64
    deinstallation of libKF5Declarative5-5.32.0-1.3.x86_64
    deinstallation of kwin5-5.8.7-2.1.x86_64
    deinstallation of libKF5GlobalAccelPrivate5-5.32.0-2.6.1.x86_64
    deinstallation of libKF5GlobalAccel5-5.32.0-2.6.1.x86_64
    deinstallation of libKF5BluezQt6-5.32.0-2.3.1.x86_64
    deinstallation of konversation-1.7.4-3.1.x86_64
    deinstallation of kmail-17.04.2-3.1.x86_64
    deinstallation of kio-core-5.32.0-5.1.x86_64
    deinstallation of kio-5.32.0-5.1.x86_64
    deinstallation of kdepim-addons-17.04.2-6.1.x86_64
    deinstallation of drkonqi5-5.8.7-11.1.x86_64
    deinstallation of libKScreenLocker5-5.8.7-2.1.x86_64
    deinstallation of libKF5XmlGui5-5.32.0-1.11.x86_64
    deinstallation of libKF5Wallet5-5.32.0-1.3.x86_64
    deinstallation of libKF5Solid5-5.32.0-1.3.x86_64
    deinstallation of libKF5Screen7-5.8.7-1.1.x86_64
    deinstallation of libKF5PimCommonAkonadi5-17.04.2-1.4.x86_64
    deinstallation of libKF5PimCommon5-17.04.2-1.4.x86_64
    deinstallation of libKF5NotifyConfig5-5.32.0-1.3.x86_64
    deinstallation of libKF5Notifications5-5.32.0-1.3.x86_64
    deinstallation of libKF5NetworkManagerQt6-5.32.0-1.3.x86_64
    deinstallation of libKF5ModemManagerQt6-5.32.0-1.1.x86_64
    deinstallation of libKF5MailTransport5-17.04.2-1.1.x86_64
    deinstallation of libKF5MailCommon5-17.04.2-1.1.x86_64
    deinstallation of libKF5LibkdepimAkonadi5-17.04.2-1.1.x86_64
    deinstallation of libKF5KontactInterface5-17.04.2-1.1.x86_64
    deinstallation of libKF5KHtml5-5.32.0-2.1.x86_64
    deinstallation of libKF5KDELibs4Support5-5.32.0-1.23.x86_64
    deinstallation of libKF5KCMUtils5-5.32.0-2.1.x86_64
    deinstallation of libKF5JobWidgets5-5.32.0-1.3.x86_64
    deinstallation of libKF5IncidenceEditor5-17.04.2-1.1.x86_64
    deinstallation of libKF5IdleTime5-5.32.0-1.3.x86_64
    deinstallation of libKF5IdentityManagement5-17.04.2-1.1.x86_64
    deinstallation of libKF5IconThemes5-5.32.0-1.3.x86_64
    deinstallation of libKF5Emoticons5-5.32.0-1.3.x86_64
    deinstallation of libKF5DNSSD5-5.32.0-1.3.x86_64
    deinstallation of libKF5DBusAddons5-5.32.0-1.3.x86_64
    deinstallation of libKF5ConfigWidgets5-5.32.0-1.3.x86_64
    deinstallation of libKF5CompactDisc5-17.04.2-1.1.x86_64
    deinstallation of libKF5Bookmarks5-5.32.0-1.3.x86_64
    deinstallation of libKF5Baloo5-5.32.0-1.3.x86_64
    deinstallation of libKF5Auth5-5.32.0-2.1.x86_64
    deinstallation of libKF5AkonadiWidgets5-17.04.2-1.6.x86_64
    deinstallation of libKF5AkonadiMime5-17.04.2-1.1.x86_64
    deinstallation of libKF5AkonadiCore5-17.04.2-1.6.x86_64
    deinstallation of libKF5AkonadiContact5-17.04.2-1.1.x86_64
    deinstallation of libKF5AkonadiCalendar5-17.04.2-1.1.x86_64
    deinstallation of libKF5AkonadiAgentBase5-17.04.2-1.6.x86_64
    deinstallation of libKF5ActivitiesStats1-5.32.0-1.3.x86_64
    deinstallation of libKF5Activities5-5.32.0-1.3.x86_64
    deinstallation of kwalletmanager5-17.04.2-1.6.x86_64
    deinstallation of kwalletd5-5.32.0-1.3.x86_64
    deinstallation of ktp-accounts-kcm-17.04.2-1.1.x86_64
    deinstallation of ksysguard5-5.8.7-1.12.x86_64
    deinstallation of kservice-5.32.0-1.3.x86_64
    deinstallation of kscreenlocker-5.8.7-2.1.x86_64
    deinstallation of kscreen5-5.8.7-1.1.x86_64
    deinstallation of kpeople5-5.32.0-1.3.x86_64
    deinstallation of korganizer-17.04.2-1.6.x86_64
    deinstallation of kontact-17.04.2-1.6.x86_64
    deinstallation of konsole-part-17.04.2-4.2.x86_64
    deinstallation of knotes-17.04.2-1.1.x86_64
    deinstallation of kmenuedit5-5.8.7-1.12.x86_64
    deinstallation of kmail-account-wizard-17.04.2-1.1.x86_64
    deinstallation of kleopatra-17.04.2-1.6.x86_64
    deinstallation of kio-extras5-17.04.2-2.1.x86_64
    deinstallation of kinit-5.32.0-1.3.x86_64
    deinstallation of kinfocenter5-5.8.7-1.1.x86_64
    deinstallation of khotkeys5-5.8.7-1.12.x86_64
    deinstallation of khelpcenter5-17.04.2-1.6.x86_64
    deinstallation of kgpg-17.04.2-1.6.x86_64
    deinstallation of keditbookmarks-17.04.2-1.1.x86_64
    deinstallation of kdialog-17.04.2-1.1.x86_64
    deinstallation of kdepim-runtime-17.04.2-1.1.x86_64
    deinstallation of kdepim-apps-libs-17.04.2-1.1.x86_64
    deinstallation of kdelibs4support-5.32.0-1.23.x86_64
    deinstallation of kded-5.32.0-1.3.x86_64
    deinstallation of kdeconnect-kde-1.0.3-2.1.x86_64
    deinstallation of kde-user-manager-5.8.7-2.1.x86_64
    deinstallation of kde-print-manager-17.04.2-1.1.x86_64
    deinstallation of kde-cli-tools5-5.8.7-1.1.x86_64
    deinstallation of kdbusaddons-tools-5.32.0-1.3.x86_64
    deinstallation of kate-17.04.2-1.6.x86_64
    deinstallation of kaddressbook-17.04.2-1.1.x86_64
    deinstallation of kactivitymanagerd-5.8.7-2.1.x86_64
    deinstallation of kaccounts-integration-17.04.2-1.1.x86_64
    deinstallation of dragonplayer-17.04.2-1.6.x86_64
    deinstallation of dolphin-part-17.04.2-4.1.x86_64
    deinstallation of dolphin-17.04.2-4.1.x86_64
    deinstallation of breeze5-style-5.8.7-2.1.x86_64
    deinstallation of breeze5-decoration-5.8.7-2.1.x86_64
    deinstallation of bluedevil5-5.8.7-1.1.x86_64
    deinstallation of baloo5-kioslaves-5.32.0-1.3.x86_64
    deinstallation of baloo5-imports-5.32.0-1.3.x86_64
    deinstallation of baloo5-file-5.32.0-1.3.x86_64
    deinstallation of ark-17.04.2-1.6.x86_64
    deinstallation of akregator-17.04.2-2.1.x86_64
    deinstallation of akonadi-server-17.04.2-1.6.x86_64
    deinstallation of akonadi-search-17.04.2-1.1.x86_64
    deinstallation of akonadi-calendar-tools-17.04.2-1.6.x86_64
    deinstallation of ktexteditor-5.32.0-3.2.x86_64
    deinstallation of kmozillahelper-5.0.2-3.1.x86_64
    deinstallation of kglobalaccel5-5.32.0-2.6.1.x86_64
    deinstallation of libQt5DesignerComponents5-5.6.2-1.23.x86_64
    deinstallation of libQt5Designer5-5.6.2-1.23.x86_64
    deinstallation of libKPimKDAV5-17.04.2-1.1.x86_64
    deinstallation of libKPimGAPICore5-17.04.2-1.1.x86_64
    deinstallation of libKPimGAPIContacts5-17.04.2-1.1.x86_64
    deinstallation of libKPimGAPICalendar5-17.04.2-1.1.x86_64
    deinstallation of libKGantt2-2.6.0-1.1.x86_64
    deinstallation of libKF5WindowSystem5-5.32.0-1.3.x86_64
    deinstallation of libKF5WidgetsAddons5-5.32.0-3.1.x86_64
    deinstallation of libKF5TextWidgets5-5.32.0-1.3.x86_64
    deinstallation of libKF5SyntaxHighlighting5-5.32.0-1.18.x86_64
    deinstallation of libKF5Style5-5.32.0-1.1.x86_64
    deinstallation of libKF5SonnetUi5-5.32.0-1.19.x86_64
    deinstallation of libKF5Sane5-17.04.2-1.1.x86_64
    deinstallation of libKF5Runner5-5.32.0-1.3.x86_64
    deinstallation of libKF5QuickAddons5-5.32.0-1.3.x86_64
    deinstallation of libKF5Prison5-5.32.0-1.3.x86_64
    deinstallation of libKF5PimTextEdit5-17.04.2-1.6.x86_64
    deinstallation of libKF5Parts5-5.32.0-1.3.x86_64
    sorry for the detailed info and i would appreciate any input. Please let me know if there is anything else needed. Note - I had to remove about half of the libraries listed for Qt5 because the size.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,462

    Default AW: VirtualBox wouldn' start

    Why not the one from the OSS Repo:
    Code:
    zypper in virtualbox
    Problem: nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by VirtualBox-5.2-5.2.22_126460_openSUSE150-1.x86_64
    But your System seems to have QT 5.6........

    So is it a Leap 15.0?
    Code:
    lsb-release -id
    Last edited by Sauerland; 12-Dec-2018 at 23:03.

  3. #3
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: VirtualBox wouldn' start

    sorry for using QUOTE tags instead of CODE tags.
    Code:
    lsb-release -id
    Distributor ID: openSUSE Leap
    Description:    openSUSE Leap 42.3
    i tried to install it from yast but the search gave me nothing for VirtualBox(?). now with your suggestion of using zypper i installed it but i will need to get myself into vboxusers group. I will comment if encounter any issues but most probably it will be fine.
    I tried few times to upgrade some VM's as a test from 42.3 to 15.0 by changing the repositories w/o success and I didn't upgrade my main system. Fresh install was always successful. I'm hesitant to do a fresh install even though I know i have lots of garbage carried from version to version since probably 9.1
    Thank you for your time and advice Sauerland

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,462

    Default AW: VirtualBox wouldn' start

    You have downloaded the wrong openSUSE Version of Virtualbox.......

    And in Linux Virtualbox and virtualbox are not the same........
    Linux is different on case sensitiv letters.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •