Results 1 to 7 of 7

Thread: gedit very slow (30 seconds+) to start

  1. #1
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default gedit very slow (30 seconds+) to start

    Leap15, x64 fully updated, and gedit is taking about 30 seconds to appear, when just opening the app, no other files involved.
    When started from terminal, receive these errors:

    Code:
    john@boss:~> gedit
    Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key
    ** (gedit:7638): WARNING **: AT-SPI: Could not obtain desktop path or name
    Invalid MIT-MAGIC-COOKIE-1 key
    ** (gedit:7638): WARNING **: atk-bridge: get_device_events_reply: unknown signature
    ** (gedit:7638): WARNING **: atk-bridge: get_device_events_reply: unknown signature
    ** (gedit:7638): WARNING **: atk-bridge: GetRegisteredEvents returned message with unknown signature
    ** (gedit:7638): WARNING **: AT-SPI: Could not obtain desktop path or name
    ** (gedit:7638): WARNING **: AT-SPI: Could not obtain desktop path or name
    ** (gedit:7638): WARNING **: AT-SPI: Could not obtain desktop path or name
    Anyone have any ideas?
    Have tried searching, and nothing obvious...

    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  2. #2
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: gedit very slow (30 seconds+) to start

    Update:
    Had previously tried resetting config files etc, but nothing had worked.
    As my default DE is Plasma, I logged out and logged in to Gnome, and tested gedit - all OK.
    After logging out of Gnome and back in to Plasma, all is working OK again - gedit opens almost immediately...
    Dunno...
    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  3. #3
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: gedit very slow (30 seconds+) to start

    Take it all back.
    On a reboot, I am back to starting very slow.
    By the looks of it, the trick to start Gnome, only works for the current session.
    Any ideas?
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: gedit very slow (30 seconds+) to start

    Quote Originally Posted by hornetster View Post
    Take it all back.
    On a reboot, I am back to starting very slow.
    By the looks of it, the trick to start Gnome, only works for the current session.
    Any ideas?
    Hi
    I don't use Plasma, but wonder if your running Wayland? Maybe try Xorg and see if it works better?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: gedit very slow (30 seconds+) to start

    Just out of interest, does it change anything if you boot an older kernel?

    I ask this, because I had "firefox" slow starting, and it was a problem with kernel 4.12.14-lp150.12.25-default.

    To boot with an older kernel, used the "Advanced options" line in the grub2 menu.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,846
    Blog Entries
    14

    Default Re: gedit very slow (30 seconds+) to start

    Any reason for wanting gedit on Plasma? Did you ever look at Kate?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: gedit very slow (30 seconds+) to start

    Quote Originally Posted by Knurpht View Post
    Any reason for wanting gedit on Plasma? Did you ever look at Kate?
    Gedit just seems to be quick/low resources, etc, and also have used for ages...
    Otherwise, no reason...
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •