Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: After resume from suspend NFS is no longer mounted

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,717
    Blog Entries
    1

    Default Re: After resume from suspend NFS is no longer mounted

    A bug report might be needed here.
    Last edited by deano_ferrari; 24-Dec-2018 at 12:28.
    openSUSE Leap 15.0; KDE Plasma 5

  2. #12

    Default Re: After resume from suspend NFS is no longer mounted

    Was there any resolution to this?
    I have recently built a workstation (opensuse TW) as a frontend to a mediaserver.

    I have the a similar fstab entry, which works for my Fedora workstations, connecting to the same media server.
    When the system resumes from suspend, the nfs shares are not connected.
    When the system resumes from suspend, the nfs shares are the only missing shares.

    Code:
    dubserv:/storage/share                     /storage/share          nfs    defaults                      0  0
    dubserv:/storage/workshop                  /storage/workshop       nfs    defaults                      0  0
    Any insight is appreciated
    -Cyril

    Quote Originally Posted by payamf View Post
    Recently after I suspend my Tumbleweed machine and then resume from suspend, my NAS NFS is no longer mounted. Here is the fstab entry:
    DiskStation:/volume1 /mnt/DiskStation nfs defaults 0 0

    When I issue the mount command, the only difference between the output of pre-suspend and post-resume is this one line:
    DiskStation:/volume1 on /mnt/DiskStation type nfs4 (rw,relatime,vers=4.0,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.43,local_lock=none,addr=192.168.1.112)

    'sudo mount -a' fixes the issue.

    Where can I look for clues as to what is happening? I have done a 'zypper dup' and am at the 2018-12-05 release.


    Thanks.


  3. #13

    Default Re: After resume from suspend NFS is no longer mounted

    I have better results just from appending x-systemd.automount to the mount options.
    It isn't obvious whether x-systemd.requires=network-online.target will properly replace the _netdev option, but I will later see what affect it has on boot, shutdown, and resume.

    Code:
    dubserv:/storage/share                     /storage/share          nfs    defaults,x-systemd.automount                      0  0
    dubserv:/storage/workshop                  /storage/workshop       nfs    defaults,x-systemd.automount                      0  0
    Quote Originally Posted by payamf View Post
    Following Per Jessen's suggestion for using systemd automount worked perfectly. As soon as I hit the power button to come out of suspend, I could hear the NAS disk start to spin up and the directories were mounted as expected.

    My fstab entry now looks like this
    Code:
    DiskStation:/volume1  /mnt/DiskStation  nfs  x-systemd.automount,x-systemd.idle-timeout=300,_netdev 0 0
    
    [ ... ]
    ref: https://wiki.archlinux.org/index.php...b_with_systemd

  4. #14

    Default Re: After resume from suspend NFS is no longer mounted

    Well, the resolution for me was that the issue disappeared as mysteriously as it appeared. I did some more experiments. I ended up with an fstab entry like this:
    Code:
    DiskStation:/volume1     /mnt/DiskStation  nfs  x-systemd.automount,x-systemd.idle-timeout=120,_netdev,nfsvers=4.0 0  0
    The reason I added the nfsvers option was that when did a mount -a -v it showed that mount was negotiating down from 4.2 and finally settling on 4.0. But that did not make a difference. nfs mount still would not mount after resume. I even did a re-install of the latest Tumbleweed. But after some while I noticed that the problem had gone away. I decided to leave well enough alone and never went back to the old fstab entry.

    Quote Originally Posted by cyri1 View Post
    I have better results just from appending x-systemd.automount to the mount options.
    It isn't obvious whether x-systemd.requires=network-online.target will properly replace the _netdev option, but I will later see what affect it has on boot, shutdown, and resume.

    Code:
    dubserv:/storage/share                     /storage/share          nfs    defaults,x-systemd.automount                      0  0
    dubserv:/storage/workshop                  /storage/workshop       nfs    defaults,x-systemd.automount                      0  0


    ref: https://wiki.archlinux.org/index.php...b_with_systemd

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •