Results 1 to 3 of 3

Thread: libusb-devel question

  1. #1

    Default libusb-devel question

    yeap its me again, theres a lot going on right now with this fresh TW install. I need the libusb-devel library (need to find the /etc/udev/rules.d to be able to install and use the Xilinx usb 2 plataform).Why? beacuse this device is not recognize at first and I need to edit and compile a driver for this device. Here is the problem, I cant find the libusb-devel library ( I checked yast2 and I already have installed libusb-1_0-devel) and when I tried to compile driver the usb.h error shows up.
    questions:
    1)Where can I find libusb-devel? Did it change name?
    2)if I have installed libusb-1_0-devel, why I have the usb.h error?

    Thanks for your help.
    Reagrds

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,000
    Blog Entries
    15

    Default Re: libusb-devel question

    Quote Originally Posted by Gaston1980 View Post
    yeap its me again, theres a lot going on right now with this fresh TW install. I need the libusb-devel library (need to find the /etc/udev/rules.d to be able to install and use the Xilinx usb 2 plataform).Why? beacuse this device is not recognize at first and I need to edit and compile a driver for this device. Here is the problem, I cant find the libusb-devel library ( I checked yast2 and I already have installed libusb-1_0-devel) and when I tried to compile driver the usb.h error shows up.
    questions:
    1)Where can I find libusb-devel? Did it change name?
    2)if I have installed libusb-1_0-devel, why I have the usb.h error?

    Thanks for your help.
    Reagrds
    Hi
    How is it checking for libusb development, if it's using pkgconfig then it should find it, else you going to have to patch the files that look for it to;

    Code:
    libusb-1.0/usb.h
    Else install libusb-compat-devel which is libusb-1.0 Compatibility Layer for libusb-0.1, best to look at the file descriptions as they should point to the correct package you need, I think this solution should sort it
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: libusb-devel question

    thanks for your answer. No problem so far.
    Regards
    Gastón

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •