I'm running Tumbleweed with the current Qt Creator (4.7.1) and Qt (5.11.2). When I run a project that emits debug output (such as
in QML or
qDebug() << "..."
in C++) in Qt Creator, it does not show in the "Application Output" pane. Output from C++'s "cout" and (surprisingly) "cerr" do show. If I select "run in terminal" in the project's run configuration, it shows a terminal and does display the debug output. If I run the project's executable in a new Konsole window, it also will display this output. If I use a different version of Qt I have installed from Qt to build the project, I see the debug output. Finally, if I start Qt Creator from a Konsole window (running "qtcreator" on the command line) instead of clicking it in the application menu, I also see the debug output.

First of all, can anyone else confirm this behavior, or is there something unique going on with my system? I will note that some time in the past this did work, but I also re-installed Tumbleweed from scratch recently on a new hard drive. This is not related to qtlogging.ini (as in a similar issue in Red Hat https://bugzilla.redhat.com/show_bug.cgi?id=1227295); I have created that file in ~/.config/QtProject to no effect and there is no such file in /etc/xdg/QtProject or /usr/share/qt5.

Second of all, there are several bug "discussions" I have found (including https://bugreports.qt.io/browse/QTBUG-66153 and https://bugreports.qt.io/browse/QTCREATORBUG-12564) about this. The second one especially may apply as it looks like Tumbleweed is building Qt with the "-journald" option like ArchLinux is as discussed in the second bug. But the bugs I am finding are closed, either "fixed" or out of scope. Is this something I should report on OpenSUSE Bugzilla, or should I just add some information to those upstream bugs and try to swim against the current there?