Results 1 to 3 of 3

Thread: Компиляция Virtualbox под SLES12SP3 с ошибками

  1. #1

    Default Компиляция Virtualbox под SLES12SP3 с ошибками

    Компилирую Virtualbox под SLES12SP3 со spec файлом взятым отсюда: https://download.opensuse.org/update...2-63.1.src.rpm
    При компиляции выходят ошибки:
    # rpmbuild -ba /usr/src/packages/SPECS/virtualbox.spec
    error: Failed build dependencies:
    xorg-x11-libX11-devel-32bit is needed by virtualbox-5.2.22-63.1.x86_64
    xorg-x11-libXext-devel-32bit is needed by virtualbox-5.2.22-63.1.x86_64
    xorg-x11-libXmu-devel-32bit is needed by virtualbox-5.2.22-63.1.x86_64
    xorg-x11-libXt-devel-32bit is needed by virtualbox-5.2.22-63.1.x86_64
    Предполагаю, что пакеты переименованы в:

    libX11-devel-32bit
    libXext-devel-32bit
    libXmu-devel-32bit
    libXt-devel-32bit


    Вопрос, верно ли мое предположение? Где их можно найти? И почему в спек файле их (xorg-x11-libX11-devel-32bit, xorg-x11-libXext-devel-32bit, xorg-x11-libXmu-devel-32bit, xorg-x11-libXt-devel-32bit) таскают уже несколько лет?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Компиляция Virtualbox под SLES12SP3 с ошибками

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,001
    Blog Entries
    1

    Default Re: Компиляция Virtualbox под SLES12SP3 с ошибками

    Компилирую Virtualbox под SLES12SP3
    Это не openSUSE. Может быть разница.

    В openSUSE:
    Code:
    % zypper se --provides xorg-x11-libX11-devel-32bit
    
    С | Имя                | Заключение                                              | Тип  
    --+--------------------+---------------------------------------------------------+------
      | libX11-devel-32bit | Файлы разработки для библиотеки основного протокола X11 | пакет

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •