I have been hacking at this a bit with no success, time to seek some help.

My HP laptop has internal 2.4 band wifi, which appears as wlan0.
It has been acting flaky for a while, plus I would like to add 5G band capability.
Hence I acquired a dual band usb dongle that uses the rtl8812au device.

My laptop is running Leap 15.0
Code:
carl@HPDV7-Linux:~> uname -a                                                                                                        
Linux HPDV7-Linux.capenet 4.12.14-lp150.12.25-default #1 SMP Thu Nov 1 06:14:23 UTC 2018 (3fcf457) x86_64 x86_64 x86_64 GNU/Linux
I have the Hardware Repo enabled and have downloaded and installed what appeared to be the correct driver package
Code:
 
rtl8812au-kmp-default - Kernel driver for Realtek 802.11ac rtl8812au wifi cards
Alternate Version Installed Version
Version: 5.2.20.2_k4.12.14_lp150.12.25-lp150.8.14 5.2.20.2_k4.12.14_lp150.12.25-lp150.8.14
Build Time: Thu 29 Nov 2018 04:06:48 PM EST Thu 29 Nov 2018 04:06:48 PM EST
Install Time: Sat 01 Dec 2018 09:55:33 AM EST
Package Group: System/Kernel System/Kernel
License: GPL-2.0-only GPL-2.0-only
Installed Size: 3.3 MiB 3.3 MiB
Download Size: 567.5 KiB 0 B
Distribution: hardware / openSUSE_Leap_15.0
Vendor: obs://build.opensuse.org/hardware obs://build.opensuse.org/hardware
Packager:
Architecture: x86_64 x86_64
Build Host:
URL: https://github.com/gordboy/rtl8812au https://github.com/gordboy/rtl8812au
Source Package: rtl8812au-5.2.20.2-lp150.8.14 rtl8812au-5.2.20.2-lp150.8.14
Media No.: 1
Authors:
After install, I ran
Code:
carl@HPDV7-Linux:~> sudo modprobe 8812au   
carl@HPDV7-Linux:~> lsmod |grep 8812       
8812au               1634304  0
cfg80211              696320  4 8812au,iwlwifi,mac80211,iwldvm
usbcore               286720  7 8812au,uvcvideo,ehci_hcd,xhci_pci,btusb,xhci_hcd,ehci_pci
carl@HPDV7-Linux:~> sudo depmod -a
carl@HPDV7-Linux:~> usb-devices            
                                                                                                                                    
..........
T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  4 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0bda ProdID=c811 Rev=02.00
S:  Manufacturer=Realtek
S:  Product=802.11ac NIC
S:  SerialNumber=123456
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 5 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
So USB seems to have established the physical connection but the driver is not attached to it.

With the driver not attached, I am not surprised to see that only the existing PCI connected hardware appears
Code:
sudo iw dev                                                                                                     
[sudo] password for root:                                                                                                           
phy#0                                                                                                                               
        Interface wlan0                                                                                                             
                ifindex 3                                                                                                           
                wdev 0x1                                                                                                            
                addr 84:a6:c8:fa:9a:24                                                                                              
                type managed                                                                                                        
                txpower 16.00 dBm
Is there some additional magic I need to implement?
I have scoured the Forum and Googled a lot, sort of difficult to determine what applies these days, much of the discussion is rather dated.

Do I need to disable the existing wifi hardware first?

Thanks in advance