Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Trying to build the latest icecat package, having an issue with a dependency so far...

  1. #1

    Question Trying to build the latest icecat package, having an issue with a dependency so far...

    Code:
    conflict for providers of openssl(cli) needed by ca-certificates, (provider openssl-1_0_0 conflicts with openssl), (provider openssl-1_1 conflicts with openssl), have choice for pkgconfig(openssl) >= 1.1.0: libopenssl-1_1-devel libressl-devel
    I have tried adding:
    Code:
    BuildRequires: pkgconfig(openssl) >= 1.1.0
    to fix it, but I am rather inexperienced on how to fix this exact error.

    Any help would be greatly appreciated. Thanks in advance.

    https://build.opensuse.org/package/s...st:misc/icecat

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,693
    Blog Entries
    15

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    Quote Originally Posted by ryanbach View Post
    Code:
    conflict for providers of openssl(cli) needed by ca-certificates, (provider openssl-1_0_0 conflicts with openssl), (provider openssl-1_1 conflicts with openssl), have choice for pkgconfig(openssl) >= 1.1.0: libopenssl-1_1-devel libressl-devel
    I have tried adding:
    Code:
    BuildRequires: pkgconfig(openssl) >= 1.1.0
    to fix it, but I am rather inexperienced on how to fix this exact error.

    Any help would be greatly appreciated. Thanks in advance.

    https://build.opensuse.org/package/s...st:misc/icecat
    Hi
    Change to libopenssl-devel and see how that goes.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,693
    Blog Entries
    15

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    Hi
    Another thought, since your just building for Tumbleweed, just use pkgconfig(libopenssl) with no version requirement....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    nothing provides pkgconfig(libopenssl)

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,693
    Blog Entries
    15

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    Quote Originally Posted by ryanbach View Post
    nothing provides pkgconfig(libopenssl)
    Hi
    Looks like openssl then;
    https://build.opensuse.org/package/b...1.1.noarch.rpm

    Nothing under the libopenssl pkgconfig...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Looks like openssl then;
    https://build.opensuse.org/package/b...1.1.noarch.rpm

    Nothing under the libopenssl pkgconfig...
    Tried pkgconfig(openssl)

    I get:

    conflict for providers of openssl(cli) needed by ca-certificates, (provider openssl-1_0_0 conflicts with openssl), (provider openssl-1_1 conflicts with openssl)

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,693
    Blog Entries
    15

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    Quote Originally Posted by ryanbach View Post
    Tried pkgconfig(openssl)

    I get:

    conflict for providers of openssl(cli) needed by ca-certificates, (provider openssl-1_0_0 conflicts with openssl), (provider openssl-1_1 conflicts with openssl)
    Hi
    Dang!

    pkgconfig(openssl) >= 1.1.0h
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Sep 2012
    Posts
    5,914

    Default Re: Trying to build the latest icecat package, having an issue with a dependency so far...

    pkgconfig is provided by devel packages while error clearly points to normal binary package. I do not see any conflict between openssl and openssl-1_1 on TW - actually, openssl is dummy package. My TW have both openssl and openssl-1_1 (which indeed provided openssl(cli)). May be you have some non-standard version of openssl.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,693
    Blog Entries
    15

    Default Re: Trying to build the latest icecat package, having an issue witha dependency so far...

    On Sat 01 Dec 2018 09:16:04 PM CST, arvidjaar wrote:


    pkgconfig is provided by devel packages while error clearly points to
    normal binary package. I do not see any conflict between openssl and
    openssl-1_1 on TW - actually, openssl is dummy package. My TW have both
    openssl and openssl-1_1 (which indeed provided openssl(cli)). May be you
    have some non-standard version of openssl.


    Hi
    That would appear to be so, it's linked to another project which has an
    old openssl...

    @ryanbach break the link and just use copypac to put it elswhere.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10

    Default Re: Trying to build the latest icecat package, having an issue witha dependency so far...

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That would appear to be so, it's linked to another project which has an
    old openssl...

    @ryanbach break the link and just use copypac to put it elswhere.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    Well I removed the .link from the project but I don't know what I should put in osc, I tried:

    osc copypac home:ryanbach:branches:home:Ledest:misc home:ryanbach:branches:home:browser icecat
    Server returned an error: HTTP Error 404: Not Found


    Could someone give me an example that I could copy paste, so I could learn; I am a bit new.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •